Error when setting up on debian

I’m trying to get request-tracker running on a debian system (mostly stable,
but I’ve grabbed 2.0.14 from testing). I’ve followed the instructions in
the README.Debian file, through running

cd /usr/share/request-tracker/postinstall

tools/initdb mysql /usr “” “” root rt create

tools/initdb mysql /usr “” “” root rt insert

the next step is tools/insertdata which is where I get the error:

DBI->connect(dbname=rt) failed: Access denied for user: ‘rt@localhost’
(Using password: YES) at /usr/share/perl5/DBIx/SearchBuilder/Handle.pm line
119
Connect Failed Access denied for user: ‘rt@localhost’ (Using password: YES)
at tools/insertdata line 27

I don’t know mysql, so I’m just trying to follow the instructions. Anyone
know where to proceed from here? The lines from
/etc/request-tracker/config.pm that seem relevant are:

{{{ Base Configuration

$rtname the string that RT will look for in mail messages to

figure out what ticket a new piece of mail belongs to

Your domain name is recommended, so as not to pollute the namespace.

once you start using a given tag, you should probably never change it.

(otherwise, mail for existing tickets won’t get put in the right place

$rtname=“lakeland”;

You should set this to your organization’s DNS domain. For example,

fsck.com or asylum.arkham.ma.us. It’s used by the linking interface to

guarantee that ticket URIs are unique and easy to construct.

$Organization = “lakelandleather.co.uk”;

$user_passwd_min defines the minimum length for user passwords. Setting

it to 0 disables this check

$MinimumPasswordLength = “5”;

$Timezone is used to convert times entered by users into GMT and back

again

It should be set to a timezone recognized by your local unix box.

$Timezone = ‘Europe/London’;

LogDir is where RT writes its logfiles.

This directory should be writable by your rt group

$LogDir = “/var/log/request-tracker”;

}}}

{{{ Database Configuration

Database driver being used - i.e. mysql, oracle, Pg

$DatabaseType=“mysql”;

The domain name of your database server

If you’re running mysql and it’s on localhost,

leave it blank for enhanced performance

$DatabaseHost="";

The port that your database server is running on. Ignored unless it’s

a positive integer. It’s usually safe to leave this blank

$DatabasePort="";

#The name of the database user (inside the database)
$DatabaseUser=‘rt’;

Password the DatabaseUser should use to access the database

$DatabasePassword=‘rtpass’;

The name of the RT’s database on your database server

$DatabaseName=‘rt’;

If you’re using Postgres and have compiled in SSL support,

set DatabaseRequireSSL to 1 to turn on SSL communication

$DatabaseRequireSSL=undef;

}}}

Is there anything else you’d need to know? Thanks in advance!

Randy Orrison

Randy Orrison
IT & Project Manager
Lakeland Properties Ltd