Error when adding user to RT 4 (email exists)

Hello All

I’ve tried to add a person in our RT, but it says “email already in use”, and doesn’t let me create the new user.I query everything I can find, but nothing comes up.

Obviously this is a user who doesn’t have an account yet, but was included in one of the ticket emails. However, I’m unclear how to run a query for a “non privileged” user. (And the RT Essentials book doesn’t reveal how because it’s for a much older version).

Any ideas how I might resolve this issue?

Thank you!

Rick

Thanks. Unfortunately there is nothing like that in the latest RT version. Plus, this is an unprivileged user, so it probably wouldn’t show up anyway. Not sure.

Strange though that I just can’t get beyond this issue…

Thanks!On Jul 23, 2013, at 05:16 PM, “Beachey, Kendric” Kendric.Beachey@garmin.com wrote:

Hi Rick,

It’s possible things have changed since the version of RT we’re running (3.6.5) but I do searches like this from the web interface, with the magic box checked…

<image001.png>
HTH,

Kendric Beachey

From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of window camera
Sent: Tuesday, July 23, 2013 3:58 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error when adding user to RT 4 (email exists)

Hello All

I’ve tried to add a person in our RT, but it says “email already in use”, and doesn’t let me create the new user.I query everything I can find, but nothing comes up.

Obviously this is a user who doesn’t have an account yet, but was included in one of the ticket emails. However, I’m unclear how to run a query for a “non privileged” user. (And the RT Essentials book doesn’t reveal how because it’s for a much older version).

Any ideas how I might resolve this issue?

Thank you!

Rick

CONFIDENTIALITY NOTICE: This email and any attachments are for the sole use of the intended recipient(s) and contain information that may be confidential and/or legally privileged. If you have received this email in error, please notify the sender by reply email and delete the message. Any disclosure, copying, distribution or use of this communication (including attachments) by someone other than the intended recipient is prohibited. Thank you.

Hi Rick,

It’s possible things have changed since the version of RT we’re running (3.6.5) but I do searches like this from the web interface, with the magic box checked…

[rt.search.for.disabled.users.png]
HTH,

Kendric BeacheyFrom: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of window camera
Sent: Tuesday, July 23, 2013 3:58 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error when adding user to RT 4 (email exists)

Hello All

I’ve tried to add a person in our RT, but it says “email already in use”, and doesn’t let me create the new user.I query everything I can find, but nothing comes up.

Obviously this is a user who doesn’t have an account yet, but was included in one of the ticket emails. However, I’m unclear how to run a query for a “non privileged” user. (And the RT Essentials book doesn’t reveal how because it’s for a much older version).

Any ideas how I might resolve this issue?

Thank you!

Rick

CONFIDENTIALITY NOTICE: This email and any attachments are for the sole use of the intended recipient(s) and contain information that may be confidential and/or legally privileged. If you have received this email in error, please notify the sender by reply email and delete the message. Any disclosure, copying, distribution or use of this communication (including attachments) by someone other than the intended recipient is prohibited. Thank you.

Thanks. Unfortunately there is nothing like that in the latest RT
version. Plus, this is an unprivileged user, so it probably wouldn’t
show up anyway. Not sure.

Tools -> Configuration -> Users

The search form shows up there.

Unprivileged users are shown in user searches, but not when you first
load the page (since there are often thousands of unprivileged users).

Thanks Thomas. This worked for me. (I’m a newbie, so just learning the ropes.)

RickOn Jul 23, 2013, at 05:43 PM, Thomas Sibley trs@bestpractical.com wrote:

On 07/23/2013 02:31 PM, window camera wrote:
Thanks. Unfortunately there is nothing like that in the latest RT
version. Plus, this is an unprivileged user, so it probably wouldn’t
show up anyway. Not sure.

Tools → Configuration → Users

The search form shows up there.

Unprivileged users are shown in user searches, but not when you first
load the page (since there are often thousands of unprivileged users).

Obviously this is a user who doesn’t have an account yet, but was
included in one of the ticket emails. However, I’m unclear how to run a
query for a “non privileged” user.

The search by name box in Tools->Configuration->Users->Select accepts
SQL wildcards. So you can search for:

%

to find all users.

It’s always struck me as very weird that the user browser does not
provide an “include unprivileged users” checkbox, like the “include
disabled users” checkbox.

Any ideas how I might resolve this issue?

Searching for the user by email address should find them. If not, try a
wildcard.

Craig Ringer http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services