Error trying to create a new user on new 3.8.1 install

When I try to create a new user on a fresh 3.8.1 install, I get this
message when I click on “create”:

Can’t call method “Disabled” on an undefined value at
/opt/rt3/bin/…/lib/RT/User_Overlay.pm line 1098.

Im not sure what the error means, I haven’t modified Modify.html or
User_Overlay.pm at all. Thanks in advance for any help.

Sean McCreadie

IT Support

Canyon Partners, LLC

310 272 1764

Also, when I look at messages log it has this error every time I click
on create:

“RT: Couldn’t get principal for not loaded object
(/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1113)”

Anybody have any ideas? I got my fresh install working great except for
this show stopper. Thanks again for any insight.

Sean

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Sean
McCreadieSent: Saturday, October 18, 2008 2:03 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error trying to create a new user on new 3.8.1
install

When I try to create a new user on a fresh 3.8.1 install, I get this
message when I click on “create”:

Can’t call method “Disabled” on an undefined value at
/opt/rt3/bin/…/lib/RT/User_Overlay.pm line 1098.

Im not sure what the error means, I haven’t modified Modify.html or
User_Overlay.pm at all. Thanks in advance for any help.

Sean McCreadie

IT Support

Canyon Partners, LLC

310 272 1764

Sean,

What autorization extensions are you using in your RT_SiteConfig.pm 

settings?

Kenn
LBNLOn 10/20/2008 12:25 PM, Sean McCreadie wrote:

Also, when I look at messages log it has this error every time I click
on create:

�RT: Couldn’t get principal for not loaded object
(/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1113)�

Anybody have any ideas? I got my fresh install working great except for
this show stopper. Thanks again for any insight.

Sean

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] *On Behalf Of *Sean
McCreadie
Sent: Saturday, October 18, 2008 2:03 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error trying to create a new user on new 3.8.1 install

When I try to create a new user on a fresh 3.8.1 install, I get this
message when I click on �create�:

Can’t call method “Disabled” on an undefined value at
/opt/rt3/bin/…/lib/RT/User_Overlay.pm line 1098.

Im not sure what the error means, I haven�t modified Modify.html or
User_Overlay.pm at all. Thanks in advance for any help.

Sean McCreadie

IT Support

Canyon Partners, LLC

310 272 1764



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Kenn,

I have aded RTFM, and RTx-Calendar (which ive used before with no
problems), but I did just add TicketLocking extension to my new build
because it looks like something we could use. Should I disable them in
RT_Siteconfig to test? Thanks for the quick response.
SeanFrom: Kenneth Crocker [mailto:KFCrocker@lbl.gov]
Sent: Monday, October 20, 2008 12:32 PM
To: Sean McCreadie
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Error trying to create a new user on new 3.8.1
install

Sean,

What autorization extensions are you using in your

RT_SiteConfig.pm
settings?

Kenn
LBNL

Also, when I look at messages log it has this error every time I click

on create:

“RT: Couldn’t get principal for not loaded object
(/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1113)”

Anybody have any ideas? I got my fresh install working great except
for
this show stopper. Thanks again for any insight.

Sean

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] *On Behalf Of *Sean
McCreadie
Sent: Saturday, October 18, 2008 2:03 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error trying to create a new user on new 3.8.1
install

When I try to create a new user on a fresh 3.8.1 install, I get this
message when I click on “create”:

Can’t call method “Disabled” on an undefined value at
/opt/rt3/bin/…/lib/RT/User_Overlay.pm line 1098.

Im not sure what the error means, I haven’t modified Modify.html or
User_Overlay.pm at all. Thanks in advance for any help.

Sean McCreadie

IT Support

Canyon Partners, LLC

310 272 1764


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Sean,

I was thinking more along the lines of the problem I had when I tried 

to add a new user and the LDAP authorization setting was on, ergo not
allowing me to do so since I could not sign on using their LDAP. I don’t
using ticket locking or whatever. I’d have to look at it to see if that
is also a reasonable cause. Sorry.

Kenn
LBNLOn 10/20/2008 12:36 PM, Sean McCreadie wrote:

Kenn,

I have aded RTFM, and RTx-Calendar (which ive used before with no
problems), but I did just add TicketLocking extension to my new build
because it looks like something we could use. Should I disable them in
RT_Siteconfig to test? Thanks for the quick response.
Sean

-----Original Message-----
From: Kenneth Crocker [mailto:KFCrocker@lbl.gov]
Sent: Monday, October 20, 2008 12:32 PM
To: Sean McCreadie
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Error trying to create a new user on new 3.8.1
install

Sean,

What autorization extensions are you using in your
RT_SiteConfig.pm
settings?

Kenn
LBNL

On 10/20/2008 12:25 PM, Sean McCreadie wrote:

Also, when I look at messages log it has this error every time I click

on create:

“RT: Couldn’t get principal for not loaded object
(/opt/rt3/bin/…/lib/RT/User_Overlay.pm:1113)”

Anybody have any ideas? I got my fresh install working great except
for
this show stopper. Thanks again for any insight.

Sean

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] *On Behalf Of *Sean
McCreadie
Sent: Saturday, October 18, 2008 2:03 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Error trying to create a new user on new 3.8.1
install

When I try to create a new user on a fresh 3.8.1 install, I get this
message when I click on “create”:

Can’t call method “Disabled” on an undefined value at
/opt/rt3/bin/…/lib/RT/User_Overlay.pm line 1098.

Im not sure what the error means, I haven’t modified Modify.html or
User_Overlay.pm at all. Thanks in advance for any help.

Sean McCreadie

IT Support

Canyon Partners, LLC

310 272 1764



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com