Error Starting httpd service

Hi Guys,

I managed to go through the whole installation guide…
Now , I try to run >>service httpds start , I get the following error.

Any Ideas

Starting httpd: Syntax error on line 2 of
/etc/httpd/conf.d/FastCGI.conf:
FastCgiIpcDir /tmp: can’t create dynamic directory “/tmp/dynamic”:
access for server (uid -1, gid -1) failed: read not allowed
[FAILED]

The apache user account doesn’t have rights to create folders/files in
the /tmp directory.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Tamer
Tayea
Sent: Friday, August 24, 2007 1:58 PM
To: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Error Starting httpd service

Hi Guys,

I managed to go through the whole installation guide…
Now , I try to run >>service httpds start , I get the following error.

Any Ideas

Starting httpd: Syntax error on line 2 of
/etc/httpd/conf.d/FastCGI.conf:
FastCgiIpcDir /tmp: can’t create dynamic directory “/tmp/dynamic”:
access for server (uid -1, gid -1) failed: read not allowed
[FAILED]
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Justin Brodley wrote:

The apache user account doesn’t have rights to create folders/files in
the /tmp directory.

That could be, but you’d have to have some screwy permissions on /tmp.
Check the permissions:

$ ls -ld /tmp
drwxrwxrwt 20 root root 1998848 Aug 24 14:23 /tmp

Also, you might already have a directory called ‘dymanic’ in there that
is owned by someone other than whatever you’re using for your apache user.

Or, this behavior could be caused by selinux. You might want to review
your selinux policy and see if that’s the case, or you could just change
your selinux mode to permissive / disable selinux to test if that is
what is causing your problem.

.r’