Error (not ok - Could not load a valid user) - While creating a ticket via email


I tried looking for this problem in the list, but could not locate any information and as a result I am posting this issue. I would appreciate if anyone on the list can provide me a pointer or a helpful hint.

I have installed RT 3.0.5/Apache-1.3.28/mod_perl-1.28/mysql-4.0.15/fetchmail-6.2.4/perl-5.8.0

I am able to login to through the user interface and create new ticket once I log in. But I am getting an error when I send an email to open a new ticket.

I use fetchmail on the host where I have installed RT and using the mda command in .fetchmailrc to send it to /opt/rt3/bin/rt-mailgate.

When I run the rt-mailgate with debug option, I see an error “not ok - Could not load a valid user”.

I am having the mail sent to

I am following the draftmanual. Please help me if anyone knows what is the problem or where I should be looking?

Also, even after mentioning the log file in, I donot see the logs in the file /opt/rt3/var/log/rt.log.

Thanks in advance.