Error after fresh installation of 3.9-trunk

Hi,

after a fresh installation of 3.9-trunk from github and logging in,
instead of the quicksearch component I get the follwing error:

Error during compilation of
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle:
Can’t locate RT/Report/Tickets.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle line 94.

Any ideas?

-Chris

Hi,

after a fresh installation of 3.9-trunk from github and logging in,
instead of the quicksearch component I get the follwing error:

Error during compilation of
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle:
Can’t locate RT/Report/Tickets.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle line 94.

Did you run autoconf? I’m surprised not to see /opt/rt3 in your @INC

Hi,

after a fresh installation of 3.9-trunk from github and logging in,
instead of the quicksearch component I get the follwing error:

Error during compilation of
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle:
Can’t locate RT/Report/Tickets.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle line 94.
Did you run autoconf? I’m surprised not to see /opt/rt3 in your @INC
Any ideas?

-Chris
I had the same problem and I had run configure with --prefix=/ROOTOFINSTALL.

Finally tracked it down to the fact that some, but not all, of the *.in
files in sbin use

@RT_LIB_PATH@” and “@LOCAL_LIB_PATH@” instead of the “_R” versions.
Tweaked everyone to use the _R versions and rebuilt stuff and it all
went away. There’s something funny happening with the entire routine
that starts

fix lib paths, some may be relative in the *.in files.

Haven’t had a chance to dig beyond that.

Jeff

Yes I run autoconf and configure with --prefix=/opt/rt39

At the moment I only have with the quicksearch portlet the problem and
didn’t see any other problems.Am 25.11.2010 04:24, schrieb Jeff Voskamp:

On 11/24/2010 06:48 PM, Jesse Vincent wrote:

On Thu, Nov 25, 2010 at 12:47:04AM +0100, Christian Loos wrote:

Hi,

after a fresh installation of 3.9-trunk from github and logging in,
instead of the quicksearch component I get the follwing error:

Error during compilation of
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle:
Can’t locate RT/Report/Tickets.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle line 94.
Did you run autoconf? I’m surprised not to see /opt/rt3 in your @INC
Any ideas?

-Chris
I had the same problem and I had run configure with
–prefix=/ROOTOFINSTALL.

Finally tracked it down to the fact that some, but not all, of the *.in
files in sbin use

@RT_LIB_PATH@” and “@LOCAL_LIB_PATH@” instead of the “_R” versions.
Tweaked everyone to use the _R versions and rebuilt stuff and it all
went away. There’s something funny happening with the entire routine
that starts

fix lib paths, some may be relative in the *.in files.

Haven’t had a chance to dig beyond that.

Jeff

Still having this problem.
Any Ideas?

-Chris

Still having this problem.
Any Ideas?

Did you try Jeff Voskamp’s suggestion wrt relative paths? (Also, is it
still failing on trunk?)

Hi Chris

did you use apache2+mod_perl, maybe also with mpm_worker?

if so, does it help if you add "PerlSwitches -I/path/to/rt/local/lib -I/path/to/rt/lib"
to apache’s config file?

best wishes
sunnavyOn 10-11-25 00:47, Christian Loos wrote:

Hi,

after a fresh installation of 3.9-trunk from github and logging in,
instead of the quicksearch component I get the follwing error:

Error during compilation of
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle:
Can’t locate RT/Report/Tickets.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt39/share/html/Elements/QueueSummaryByLifecycle line 94.

Any ideas?

-Chris


List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

Hi Jesse and Sunnavy,

I tried on the latest trunk from github with “./configure
–enable-layout=RT3” and “./configure --enable-layout=relative” and with
"PerlSwitches -I/opt/rt4/local/lib -I/opt/rt4/lib" apache directive and
without this directive and with all combinations from above, all with
the same strange result:
It is still failing SOMETIMES!!

Most times, after a apache restart it doesn’t fail. But after some page
reloads (up to 10) it suddenly fails.

My system:
Ubuntu 10.10 + apache2 (2.2.16-1ubuntu3.1, mpm-worker) + mod_perl2
(2.0.4-7ubuntu1)

If available, I use the Perl modules from the Ubuntu repositories. The
rest I get from CPAN.

-Chris

What’s your apache config look like?On Thu, Dec 09, 2010 at 12:58:06AM +0100, Christian Loos wrote:

Hi Jesse and Sunnavy,

I tried on the latest trunk from github with “./configure
–enable-layout=RT3” and “./configure --enable-layout=relative” and with
"PerlSwitches -I/opt/rt4/local/lib -I/opt/rt4/lib" apache directive and
without this directive and with all combinations from above, all with
the same strange result:
It is still failing SOMETIMES!!

Most times, after a apache restart it doesn’t fail. But after some page
reloads (up to 10) it suddenly fails.

My system:
Ubuntu 10.10 + apache2 (2.2.16-1ubuntu3.1, mpm-worker) + mod_perl2
(2.0.4-7ubuntu1)

If available, I use the Perl modules from the Ubuntu repositories. The
rest I get from CPAN.

-Chris

Attached my apache config.Am 09.12.2010 20:14, schrieb Jesse Vincent:

What’s your apache config look like?

rt4-8765 (745 Bytes)

seems that PerlSwitches doesn’t take affect in
though mod_perl doc says it can, I think there’s a bug.

could you put PerlSwitches out of VirtualHost and try again?
(e.g. put it to the head of httpd.conf instead)

best wishes
sunnavyOn 10-12-09 22:24, Christian Loos wrote:

Attached my apache config.

Am 09.12.2010 20:14, schrieb Jesse Vincent:

What’s your apache config look like?

<VirtualHost *:8765>
ServerName localhost

    <Directory />
        Options FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>

    AddDefaultCharset UTF-8
    PerlSetEnv RT_SITE_CONFIG /opt/rt4/etc/RT_SiteConfig.pm
    PerlSwitches -I/opt/rt4/local/lib -I/opt/rt4/lib

    RedirectMatch permanent (.*)/$ $1/index.html

    DocumentRoot /opt/rt4/share/html
    <Directory /opt/rt4/share/html>
        Order allow,deny
        Allow from all

        SetHandler perl-script
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Directory>

btw, you can omit PerlSwitches if with latest 3.9-trunk(after f35699355a).
if so, you need to add the following lines to apache’s config:

use Plack::Handler::Apache2; Plack::Handler::Apache2->preload("/opt/rt3/sbin/rt-server");

best wishes
sunnavyOn 10-12-10 15:40, sunnavy wrote:

seems that PerlSwitches doesn’t take affect in
though mod_perl doc says it can, I think there’s a bug.

could you put PerlSwitches out of VirtualHost and try again?
(e.g. put it to the head of httpd.conf instead)

best wishes
sunnavy

On 10-12-09 22:24, Christian Loos wrote:

Attached my apache config.

Am 09.12.2010 20:14, schrieb Jesse Vincent:

What’s your apache config look like?

<VirtualHost *:8765>
ServerName localhost

    <Directory />
        Options FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>

    AddDefaultCharset UTF-8
    PerlSetEnv RT_SITE_CONFIG /opt/rt4/etc/RT_SiteConfig.pm
    PerlSwitches -I/opt/rt4/local/lib -I/opt/rt4/lib

    RedirectMatch permanent (.*)/$ $1/index.html

    DocumentRoot /opt/rt4/share/html
    <Directory /opt/rt4/share/html>
        Order allow,deny
        Allow from all

        SetHandler perl-script
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Directory>

List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

After adding this to the apache config I don’t get this error any more.

Thanks!

-ChrisAm 10.12.2010 11:06, schrieb sunnavy:

btw, you can omit PerlSwitches if with latest 3.9-trunk(after f35699355a).
if so, you need to add the following lines to apache’s config:

use Plack::Handler::Apache2; Plack::Handler::Apache2->preload("/opt/rt3/sbin/rt-server");

best wishes
sunnavy