Empty From: email header in RT 4.2.12

When I create/reply to a ticket, the outgoing email has an empty From: header. This is causing the email to not be delivered by google-based servers.

Here is the content of my RT_SiteConfig.pm

Set( $rtname, ‘support.diehlnet.com:8080’);
Set($WebDomain, ‘support.diehlnet.com’);

Set($CorrespondAddress, ‘support@diehlnet.com’);
Set($CommentAddress, ‘support@diehlnet.com’);

Set($SetOutgoingMailFrom, 1);
Set($SetOutgoingMailFrom, “support@diehlnet.com”);


Any ideas?

Thanks in advance,
Mike Diehl.

Hmm. You seem to have SetOutgoingMailFrom defined twice there.

Manual says that this is to set the envelope (e.g. mail from <>) address rather than the From: header, which seems to come from either the queue configuration or another hash ref called OverrideOutgoingMailFrom. I can’t see why you would need to set that, ordinarily though. It should take the From: header from the queue configuration.


Here’s what I have:

Set($CorrespondAddress, 'support@domain.net');
Set($CommentAddress, 'support-comment@domain.net');

Set($SetOutgoingMailFrom, 1);

Then in mail aliases:(/etc/aliases) for each queue:

support: "|/usr/bin/rt-mailgate --queue \"Support\" --action correspond --url https://support.domain.net/rt"
support-comment: "|/usr/bin/rt-mailgate --queue \"Support\" --action comment --url https://support.domain.net/rt"

This pipes the input into RT from exim (in our case).

Then in each queue config in RT (under Admin → Queues) the Reply Address and Comment address are set the same, but underneath each one is a note that what it would be set to by default, which is picked up from the config. A few of our queues have a different address.

Some MTAs by default do not allow unprivileged users to use the "-f" option to override the envelope from address. Check what the default “sendmail” does on your system.

For exim for example, you might need to set

# allow untrusted users to set an envelope sender
untrusted_set_sender = *

(or just the user that RT is running from, maybe www-user. This seems to be the default though in, say, the debian/ubuntu exim conf scheme.)

You’ll have to look at the various logs for RT and your MTA to determine what’s going on.

See also docu under RT Config - RT 4.4.4 Documentation - Best Practical (look for section Outgoing mail).