Email gateway problems

Hi,

We are having trouble with our RT install here. When ever anybody sends
mail with characters greater than 127 ascii in the body (Notes seems
good at doing this!) the ticket coming into RT is completely empty. Also
if a mime text attachment contains these unprintable characters it is
truncated.

If i manually feed the mail with rt-mailgate I get the following error
(repeated for every 8bit char).

Malformed UTF-8 character (unexpected continuation byte 0xa0, with no
preceding start byte) in substitution iterator at
/usr/lib/perl5/vendor_perl/5.8.0/URI/_query.pm line 38, <> chunk 1.

I have played around with the EmailInputEncodings array with no luck ?
Is there anyway of getting these mails into rt or will I have to pipe
them through a filter from procmail ?

Cheers,
Nic Strong

smime.p7s (3.7 KB)

Does this still happen with RT 3.0.3? (available, but not yet announced.
That will happen within a few hours.)On Tue, Jun 24, 2003 at 04:05:00PM +1200, Nic Strong wrote:

Hi,

We are having trouble with our RT install here. When ever anybody sends
mail with characters greater than 127 ascii in the body (Notes seems
good at doing this!) the ticket coming into RT is completely empty. Also
if a mime text attachment contains these unprintable characters it is
truncated.

If i manually feed the mail with rt-mailgate I get the following error
(repeated for every 8bit char).

Malformed UTF-8 character (unexpected continuation byte 0xa0, with no
preceding start byte) in substitution iterator at
/usr/lib/perl5/vendor_perl/5.8.0/URI/_query.pm line 38, <> chunk 1.

I have played around with the EmailInputEncodings array with no luck ?
Is there anyway of getting these mails into rt or will I have to pipe
them through a filter from procmail ?

Cheers,
Nic Strong

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Nic Strong wrote:

We are having trouble with our RT install here. When ever anybody sends
mail with characters greater than 127 ascii in the body (Notes seems
good at doing this!) the ticket coming into RT is completely empty. Also
if a mime text attachment contains these unprintable characters it is
truncated.

You didn’t mention what version of RT you are using.
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances

Finally got around to the upgrade. Worked a charm. Thanks everyone.

NicFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Jesse Vincent
Sent: Tuesday, 24 June 2003 4:18 p.m.
To: Nic Strong
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] Email gateway problems

Does this still happen with RT 3.0.3? (available, but not yet announced.
That will happen within a few hours.)

smime.p7s (3.7 KB)