Email disabled for ticket

Hello,
We have a ticket which was sent in from a new, non-privileged user. The account was autocreated upon ticket submission.

Under ‘People’ it says that the user (requestor)'s email is ‘disabled for ticket’. It says this just after his email address on the Requestors line.

What does this mean? Some replies did in fact work but at some point the system flagged his email as disabled for the ticket.

Thanks!
William

Under People' it says that the user (requestor)'s email isdisabled for ticket’. It says
this just after his email address on the Requestors line.

What does this mean? Some replies did in fact work but at some point the system flagged his
email as disabled for the ticket.

Click on the People at the top of that tab (or at the top of the page)
to get to the Modify People page.

Scroll down and see the ‘Modify who receives mail’ section.
It’s like the checkboxes on the reply page which squelch people for a
single transaction, but this does it for the whole ticket.

You can grovel in the database to find out who unchecked them.
It’ll be an attribute connected to the ticket named SquelchMailTo.

-kevin

Hi there:

I found this thread and have a few questions:

Under People' it says that the user (requestor)'s email isdisabled
for ticket’. It says
this just after his email address on the Requestors line.

We would like that to happen on our end but don’t know how to implement it.
In our case,
when a requestor is disabled it simply does not show that requestor under
’People’ in Ticket/Display.html
On the other hand, Ticket/ModifyPeople.html shows the disabled requestor
but no indication about
the status

What does this mean? Some replies did in fact work but at some point
the system flagged his

email as disabled for the ticket.

Click on the People at the top of that tab (or at the top of the page)
to get to the Modify People page.

Scroll down and see the ‘Modify who receives mail’ section.
It’s like the checkboxes on the reply page which squelch people for a
single transaction, but this does it for the whole ticket.

In our case, the 'Modify who receives email ’ section just shows this text:
'The checked users may receive email related to this ticket depending on
the action taken. Uncheck users to stop sending email to them about this
ticket.'
but no checkboxes or any other input field …

Sys Info about our instance:
OS: Centos6
RT version: 4.2.2

I tried everything in user’s access control (on/off):
- Let this user access RT, and
- Let this user be granted rights (Privileged)

I also browsed RT_Config up and down but nothing seems to control this
particular behaviour or I’m missing something …

Any help will be highly appreciated

Regards,

Hugo Escobar

http://www.associationfinancialservices.com/

4770 Biscayne Blvd, Ste 700
Miami, FL 33137

main: 305.677.0022
support: 305.921.4620
email: hescobar@afslc.com

Follow us on Facebook and Linked-In
http://www.facebook.com/pages/Miami-FL/ASSOCIATION-FINANCIAL/64952991864
http://www.linkedin.com/companies/1006276

NOTICE: This email and any attachment to this email may contain
confidential information. If you are not the intended recipient, you must
not review, retransmit, convert to hard copy, photocopy, use or disseminate
this email or any attachments to it. If you have received this email in
error, please notify us immediately by return email and delete this
message. Please note that if this email contains a forwarded message or is
a reply to a prior message, some or all of the contents of this message or
any attachments may not have been produced by our firm. As our firm may be
deemed a debt collector, if your payment is in default, we may be
attempting to collect a debt on behalf of the association, and any
information obtained may be used for that purpose.

I found this thread and have a few questions:

Unfortunately, this thread appears to be unrelated to your problems.

>    Under `People' it says that the user (requestor)'s email is `disabled
for ticket'. It says
>    this just after his email address on the Requestors line.
>

We would like that to happen on our end but don’t know how to implement it. In
our case,
when a requestor is disabled it simply does not show that requestor under
’People’ in Ticket/Display.html
On the other hand, Ticket/ModifyPeople.html shows the disabled requestor but no
indication about
the status

You’re confusing a Disabled requestor with a Squelched requestor who
has been configured to not receive mail for this ticket.

In our case, the 'Modify who receives email ’ section just shows this text:
'The checked users may receive email related to this ticket depending on the
action taken. Uncheck users to stop sending email to them about this ticket.'
but no checkboxes or any other input field …

Sys Info about our instance:
OS: Centos6
RT version: 4.2.2

I tried everything in user’s access control (on/off):
- Let this user access RT, and
- Let this user be granted rights (Privileged)

I also browsed RT_Config up and down but nothing seems to control this
particular behaviour or I’m missing something …

Guesses? You use only TransactionBatch scrips. You have no scrips
or users that would get mail on that ticket. You do not have
ShowOutgoingEmail.

-kevin

I found this thread and have a few questions:

Unfortunately, this thread appears to be unrelated to your problems.

>    Under `People' it says that the user (requestor)'s email is

`disabled

for ticket'. It says
>    this just after his email address on the Requestors line.
>

We would like that to happen on our end but don’t know how to implement
it. In
our case,
when a requestor is disabled it simply does not show that requestor under
’People’ in Ticket/Display.html
On the other hand, Ticket/ModifyPeople.html shows the disabled requestor
but no
indication about
the status

You’re confusing a Disabled requestor with a Squelched requestor who
has been configured to not receive mail for this ticket.

In our case, the 'Modify who receives email ’ section just shows this
text:
'The checked users may receive email related to this ticket depending on
the
action taken. Uncheck users to stop sending email to them about this
ticket.'
but no checkboxes or any other input field …

Sys Info about our instance:
OS: Centos6
RT version: 4.2.2

I tried everything in user’s access control (on/off):
- Let this user access RT, and
- Let this user be granted rights (Privileged)

I also browsed RT_Config up and down but nothing seems to control this
particular behaviour or I’m missing something …

Guesses? You use only TransactionBatch scrips. You have no scrips
or users that would get mail on that ticket. You do not have
ShowOutgoingEmail.

-kevin


RT Training - Boston, September 9-10
http://bestpractical.com/training

After doing a clean install of RT I saw the normal behaviour in RT which is
to show ‘disabled for ticket’ when the email has been unchecked under
the 'Modify who receives email ’ section.

At some point this stopped happening on my system. I managed to isolate the
cause and it seems to be the database.

Thanks for your help

Regards,

Hugo Escobar

http://www.associationfinancialservices.com/

4770 Biscayne Blvd, Ste 700
Miami, FL 33137

main: 305.677.0022
support: 305.921.4620
email: hescobar@afslc.com

Follow us on Facebook and Linked-In
http://www.facebook.com/pages/Miami-FL/ASSOCIATION-FINANCIAL/64952991864
http://www.linkedin.com/companies/1006276

NOTICE: This email and any attachment to this email may contain
confidential information. If you are not the intended recipient, you must
not review, retransmit, convert to hard copy, photocopy, use or disseminate
this email or any attachments to it. If you have received this email in
error, please notify us immediately by return email and delete this
message. Please note that if this email contains a forwarded message or is
a reply to a prior message, some or all of the contents of this message or
any attachments may not have been produced by our firm. As our firm may be
deemed a debt collector, if your payment is in default, we may be
attempting to collect a debt on behalf of the association, and any
information obtained may be used for that purpose.