Doc tweak for RT_Config.pm

Hi all,

Following some discussion on rt-users@ last week, it seems that FreeBSD
likes to use the same Log::Dispatch::Syslog settings that RT_Config.pm
recommends for Solaris, ie:

@LogToSyslogConf = ( socket => 'inet' ) unless

(@LogToSyslogConf);

The attached patch just changes the comments in RT_Config.pm to say
"Solaris and FreeBSD" instead of just “Solaris”. It would be good if
this could make it into the offical RT distribution.

Cheers,

Scott

RT_Config.pm.diff (674 Bytes)

Following some discussion on rt-users@ last week, it seems that FreeBSD
likes to use the same Log::Dispatch::Syslog settings that RT_Config.pm
recommends for Solaris, ie:

Which FreeBSD? On 4.10-RELEASE, I have no such setting on my
RT_SiteConfig.pm and logs go to syslog just fine, as seen here in
/var/log/messages:

Aug 18 22:27:20 w01 RT: Out of memory during “large” request for
8392704 bytes,
total sbrk() is 48089088 bytes at /usr/local/lib/perl5/5.8.4/CGI.pm
line 679. (
/var/vkmlm/rt3/bin/webmux.pl:107)

This is with RT 3.2.1

Vivek Khera wrote:> On Aug 31, 2004, at 5:06 AM, Scott Mitchell wrote:

Following some discussion on rt-users@ last week, it seems that
FreeBSD likes to use the same Log::Dispatch::Syslog settings that
RT_Config.pm recommends for Solaris, ie:

Which FreeBSD? On 4.10-RELEASE, I have no such setting on my
RT_SiteConfig.pm and logs go to syslog just fine, as seen here in
/var/log/messages:

Currently RT 3.0.11 on FreeBSD 4.8p20. We had plenty of stuff logging
to syslog too, except that we could provoke a 'no connection to syslog’
error consistently when trying to create a new email template. The
problem went away when we changed RT_SiteConfig.pm. I don’t really talk
Perl, so I can’t give you much more of an analysis than that.

Cheers,

Scott