Default templates not working?


#1

I figured this was a permissions problem, so I ran ‘gmake
fixperms’ and then even ‘gmake upgrade’ but am still having
the same issue (on FreeBSD 3.4.)

Basically, instead of the default template, I get:

The specified template is missing or inaccessable.
(/local/maps/rt/etc/templates/queues/ticket-system/autoreply)
However, the custom content which was supposed to fill the template was:

...and nothing else.

I'm sure I'm just missing something dumb....

J.D. Falk "Laughter is the sound
Product Manager that knowledge makes when it’s born."
Mail Abuse Prevention System LLC – The Cluetrain Manifesto


#2

Your permissions for the rt/etc/templates/queues//* should be rwx,
and owned by rt.
If those files don’t exist, then rt is probably having problems setting up the
queue in the first place.
Check the permissions on rt/lib/generic_templates - They should also be rwx
and owned by rt. If not, then rt won’t be able to create the templates for
your queue.

-Feargal.

Feargal Reilly,
Systems administrator,
The CIA.


#3

Your permissions for the rt/etc/templates/queues//* should be rwx,
and owned by rt.
If those files don’t exist, then rt is probably having problems setting up the
queue in the first place.

Hmm, that must be it; they don't exist, though the rest of the
queue seems fine.

Check the permissions on rt/lib/generic_templates - They should also be rwx
and owned by rt. If not, then rt won’t be able to create the templates for
your queue.

Those are okay now, but might not have been with some of the
earlier queue creations.  However, after I ran 'make fixperms'
and created a new queue, it was still b0rken.

Any other things I should check?

J.D. Falk "Laughter is the sound
Product Manager that knowledge makes when it’s born."
Mail Abuse Prevention System LLC – The Cluetrain Manifesto