Default createticket owner?

How can I set the default Owner on the Create Ticket page to something other
than “Nobody”?
I tried a few things, modifying:

  • /share/html/Ticket/Create.html (and)
  • /share/html/Elements/SelectOwner

… but nothing worked. I use the system for a personal “to do” list, so I
only have 1 user (aside from Nobody). It should be easy enough to change
the “selected” (as in <select ) user. Can anyone please
make a suggestion?

Thanks,
Vince

Vince wrote:

How can I set the default Owner on the Create Ticket page to something other
than “Nobody”?
I tried a few things, modifying:

  • /share/html/Ticket/Create.html (and)
  • /share/html/Elements/SelectOwner

… but nothing worked.

Changing share/html/Ticket/Create.html would be simple enough. Just replace
$RT::Nobody->Id in line 72 with the numeric id of the user you’d like
as the default. You can get this id from the URL when you open the
modify user page.

You can even get by without modifying code by using a bookmark to the
Create Ticket page that adds &Owner= (replace with the same id
mentioned above) to the usual URL.

Hope that helps.

Rolf

How can I set the default Owner on the Create Ticket page to something
other than “Nobody”?
I tried a few things, modifying:

  • /share/html/Ticket/Create.html (and)
  • /share/html/Elements/SelectOwner

… but nothing worked.

Changing share/html/Ticket/Create.html would be simple enough. Just
replace
$RT::Nobody->Id in line 72 with the numeric id of the user you’d like as
the default. You can get this id from the URL when you open the modify
user page.

You can even get by without modifying code by using a bookmark to the
Create Ticket page that adds &Owner= (replace with the same id
mentioned above) to the usual URL.

Thanks for the suggestions, Rolf. The added “&Owner=” on the
end of the URL was the first thing I tried. No luck. I even tried
&Owner=root (that’s the user name).

I also tried changing line 72 in share/html/Ticket/Create.html from:
"…, Default => $ARGS{Owner}||$RT::Nobody->Id, …“
to each of these:
”…, Default => $ARGS{Owner}||12, …"
"…, Default => 12, …" (“12” is the numeric id of the user I
want)

…with no effect on the “create ticket” html page after stopping and
starting the httpd server.

I did have to change share/html/Elements/SelectOwner, though, just to get my
user to show in the drop-down. Without editing it, the only option was
"Nobody".

I’d love to get it to come up with “root” selected, not “Nobody”, to save me
from having to remember to change that drop-down every time I create a
ticket.

Any more ideas?

Thanks again,
Vince

Vince wrote:

Thanks for the suggestions, Rolf. The added “&Owner=” on
the end of the URL was the first thing I tried. No luck. I even
tried &Owner=root (that’s the user name).

Using the name won’t work. You need the id. Of course then you also need
to have the user listed in the first place, which brings us to your
other problem:

I did have to change share/html/Elements/SelectOwner, though, just to
get my user to show in the drop-down. Without editing it, the only
option was “Nobody”.

That is due to a change in RT 3.4 that requires a user to have the
OwnTicket right (just SuperUser is not enough) to show up in the list.
I’ve already filed a bug report to revert that change for other
SuperUsers ([fsck.com #6729]), in the meantime you should just give the
OwnTicket right to your root user.

I’d love to get it to come up with “root” selected, not “Nobody”, to
save me from having to remember to change that drop-down every time I
create a ticket.

Any more ideas?

It should just work once you get the user in the list without any
modifications to the code.

Rolf

Thanks for the suggestions, Rolf. The added “&Owner=” on the
end of the URL was the first thing I tried. No luck. I even tried
&Owner=root (that’s the user name).

Using the name won’t work. You need the id. Of course then you also need
to have the user listed in the first place, which brings us to your other
problem:

I did have to change share/html/Elements/SelectOwner, though, just to get
my user to show in the drop-down. Without editing it, the only option
was “Nobody”.

That is due to a change in RT 3.4 that requires a user to have the
OwnTicket right (just SuperUser is not enough) to show up in the list.
I’ve already filed a bug report to revert that change for other SuperUsers
([fsck.com #6729]), in the meantime you should just give the OwnTicket
right to your root user.

I’d love to get it to come up with “root” selected, not “Nobody”, to save
me from having to remember to change that drop-down every time I create a
ticket.

Any more ideas?

It should just work once you get the user in the list without any
modifications to the code.

Rolf

Thanks, Rolf. Sorry for the trouble… It’s working now. I guess I hadn’t
tried the combination of “&Owner=12” on the URL …AND… editing the
SelectOwner file so my root user shows.

For the record, if I hadn’t edited the SelectOwner file, how do I add the
OwnTicket right to my root user? I can see how I might do it tinkering with
the ACL table directly, but what’s the proper way to do it?
(Strange that the SuperUser wouldn’t have the OwnTicket right…?)

Thanks,
Vince

Vince wrote:

For the record, if I hadn’t edited the SelectOwner file, how do I add
the OwnTicket right to my root user? I can see how I might do it
tinkering with the ACL table directly, but what’s the proper way to do
it?

Configuration -> Global -> User Rights

(Strange that the SuperUser wouldn’t have the OwnTicket right…?)

The idea was not to list all SuperUsers to regular users, but IMHO they
overshot the target.

Rolf