Debian woody/stable packages

Hi All,

I have now put together an apt repository of all the necessary
backported packages to install rt3 onto a Debian woody/stable
machine. The packages are for running using perl 5.6 on Apache 1.3
with PostgreSQL and either mod_perl or FastCGI.

The /etc/apt/sources.list entries are:

deb http://people.debian.org/~sjq/debian woody rt3
deb-src http://people.debian.org/~sjq/debian woody rt3

you should just need:

apt-get update
apt-get install request-tracker3

to get started on woody/stable. (Use aptitude or dselect if you want
to choose fastcgi instead of mod_perl.)

I would love to hear from anyone who successfully (or otherwise) uses
these packages. It all seems to install and run properly so hopefully
there will be few problems with the packages.

Stephen Quinney sjq@debian.org

rt3 have to be run with perl 5.8.0 to avoid UTF problems and thus
slowdown email trafic on this list.
Best regards. Ruslan.
Stephen Quinney wrote:

rt3 have to be run with perl 5.8.0 to avoid UTF problems and thus
slowdown email trafic on this list.

I agree, anyone who want to use RT with languages other than english
should probably use perl 5.8.0, and that means debian testing or
unstable. I don’t have the time to backport perl 5.8 and hopefully
sarge will become stable within 3 or 4 months. In my situation we only
need RT in english and perl 5.6 is perfectly acceptable.

I believe there are backports of perl 5.8 out there (check
http://www.apt-get.org/) and people could install one of those and
then install a lot of packages directly from sarge/testing.

Stephen