$DBI::Version error

Hello,
I have setup my rt server on Linux 7.0 with MySQL. I have done all the
installation per the docs and have tested my DB. I get the following
error when I try to start my apache web server…

root@mini rt-2-0-7]# /usr/local/apache/bin/apachectl start
Syntax error on line 973 of /usr/local/apache/conf/httpd.conf:
DBI object version 1.20 does not match $DBI::VERSION 0.93 at
/usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm line 219.
Compilation failed in require at (eval 3) line 3.

/usr/local/apache/bin/apachectl start: httpd could not be started

These are the results of my make testdeps just in case it helps…

[root@mini rt-2-0-7]# make testdeps
/usr/bin/perl ./tools/testdeps -warn mysql
Checking for DBI 1.18 …found
Checking for DBIx::DataSource 0.02 …found
Checking for DBIx::SearchBuilder 0.40 …found
Checking for HTML::Entities…found
Checking for MLDBM…found
Checking for Net::Domain…found
Checking for Net::SMTP…found
Checking for Params::Validate 0.02 …found
Checking for HTML::Mason 0.896 …found
Checking for CGI::Cookie 1.20 …found
Checking for Apache::Cookie…found
Checking for Apache::Session 1.53 …found
Checking for Date::Parse…found
Checking for Date::Format…found
Checking for MIME::Entity 5.108 …found
Checking for Mail::Mailer 1.20 …found
Checking for Getopt::Long 2.24 …found
Checking for Tie::IxHash…found
Checking for Text::Wrapper…found
Checking for Text::Template…found
Checking for File::Spec 0.8 …found
Checking for Errno…found
Checking for FreezeThaw…found
Checking for File::Temp…found
Checking for Log::Dispatch 1.6 …found
Checking for DBD::mysql 2.0416 …found

Any help would be greatly appreciated.

Thanks,
Simon Hearsey
Univ. of Washington Physics

I suspect this isn’t RT related, but is actually jsut that you’ve got
two conflicting versions of DBI installed. try reinstalling DBI with UNINST=1On Fri, Oct 05, 2001 at 05:00:03PM -0700, Simon Hearsey wrote:

Hello,
I have setup my rt server on Linux 7.0 with MySQL. I have done all the
installation per the docs and have tested my DB. I get the following
error when I try to start my apache web server…

root@mini rt-2-0-7]# /usr/local/apache/bin/apachectl start
Syntax error on line 973 of /usr/local/apache/conf/httpd.conf:
DBI object version 1.20 does not match $DBI::VERSION 0.93 at
/usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm line 219.
Compilation failed in require at (eval 3) line 3.

/usr/local/apache/bin/apachectl start: httpd could not be started

These are the results of my make testdeps just in case it helps…

[root@mini rt-2-0-7]# make testdeps
/usr/bin/perl ./tools/testdeps -warn mysql
Checking for DBI 1.18 …found
Checking for DBIx::DataSource 0.02 …found
Checking for DBIx::SearchBuilder 0.40 …found
Checking for HTML::Entities…found
Checking for MLDBM…found
Checking for Net::Domain…found
Checking for Net::SMTP…found
Checking for Params::Validate 0.02 …found
Checking for HTML::Mason 0.896 …found
Checking for CGI::Cookie 1.20 …found
Checking for Apache::Cookie…found
Checking for Apache::Session 1.53 …found
Checking for Date::Parse…found
Checking for Date::Format…found
Checking for MIME::Entity 5.108 …found
Checking for Mail::Mailer 1.20 …found
Checking for Getopt::Long 2.24 …found
Checking for Tie::IxHash…found
Checking for Text::Wrapper…found
Checking for Text::Template…found
Checking for File::Spec 0.8 …found
Checking for Errno…found
Checking for FreezeThaw…found
Checking for File::Temp…found
Checking for Log::Dispatch 1.6 …found
Checking for DBD::mysql 2.0416 …found

Any help would be greatly appreciated.

Thanks,
Simon Hearsey
Univ. of Washington Physics


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.