Create ticket via API ignores Requestors field on notify requestors?

Hey,

We’re running RT 4.2.8 and using the API to create some tickets. But,
no notification is sent out to the requestor we’re setting. We are
using a privileged account to connect to the API.

I can see the requestor set on the ticket when I check the website, but
no recipients are considered when the scrip runs:

Oct 6 14:21:09 cat-prod-rt RT: [1145] Working on mailfield To;
recipients are (/usr/share/request-
tracker4/lib/RT/Action/SendEmail.pm:639)

Oct 6 14:21:09 cat-prod-rt RT: [1145] No recipients found for deferred
delivery on transaction #213681 (/usr/share/request-tracker4/lib/RT/
Action/SendEmail.pm:691)
Oct 6 14:21:09 cat-prod-rt RT: [1145] <rt-4.2.8-1145-1475716868-1698.2
5796-22-0@rt.catalyst.net.nz> #25796/213681 - Scrip 22 On Create Notify
Requestor

Is there anything we can do to make this work?

Cheers,
Andrew

Andrew Ruthven, Wellington, New Zealand
andrew@etc.gen.nz | linux.conf.au 2017, Hobart, AU
New Zealand’s only Cloud: | The Future of Open Source
https://catalyst.net.nz/cloud | http://linux.conf.au

Andrew,

If RT believes the Requester is also the actor requesting the ticket, it
doesn’t usually (depends on default settings for “Notify Actor”) send a
notification to the person making the request. It’s considered redundant.
Read about the setting and change the setting.

Good Luck.

CaseyOn Oct 5, 2016 7:30 PM, “Andrew Ruthven” andrew@etc.gen.nz wrote:

Hey,

We’re running RT 4.2.8 and using the API to create some tickets. But,
no notification is sent out to the requestor we’re setting. We are
using a privileged account to connect to the API.

I can see the requestor set on the ticket when I check the website, but
no recipients are considered when the scrip runs:

Oct 6 14:21:09 cat-prod-rt RT: [1145] Working on mailfield To;
recipients are (/usr/share/request-
tracker4/lib/RT/Action/SendEmail.pm:639)

Oct 6 14:21:09 cat-prod-rt RT: [1145] No recipients found for deferred
delivery on transaction #213681 (/usr/share/request-tracker4/lib/RT/
Action/SendEmail.pm:691)
Oct 6 14:21:09 cat-prod-rt RT: [1145] <rt-4.2.8-1145-1475716868-1698.2
5796-22-0@rt.catalyst.net.nz> #25796/213681 - Scrip 22 On Create Notify
Requestor

Is there anything we can do to make this work?

Cheers,
Andrew


Andrew Ruthven, Wellington, New Zealand
andrew@etc.gen.nz | linux.conf.au 2017, Hobart, AU
New Zealand’s only Cloud: | The Future of Open Source
https://catalyst.net.nz/cloud | http://linux.conf.au


RT 4.4 and RTIR training sessions, and a new workshop day!
https://bestpractical.com/training

  • Boston - October 24-26
  • Los Angeles - Q1 2017

Hi Casey,

Thanks for that, the requestor is a different email address from what
is being used for the actor making the API call but the name is the
same. I’ve just changed the name and we’ve retested.

I can see NotifyActor correctly decide not to hassle the person who
created the ticket.

Cheers,
AndrewOn Wed, 2016-10-05 at 19:37 -0700, Kenneth Crocker wrote:

Andrew,
If RT believes the Requester is also the actor requesting the ticket,
it doesn’t usually (depends on default settings for “Notify Actor”)
send a notification to the person making the request. It’s considered
redundant. Read about the setting and change the setting.
Good Luck.
Casey

On Oct 5, 2016 7:30 PM, “Andrew Ruthven” andrew@etc.gen.nz wrote:

Hey,

We’re running RT 4.2.8 and using the API to create some tickets.
But,
no notification is sent out to the requestor we’re setting. We are
using a privileged account to connect to the API.

I can see the requestor set on the ticket when I check the website,
but
no recipients are considered when the scrip runs:

Oct 6 14:21:09 cat-prod-rt RT: [1145] Working on mailfield To;
recipients are (/usr/share/request-
tracker4/lib/RT/Action/SendEmail.pm:639)

Oct 6 14:21:09 cat-prod-rt RT: [1145] No recipients found for
deferred
delivery on transaction #213681 (/usr/share/request-
tracker4/lib/RT/
Action/SendEmail.pm:691)
Oct 6 14:21:09 cat-prod-rt RT: [1145] <rt-4.2.8-1145-1475716868-
1698.2
5796-22-0@rt.catalyst.net.nz> #25796/213681 - Scrip 22 On Create
Notify
Requestor

Is there anything we can do to make this work?

Cheers,
Andrew


Andrew Ruthven, Wellington, New Zealand
andrew@etc.gen.nz | linux.conf.au 2017, Hobart, AU
New Zealand’s only Cloud: | The Future of Open Source
https://catalyst.net.nz/cloud | http://linux.conf.au


RT 4.4 and RTIR training sessions, and a new workshop day! https://
bestpractical.com/training

Hey,

Any other suggestions? I’m kinda grasping at straws here.

Cheers,
AndrewOn Thu, 2016-10-06 at 16:08 +1300, Andrew Ruthven wrote:

Hi Casey,

Thanks for that, the requestor is a different email address from what
is being used for the actor making the API call but the name is the
same. I’ve just changed the name and we’ve retested.

I can see NotifyActor correctly decide not to hassle the person who
created the ticket.

Cheers,
Andrew

On Wed, 2016-10-05 at 19:37 -0700, Kenneth Crocker wrote:

Andrew,
If RT believes the Requester is also the actor requesting the
ticket,
it doesn’t usually (depends on default settings for “Notify Actor”)
send a notification to the person making the request. It’s
considered
redundant. Read about the setting and change the setting.
Good Luck.
Casey

On Oct 5, 2016 7:30 PM, “Andrew Ruthven” andrew@etc.gen.nz wrote:

Hey,

We’re running RT 4.2.8 and using the API to create some tickets.
But,
no notification is sent out to the requestor we’re setting. We
are
using a privileged account to connect to the API.

I can see the requestor set on the ticket when I check the
website,
but
no recipients are considered when the scrip runs:

Oct 6 14:21:09 cat-prod-rt RT: [1145] Working on mailfield To;
recipients are (/usr/share/request-
tracker4/lib/RT/Action/SendEmail.pm:639)

Oct 6 14:21:09 cat-prod-rt RT: [1145] No recipients found for
deferred
delivery on transaction #213681 (/usr/share/request-
tracker4/lib/RT/
Action/SendEmail.pm:691)
Oct 6 14:21:09 cat-prod-rt RT: [1145] <rt-4.2.8-1145-1475716868-
1698.2
5796-22-0@rt.catalyst.net.nz> #25796/213681 - Scrip 22 On Create
Notify
Requestor

Is there anything we can do to make this work?

Cheers,
Andrew


Andrew Ruthven, Wellington, New Zealand
andrew@etc.gen.nz | linux.conf.au 2017, Hobart, AU
New Zealand’s only Cloud: | The Future of Open Source
https://catalyst.net.nz/cloud | http://linux.conf.au


RT 4.4 and RTIR training sessions, and a new workshop day!
https://
bestpractical.com/training

Any other suggestions? I’m kinda grasping at straws here.

Perhaps you need to make Scrip 22 runs in the “Batch” scrip stage?

Any other suggestions? I’m kinda grasping at straws here.

Perhaps you need to make Scrip 22 runs in the “Batch” scrip stage?

Hi Bill,

Yes, that worked perfectly. Thanks for the suggestion.

Cheers,
Andrew

Andrew Ruthven, Wellington, New Zealand
andrew@etc.gen.nz | linux.conf.au 2017, Hobart, AU
New Zealand’s only Cloud: | The Future of Open Source
https://catalyst.net.nz/cloud | http://linux.conf.au