Create scrip failing to mail

We’re running RT 3.2.2 under Solaris 8. We haven’t modified the Global
Scrips, so they’re in effect on all queues. In most of the queues, when a
user submits a request via email, the autoreply mail is sent. In some of our
queues, however, the user recieves no mail. taking a look at the log file, RT
claims:

[Fri Nov 18 17:15:06 2005] [debug]: Converting ‘us-ascii’ to ‘utf-8’ for text/plain - test (/opt/rt3/lib/RT/I18N.pm:222)
[Fri Nov 18 17:15:07 2005] [debug]: About to think about scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:140)
[Fri Nov 18 17:15:07 2005] [debug]: About to prepare scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:144)
[Fri Nov 18 17:15:07 2005] [debug]: Found 2 scrips (/opt/rt3/lib/RT/Scrips_Overlay.pm:349)
[Fri Nov 18 17:15:08 2005] [debug]: About to commit scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:153)
[Fri Nov 18 17:15:08 2005] [info]: rt-3.2.2-48439-198785-15.18.9356892968107@rt #48439/198785 - Scrip 15 OnCreate notify requestors, cc’s, admincc’s Imported from RT 2.0 (/opt/rt3/lib/RT/Action/SendEmail.pm:231)
[Fri Nov 18 17:15:08 2005] [info]: rt-3.2.2-48439-198785-15.18.9356892968107@rt No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:243)
[Fri Nov 18 17:15:08 2005] [info]: Ticket 48439 created in queue 'FW-Request’
by arrich10 (/opt/rt3/lib/RT/Ticket_Overlay.pm:718)

Why is RT claiming that it can’t find any recipients when creating a brand new
ticket from an email?

FAQ NotifyActorOn 11/18/05, amy.rich@tufts.edu amy.rich@tufts.edu wrote:

We’re running RT 3.2.2 under Solaris 8. We haven’t modified the Global
Scrips, so they’re in effect on all queues. In most of the queues, when a
user submits a request via email, the autoreply mail is sent. In some of our
queues, however, the user recieves no mail. taking a look at the log file, RT
claims:

[Fri Nov 18 17:15:06 2005] [debug]: Converting ‘us-ascii’ to ‘utf-8’ for text/plain - test (/opt/rt3/lib/RT/I18N.pm:222)
[Fri Nov 18 17:15:07 2005] [debug]: About to think about scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:140)
[Fri Nov 18 17:15:07 2005] [debug]: About to prepare scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:144)
[Fri Nov 18 17:15:07 2005] [debug]: Found 2 scrips (/opt/rt3/lib/RT/Scrips_Overlay.pm:349)
[Fri Nov 18 17:15:08 2005] [debug]: About to commit scrips for transaction198785 (/opt/rt3/lib/RT/Transaction_Overlay.pm:153)
[Fri Nov 18 17:15:08 2005] [info]: rt-3.2.2-48439-198785-15.18.9356892968107@rt #48439/198785 - Scrip 15 OnCreate notify requestors, cc’s, admincc’s Imported from RT 2.0 (/opt/rt3/lib/RT/Action/SendEmail.pm:231)
[Fri Nov 18 17:15:08 2005] [info]: rt-3.2.2-48439-198785-15.18.9356892968107@rt No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:243)
[Fri Nov 18 17:15:08 2005] [info]: Ticket 48439 created in queue 'FW-Request’
by arrich10 (/opt/rt3/lib/RT/Ticket_Overlay.pm:718)

Why is RT claiming that it can’t find any recipients when creating a brand new
ticket from an email?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at http://bestpractical.com/services/training.html

Best regards, Ruslan.