Create request via rt-mailgate


#1

I’ve been going around in circles with this - but it is probably
something quite simple.

I am unable to create requests using the mail interface, unless I
configure the queue to accept create requests from non-members.
The users appear to be members of the queue, so I am not sure
what is wrong.

example reply from rt: ---------------------------------

Subject:
[RequestTracker #0] (_rt_system) RT Error: test 66
Date:
Wed, 9 Aug 2000 16:07:14 +1000 (EST)
From:
Jim Clark via RT rt@outbak.sop.dec.com
To:
clarkj@auss.sop.dec.com

There has been an error:
There has been an error with your request:
You don’t have permission to create requests in this queue

Your message is reproduced below:

test 66
Cheers,
Jim.

— Headers Follow —

From clarkj@auss.sop.dec.com Wed Aug 9 16:07:12 2000
Return-Path: clarkj@auss.sop.dec.com
Delivered-To: rt-pms35@outbak.sop.dec.com
Received: from lamhra.SOP.DEC.COM (lamhra.sop.dec.com [16.172.80.43])
by outbak.sop.dec.com (Postfix) with SMTP id 7C0991F0DD
for rt-pms35@outbak.sop.dec.com; Wed, 9 Aug 2000 16:07:12 +1000 (EST)
Received: by lamhra.sop.dec.com (UCX V4.2-21, OpenVMS V6.2 Alpha);
Wed, 9 Aug 2000 16:07:04 +1000
Sender: jim@outbak.sop.dec.com
Message-ID: 3990F50B.64C1004B@auss.sop.dec.com
X-Mailer: Mozilla 4.73 [en] (X11; I; Linux 2.2.15-4mdk i586)
X-Accept-Language: en
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

-------------------------------------------- Managed by Request Tracker

both ‘clarkj’ and ‘jim’ are members of the queue pms_V3_5, and have
manipulate authority.

the mail alias has been set as:
rt-pms35: |"/opt/rt/bin/rt-mailgate pms_V3_5 correspond"

Thanks,
Jim.


#2

I’ve been going around in circles with this - but it is probably
something quite simple.

I am unable to create requests using the mail interface, unless I
configure the queue to accept create requests from non-members.
The users appear to be members of the queue, so I am not sure
what is wrong.

I don’t know what rules rt uses to determine if an email source equates
to a particular queue member. But, toward that positive recognition,
you might try:

  1. making sure you’re sending email from the same address as what you’ve
    told rt belongs to the queue member in question;

  2. making sure your email client doesn’t pervert your source address on
    emails it sends (so that it’s not what you think it is).

example reply from rt: ---------------------------------

Subject:
[RequestTracker #0] (_rt_system) RT Error: test 66
Date:
Wed, 9 Aug 2000 16:07:14 +1000 (EST)
From:
Jim Clark via RT rt@outbak.sop.dec.com
To:
clarkj@auss.sop.dec.com

There has been an error:
There has been an error with your request:
You don’t have permission to create requests in this queue

Your message is reproduced below:

test 66

Cheers,
Jim.

— Headers Follow —

From clarkj@auss.sop.dec.com Wed Aug 9 16:07:12 2000
Return-Path: clarkj@auss.sop.dec.com
Delivered-To: rt-pms35@outbak.sop.dec.com
Received: from lamhra.SOP.DEC.COM (lamhra.sop.dec.com [16.172.80.43])
by outbak.sop.dec.com (Postfix) with SMTP id 7C0991F0DD
for rt-pms35@outbak.sop.dec.com; Wed, 9 Aug 2000 16:07:12 +1000 (EST)
Received: by lamhra.sop.dec.com (UCX V4.2-21, OpenVMS V6.2 Alpha);
Wed, 9 Aug 2000 16:07:04 +1000
Sender: jim@outbak.sop.dec.com
Message-ID: 3990F50B.64C1004B@auss.sop.dec.com
Date: Wed, 09 Aug 2000 16:07:07 +1000
From: Jim Clark clarkj@auss.sop.dec.com
X-Mailer: Mozilla 4.73 [en] (X11; I; Linux 2.2.15-4mdk i586)
X-Accept-Language: en
MIME-Version: 1.0
To: rt-pms35@outbak.sop.dec.com
Subject: test 66
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

-------------------------------------------- Managed by Request Tracker

both ‘clarkj’ and ‘jim’ are members of the queue pms_V3_5, and have
manipulate authority.

the mail alias has been set as:
rt-pms35: |"/opt/rt/bin/rt-mailgate pms_V3_5 correspond"

Thanks,
Jim.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Happy Landings,

Jon Detert
Unix System Administrator, Milwaukee School of Engineering
1025 N. Broadway, Milwaukee, Wisconsin 53202


#3

Pretty simple: RT’s mail gateway does not trust your email return address
as proof that you are who you say you are. Your choices are to
allow non-members to create requests, look at the %rt user and %rt pass
commands for the mail gateway (I don’t remember if they’ll actually work for
this) or use a different create mechanism.

-jOn Wed, Aug 09, 2000 at 04:13:42PM +1000, Jim Clark wrote:

I’ve been going around in circles with this - but it is probably
something quite simple.

I am unable to create requests using the mail interface, unless I
configure the queue to accept create requests from non-members.
The users appear to be members of the queue, so I am not sure
what is wrong.

example reply from rt: ---------------------------------

Subject:
[RequestTracker #0] (_rt_system) RT Error: test 66
Date:
Wed, 9 Aug 2000 16:07:14 +1000 (EST)
From:
Jim Clark via RT rt@outbak.sop.dec.com
To:
clarkj@auss.sop.dec.com

There has been an error:
There has been an error with your request:
You don’t have permission to create requests in this queue

Your message is reproduced below:

test 66

Cheers,
Jim.

— Headers Follow —

From clarkj@auss.sop.dec.com Wed Aug 9 16:07:12 2000
Return-Path: clarkj@auss.sop.dec.com
Delivered-To: rt-pms35@outbak.sop.dec.com
Received: from lamhra.SOP.DEC.COM (lamhra.sop.dec.com [16.172.80.43])
by outbak.sop.dec.com (Postfix) with SMTP id 7C0991F0DD
for rt-pms35@outbak.sop.dec.com; Wed, 9 Aug 2000 16:07:12 +1000 (EST)
Received: by lamhra.sop.dec.com (UCX V4.2-21, OpenVMS V6.2 Alpha);
Wed, 9 Aug 2000 16:07:04 +1000
Sender: jim@outbak.sop.dec.com
Message-ID: 3990F50B.64C1004B@auss.sop.dec.com
Date: Wed, 09 Aug 2000 16:07:07 +1000
From: Jim Clark clarkj@auss.sop.dec.com
X-Mailer: Mozilla 4.73 [en] (X11; I; Linux 2.2.15-4mdk i586)
X-Accept-Language: en
MIME-Version: 1.0
To: rt-pms35@outbak.sop.dec.com
Subject: test 66
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

-------------------------------------------- Managed by Request Tracker

both ‘clarkj’ and ‘jim’ are members of the queue pms_V3_5, and have
manipulate authority.

the mail alias has been set as:
rt-pms35: |"/opt/rt/bin/rt-mailgate pms_V3_5 correspond"

Thanks,
Jim.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
I admit that X is the second worst windowing system in the world, but all the
others I’ve used are tied for first.


#4

Jesse wrote:

Pretty simple: RT’s mail gateway does not trust your email return address
as proof that you are who you say you are. Your choices are to
allow non-members to create requests, look at the %rt user and %rt pass
commands for the mail gateway (I don’t remember if they’ll actually work for
this) or use a different create mechanism.

Thanks Jesse. I had tried the %rt user/%rt pass commands, but without success.
I did not really wish to open up the system with the 'allow non-members to
create’
option, but found the relevant piece of perl and made a small change to map the
email address to a user_id for subsequent authentication. I feel this is a
better
compromise than providing indiscriminate create privilege.

If anyone else is interested in doing this, I can provide a patch.

disclaimer: I’m not a perl hacker! :slight_smile: