Contents partially missing from some tickets after upgrade


#1

I recently upgraded from 3.4.5 to 3.6.6.

I now have a situation where some of my tickets aren’t showing the
entire contents in the web interface. This has happened to some of
the old tickets, and some new ones as well. The symptoms are that
all correspondence isn’t showing up. When any new material is added
to such a ticket, the Updated: field gets updated to show the time
and date and the updater, and the update is mailed out to AdminCCs
as I’ve requested, but it can’t be viewed in the web interface at
all.

All help welcome.

Atro Tossavainen (Mr.) / The Institute of Biotechnology at
Systems Analyst, Techno-Amish & / the University of Helsinki, Finland,
+358-9-19158939 UNIX Dinosaur / employs me, but my opinions are my own.
< URL : http : / / www . helsinki . fi / %7E atossava / > NO FILE ATTACHMENTS


#2

Atro

I recently upgraded from 3.4.5 to 3.6.6.

I now have a situation where some of my tickets aren’t showing the
entire contents in the web interface. This has happened to some of
the old tickets, and some new ones as well. The symptoms are that
all correspondence isn’t showing up. When any new material is added
to such a ticket, the Updated: field gets updated to show the time
and date and the updater, and the update is mailed out to AdminCCs
as I’ve requested, but it can’t be viewed in the web interface at
all.

This sounds familiar, did you run rt-setup-database-3.6 ?

I don’t know what OS you’re on, but on debian

for y in schema acl insert; do
/usr/sbin/rt-setup-database-3.6 --action $y --datadir
/etc/request-tracker3.6/upgrade/3.5.1 --dba root;
done | tee rt-setup-database-3.6.LOG

worked for me. There’s probably and UPGRADE or README doc with this in.

Cheers
Toby

LEGAL NOTICE
Unless expressly stated otherwise, information contained in this
message is confidential. If this message is not intended for you,
please inform postmaster@ccdc.cam.ac.uk and delete the message.
The Cambridge Crystallographic Data Centre is a company Limited
by Guarantee and a Registered Charity.
Registered in England No. 2155347 Registered Charity No. 800579
Registered office 12 Union Road, Cambridge CB2 1EZ.


#3

Toby,

This sounds familiar, did you run rt-setup-database-3.6 ?

Yeah, I tried to. It’s not like I’m not reading the manuals when I
do stuff like this. :slight_smile:

The etc/upgrade/3.5.1 directory is empty in the rt-3.6.6 distribution.
I re-downloaded to verify. There’s nothing but “content” in there;
the 3.1.0, 3.3.0 and 3.3.11 directories have schema and acl modification
files as well.

For whatever it’s worth, this is on CentOS 4.x x86_64, and I’ve
installed RT manually rather than from prebuilt rpms.

Atro Tossavainen (Mr.) / The Institute of Biotechnology at
Systems Analyst, Techno-Amish & / the University of Helsinki, Finland,
+358-9-19158939 UNIX Dinosaur / employs me, but my opinions are my own.
< URL : http : / / www . helsinki . fi / %7E atossava / > NO FILE ATTACHMENTS


#4

Check for segfaults in your logs. If they are there, it sounds like
you’re getting hit with the Text::Quoted bug.
http://www.gossamer-threads.com/lists/rt/users/69899

Atro Tossavainen wrote:

I recently upgraded from 3.4.5 to 3.6.6.

I now have a situation where some of my tickets aren’t showing the
entire contents in the web interface. This has happened to some of
the old tickets, and some new ones as well. The symptoms are that
all correspondence isn’t showing up. When any new material is added
to such a ticket, the Updated: field gets updated to show the time
and date and the updater, and the update is mailed out to AdminCCs
as I’ve requested, but it can’t be viewed in the web interface at
all.

All help welcome.

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati