Configured users do not show up

Hi List,
another Problem with rt3.0.6 on Redhat 9.0:
I just started to configure RT a few days ago. Having configured 4 Users I
cannot see them since yesterday in most parts of RT, but they still can login:

  • Clicking Configuration=> users=>Select a user => there is no user visible
    If I do a search which leads to no user I get: No users matching search
    criteria found. If I do a search which should lead to a user I just see
    Users matching search criteria: without any user.
  • During ticket creation and comments I can set only nobody as owner
  • Configuration => groups => mygroup => Members shows all users which are
    already part of this group. nonmembers are not shown in the users Panel. If
    I remove a member I cannot readd him because he is not visible in the users
  • I have given all users all rights (I can see them in user rights pages)
    but still no change
  • I tried 3.0.7 pre1 => same

Looking with a SQL-tools on the database shows all users.

So the users are there and they are not.
Any ideas?


I found the problem browsing through rt.log.
During the last days a security enhancement tool (bastille) was installed.
This tool creates a userbased-TEMP Path in /tmp with very limited
access-rights. Therefore the root owned temp cannot be accessed by rt…
Removing this scripts (and therefore the TMP and TEMP paths in the user
profile) solved the problem.
Sorry for wasting your bandwith.
harald volz