Configure Fetchmail to create tickets

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now is
up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket. I
think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

In your fetchmail config, you tell fetchmail to send the emails it grabs to
a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda "/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue General
–action correspond"
Hope that helps.
Mike.On Wed, Jul 28, 2010 at 1:08 PM, George Simpson simpsongeorge68@gmail.comwrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now is
up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket. I
think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Thanks for the reply!

I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue General
–action correspond”

goes in the fetchmail.conf file right? I can do something like that for the
.fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?

Thanks for the help, and sorry for the complete lack of knowledge.

GeorgeOn Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.ca wrote:

In your fetchmail config, you tell fetchmail to send the emails it grabs to
a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda "/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue General
–action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson <simpsongeorge68@gmail.com wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now is
up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket. I
think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

I just added the argument to the .fetchmailrc file, and it returned a syntax
error before /usr/sbin/rt-mailgate, which means that the perl we have in
/user/bin/perl is wrong, right? there is both a perl and a perl5.8.8 file in
there, what does the syntax error mean in this case?

the line:

username helpdesk@mydomain.com password password ssl mda “/usr/bin/perl
/user/sbin/rt-mailgate --url http://localhost/rt3/ --queue helpdesk --action
correspond”

mydomain is set to my domain, and the password is imputed correctly.

Thanks!

GeorgeOn Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.ca wrote:

In your fetchmail config, you tell fetchmail to send the emails it grabs to
a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda "/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue General
–action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson <simpsongeorge68@gmail.com wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now is
up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket. I
think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.On Wed, Jul 28, 2010 at 2:24 PM, George Simpson simpsongeorge68@gmail.comwrote:

Thanks for the reply!

I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue General
–action correspond”

goes in the fetchmail.conf file right? I can do something like that for the
.fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?

Thanks for the help, and sorry for the complete lack of knowledge.

George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.cawrote:

In your fetchmail config, you tell fetchmail to send the emails it grabs
to a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com–queue General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now
is up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket. I
think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.

 FYI, our setup here has fetchmail running in the machine (ok, a

vm) RT is installed on, which I guess is different than some setups.
Main reason is that we did not want to run any scripts in the mail
server if we did not have to. We stole the basic idea from
http://www.oreillynet.com/linux/blog/2007/08/rt_mailgate.html: mail
goes to the rt email account, which then is queried by fetchmail
whenever it feels doing so (every 20s in our case). So, our
/etc/fetchmailrc looks like this:

set syslog;
set daemon 20;

poll "mail.domain.com"
with protocol imap
username rt password cookies
mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

And /etc/default/fetchmail kinda looks like this:

This file will be used to declare some vars for fetchmail

Uncomment the following if you don’t want localized log messages

export LC_ALL=C

If you want to specify any additional OPTION to the start

scripts specify them here

OPTIONS=…

Declare here if we want to start fetchmail. ‘yes’ or ‘no’

START_DAEMON=yes

As explained by Mike, you need to make sure that you know where
rt-mailgate and perl are hiding in your system.

Mauricio

Hi,

It’s still passing syntax errors, I have verified that the paths are right,
but its finding problems with the perl path. Is there anything that I am
doing wrong? I posted the line in my previous post.On Wed, Jul 28, 2010 at 12:02 PM, Mike Johnson mike.johnson@nosm.ca wrote:

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.

On Wed, Jul 28, 2010 at 2:24 PM, George Simpson <simpsongeorge68@gmail.com wrote:

Thanks for the reply!

I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue
General --action correspond"

goes in the fetchmail.conf file right? I can do something like that for
the .fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?

Thanks for the help, and sorry for the complete lack of knowledge.

George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.cawrote:

In your fetchmail config, you tell fetchmail to send the emails it grabs
to a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com–queue General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now
is up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket.
I think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

If you copy/pasted, the error would be you are missing a / infront of your
perl path…

not sure if you just missed that when you copy/pasted or not…On Wed, Jul 28, 2010 at 3:21 PM, George Simpson simpsongeorge68@gmail.comwrote:

Hi,

It’s still passing syntax errors, I have verified that the paths are right,
but its finding problems with the perl path. Is there anything that I am
doing wrong? I posted the line in my previous post.

On Wed, Jul 28, 2010 at 12:02 PM, Mike Johnson mike.johnson@nosm.cawrote:

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.

On Wed, Jul 28, 2010 at 2:24 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Thanks for the reply!

I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue
General --action correspond"

goes in the fetchmail.conf file right? I can do something like that for
the .fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?

Thanks for the help, and sorry for the complete lack of knowledge.

George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.cawrote:

In your fetchmail config, you tell fetchmail to send the emails it grabs
to a specific process. For RT to create a ticket from an email, you need to
give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com–queue General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it now
is up and running. However, we hit a snag while trying to set it up so that
people just sent emails to helpdesk@myurl.com and it creates a ticket.
I think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

/usr/bin/perl I think is what I wrote here, is that not correct?On Wed, Jul 28, 2010 at 12:57 PM, Mike Johnson mike.johnson@nosm.ca wrote:

If you copy/pasted, the error would be you are missing a / infront of your
perl path…

not sure if you just missed that when you copy/pasted or not…

On Wed, Jul 28, 2010 at 3:21 PM, George Simpson <simpsongeorge68@gmail.com wrote:

Hi,

It’s still passing syntax errors, I have verified that the paths are
right, but its finding problems with the perl path. Is there anything that I
am doing wrong? I posted the line in my previous post.

On Wed, Jul 28, 2010 at 12:02 PM, Mike Johnson mike.johnson@nosm.cawrote:

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.

On Wed, Jul 28, 2010 at 2:24 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Thanks for the reply!

I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue
General --action correspond"

goes in the fetchmail.conf file right? I can do something like that for
the .fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?

Thanks for the help, and sorry for the complete lack of knowledge.

George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.cawrote:

In your fetchmail config, you tell fetchmail to send the emails it
grabs to a specific process. For RT to create a ticket from an email, you
need to give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account and
sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com–queue General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson < simpsongeorge68@gmail.com> wrote:

Hello again.

We finally got fetchmail to work! thanks to everyone who helped, it
now is up and running. However, we hit a snag while trying to set it up so
that people just sent emails to helpdesk@myurl.com and it creates a
ticket. I think we have to set up aliases in fetchmail so that that email
address is forwarded to the RT helpdesk queue, but I cannot seem to find out
how to do it. Is there any documentation about doing this anywhere? I cannot
seem to find it here nor with the all-powerful google. Thanks in advance,
and I really appreciate everyones help!

George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

/usr/bin/perl I think is what I wrote here, is that not correct?

  What do you get by typing `which perl` in your machine?> On Wed, Jul 28, 2010 at 12:57 PM, Mike Johnson <mike.johnson@nosm.ca> wrote:

If you copy/pasted, the error would be you are missing a / infront of your
perl path…

not sure if you just missed that when you copy/pasted or not…

On Wed, Jul 28, 2010 at 3:21 PM, George Simpson simpsongeorge68@gmail.com wrote:

Hi,
It’s still passing syntax errors, I have verified that the paths are
right, but its finding problems with the perl path. Is there anything that I
am doing wrong? I posted the line in my previous post.

On Wed, Jul 28, 2010 at 12:02 PM, Mike Johnson mike.johnson@nosm.ca wrote:

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with /rt3),
and obviously the email server you are needing to pull emails from.

HTH.
Mike.

On Wed, Jul 28, 2010 at 2:24 PM, George Simpson simpsongeorge68@gmail.com wrote:

Thanks for the reply!
I am really new to all of this, I just became an Intern at this company
after one year of college and they asked me to set up RT. The
poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue
General --action correspond"
goes in the fetchmail.conf file right? I can do something like that for
the .fetchmailrc file, if that is the right one. The difference is that our
rt-mailgate path is usr/sbin/rt-mailgate is that all I put for “usr/bin/perl
/opt/rt3/bin/rt-mailgate”?
Thanks for the help, and sorry for the complete lack of knowledge.
George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson mike.johnson@nosm.ca wrote:

In your fetchmail config, you tell fetchmail to send the emails it
grabs to a specific process. For RT to create a ticket from an email, you
need to give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account
and sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com --queue
General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson simpsongeorge68@gmail.com wrote:

Hello again.
We finally got fetchmail to work! thanks to everyone who helped, it
now is up and running. However, we hit a snag while trying to set it up so
that people just sent emails to helpdesk@myurl.com and it creates a ticket.
I think we have to set up aliases in fetchmail so that that email address is
forwarded to the RT helpdesk queue, but I cannot seem to find out how to do
it. Is there any documentation about doing this anywhere? I cannot seem to
find it here nor with the all-powerful google. Thanks in advance, and I
really appreciate everyones help!
George

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I get /usr/bin/perl upon typing that command, but when I type which
rt-mailgate it cannot find it with that command, is that the problem?

[rpatel@ec02 ~]$ which perl
/usr/bin/perl
[rpatel@ec02 ~]$ which rt-mailgate
/usr/bin/which: no rt-mailgate in
(/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/home/rpatel/bin)On Wed, Jul 28, 2010 at 1:33 PM, Mauricio Tavares raubvogel@gmail.comwrote:

On Wed, Jul 28, 2010 at 4:26 PM, George Simpson simpsongeorge68@gmail.com wrote:

/usr/bin/perl I think is what I wrote here, is that not correct?

  What do you get by typing `which perl` in your machine?

On Wed, Jul 28, 2010 at 12:57 PM, Mike Johnson mike.johnson@nosm.ca wrote:

If you copy/pasted, the error would be you are missing a / infront of
your

perl path…

not sure if you just missed that when you copy/pasted or not…

On Wed, Jul 28, 2010 at 3:21 PM, George Simpson simpsongeorge68@gmail.com wrote:

Hi,
It’s still passing syntax errors, I have verified that the paths are
right, but its finding problems with the perl path. Is there anything
that I

am doing wrong? I posted the line in my previous post.

On Wed, Jul 28, 2010 at 12:02 PM, Mike Johnson mike.johnson@nosm.ca wrote:

Yes, this all goes into the .fetchmailrc file for the user executing
fetchmail, and yes, you’d have to adjust the settings to point to your
various pieces like perl, mailgate, RT url(note mine doesn’t end with
/rt3),

and obviously the email server you are needing to pull emails from.

HTH.
Mike.

On Wed, Jul 28, 2010 at 2:24 PM, George Simpson simpsongeorge68@gmail.com wrote:

Thanks for the reply!
I am really new to all of this, I just became an Intern at this
company

after one year of college and they asked me to set up RT. The
poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url http://rt.mydomain.com
–queue

General --action correspond"
goes in the fetchmail.conf file right? I can do something like that
for

the .fetchmailrc file, if that is the right one. The difference is
that our

rt-mailgate path is usr/sbin/rt-mailgate is that all I put for
"usr/bin/perl

/opt/rt3/bin/rt-mailgate"?
Thanks for the help, and sorry for the complete lack of knowledge.
George

On Wed, Jul 28, 2010 at 11:09 AM, Mike Johnson <mike.johnson@nosm.ca wrote:

In your fetchmail config, you tell fetchmail to send the emails it
grabs to a specific process. For RT to create a ticket from an
email, you

need to give the email to rt-mailgate.

You do this through the fetchmail config file.

This is an example of one grabbing email from a google apps account
and sending it to rt-mailgate

poll imap.gmail.com proto imap port 993:
username helpdesk@mydomain.com password mypassword ssl mda
"/usr/bin/perl /opt/rt3/bin/rt-mailgate --url
http://rt.mydomain.com --queue

General --action correspond"
Hope that helps.
Mike.

On Wed, Jul 28, 2010 at 1:08 PM, George Simpson simpsongeorge68@gmail.com wrote:

Hello again.
We finally got fetchmail to work! thanks to everyone who helped, it
now is up and running. However, we hit a snag while trying to set
it up so

that people just sent emails to helpdesk@myurl.com and it creates
a ticket.

I think we have to set up aliases in fetchmail so that that email
address is

forwarded to the RT helpdesk queue, but I cannot seem to find out
how to do

it. Is there any documentation about doing this anywhere? I cannot
seem to

find it here nor with the all-powerful google. Thanks in advance,
and I

really appreciate everyones help!
George

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.

Buy a copy at http://rtbook.bestpractical.com


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I get /usr/bin/perl upon typing that command, but when I type which
rt-mailgate it cannot find it with that command, is that the problem?

as root (or sudo),

find / -name rt-mailgate -print

I found it, the path is correct.

[root@ec02 ~]# find / -name rt-mailgate -print
/usr/sbin/rt-mailgate
/tmp/rt-3.8.8/bin/rt-mailgate
/etc/smrsh/rt-mailgate

It still has problems at /usr/bin/perl, is there any detailed set up guide
for fetchmail and RT on centos that helps with creating tickets via email?
thanks so much.On Wed, Jul 28, 2010 at 2:11 PM, George Simpson simpsongeorge68@gmail.comwrote:

I found it, the path is correct.

[root@ec02 ~]# find / -name rt-mailgate -print
/usr/sbin/rt-mailgate
/tmp/rt-3.8.8/bin/rt-mailgate
/etc/smrsh/rt-mailgate

All I can say is that there is something syntatically wrong with your
fetchmailrc file…

You have to figure out what you got wrong there.

man fetchmail and read up on the file to ensure everything is sound in
there.
HTH
Mike.On Wed, Jul 28, 2010 at 5:11 PM, George Simpson simpsongeorge68@gmail.comwrote:

I found it, the path is correct.

[root@ec02 ~]# find / -name rt-mailgate -print
/usr/sbin/rt-mailgate
/tmp/rt-3.8.8/bin/rt-mailgate
/etc/smrsh/rt-mailgate

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

It still has problems at /usr/bin/perl, is there any detailed set up guide
for fetchmail and RT on centos that helps with creating tickets via email?
thanks so much.

It would probably help if you copy-and-pasted the error messages,
rather than interpreting them for others :wink:

I assume the error is from the MDA line you posted?

mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

Did you try making that a single line?

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

I would copy and paste, but the terminal to the remote CentOS box is on
another computer. That line was one line, I didn’t know that it had been
formatted incorrectly. The syntax error says that there is an error at
/usr/bin/rt-mailgate which I assumed meant that the error was before that
argument, if that is incorrect please tell me. But I am going to read the
man page now and see if I can fix it. Ill post here again if I have any
problems, thanks to everyone who helped :smiley:

GeorgeOn Thu, Jul 29, 2010 at 6:23 AM, Rob MacGregor rob.macgregor@gmail.comwrote:

On Wed, Jul 28, 2010 at 23:24, George Simpson simpsongeorge68@gmail.com wrote:

It still has problems at /usr/bin/perl, is there any detailed set up
guide
for fetchmail and RT on centos that helps with creating tickets via
email?
thanks so much.

It would probably help if you copy-and-pasted the error messages,
rather than interpreting them for others :wink:

I assume the error is from the MDA line you posted?

mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

Did you try making that a single line?


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hi yeah, sorry for the http://localhost/rt3, its really something like
174.129.xxx.xxx/rt3, I’d be cruxified I put that here though. I will remove
the perl call, but how do I send an email from the command line?On Thu, Jul 29, 2010 at 9:42 AM, Joachim Thuau <Joachim.Thuau@heavy-iron.com wrote:

mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

A couple of thing to try:

· Mda “/usr/bin/perl …

o You listed mailgate in the smrsh, but not perl. You will need to
remove the /usr/bin/perl as it’s not needed (the script will call on it from
the #! at the top of rt-mailgate)

· --url https://localhost/

o Usually, people put an extra level for RT on their servers like
https://blah.tld/rt3/ (so that it’s easier to have un-authenticated icons
and stuff not managed by mod_perl (separating the various static and
non-static bits of RT. Are you sure that the URL above is the proper one?
You should also probably use the actual URL as seen from other hosts, as
there might be some code running that uses that to figure out where to put
it all…

And a couple of questions:

· Does RT-mailgate work with a dummy email from the command line?
You might want to confirm that all your parameters to mailgate are working…

· Confirm the URL to get to RT (open the web interface, at the
login prompt, and use that exact URL shown in the address bar)

I hope this gets you closer…

Thanks,

Jok

Add “tee” to the smrsh (“which tee” will tell you where it’s hiding)

And change the MDA line from

mda "rt-mailgate blhablhab"
to
mda “tee /tmp/maildump”

send one email, and see the content being dumped into the file “/tmp/maildump” – it’s all text.

From there, you can use the following to test:

cat /tmp/maildump | rt-mailgate blahblah from the command line to confirm that the rt-mailgate command is working…

Thanks,
JokFrom: George Simpson [mailto:simpsongeorge68@gmail.com]
Sent: Thursday, July 29, 2010 9:57 AM
To: Joachim Thuau
Cc: Rob MacGregor; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configure Fetchmail to create tickets

Hi yeah, sorry for the http://localhost/rt3, its really something like 174.129.xxx.xxx/rt3, I’d be cruxified I put that here though. I will remove the perl call, but how do I send an email from the command line?

I apologize for the confusion, but what do I put with the blahblahblah? a
path or the --queue general --action correspond part?On Thu, Jul 29, 2010 at 11:09 AM, Joachim Thuau < Joachim.Thuau@heavy-iron.com> wrote:

Add “tee” to the smrsh (“which tee” will tell you where it’s hiding)

And change the MDA line from

mda “rt-mailgate blhablhab”

to

mda “tee /tmp/maildump”

send one email, and see the content being dumped into the file
“/tmp/maildump” – it’s all text.

From there, you can use the following to test:

cat /tmp/maildump | rt-mailgate blahblah from the command line to confirm
that the rt-mailgate command is working…

Thanks,

Jok

From: George Simpson [mailto:simpsongeorge68@gmail.com]
Sent: Thursday, July 29, 2010 9:57 AM
To: Joachim Thuau
Cc: Rob MacGregor; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Configure Fetchmail to create tickets

Hi yeah, sorry for the http://localhost/rt3, its really something like
174.129.xxx.xxx/rt3, I’d be cruxified I put that here though. I will remove
the perl call, but how do I send an email from the command line?