Configuration in RT_SiteConfig.pm doesn't work


#1

Hello everyone

I am using RT 4.4.1. one of my colleagues reported a problem in viewing her ticket. RT gives her this error:

“Message body is not shown because it is too large”

I searched for this problem and I found out I should use this line in my RT_SiteConfig.pm file:

Set($MaxInlineBody, 0);

I put this line in that file and restarted these services:

  1. request-tracker4
  2. postgresql
  3. apache2

I was expecting my configuration to be set after restarting these services but nothing happend and I still get this error on my ticket.

is there any idea what is wrong it?

thanks in advance


#2

Did you clear the Mason cache?

rm -rf /opt/rt4/var/mason_data/obj

(adjust based on where you’ve install RT on your filesystem obviously). You can check what configuration RT has loaded by going to Admin->Tools->System Configuration as an admin user.

Also note from the RT documentation that “This option can be overridden by users in their preferences.”


#3

thank you for your reply!

I cleared mason cache and restarted all of my services but still it doesn’t work.
I also rebooted my server and nothing happend.
I checked my preferences for maximum inline body and it was set to default. do you have any idea what is happening?


#4

You said “for maximum inline body and it was set to default” de default it’s 25600 (25K).

@GreenJimll tell you about find de configuration Admin->Tools->System Configuration as an admin user:

MaxInlineBody_RT

I set a 1Mb in RT_SiteConfig.pm.

MaxInlineBody_RT_set

You can show us how you have configured these parameters and a screen of the error that is presented to help you.


#5

hi there

after changing my RT_SiteConfig.pm and setting “Set($MaxInlineBody, 0)” I checked my system configuration and saw this:
image
there is no error or even a log to tell me what is wrong with my configurations.

p.s: I also have this problem on setting StrictLinkACL parameter. by this line I want to disable it but nothing happen.

Set($StrictLinkACL, 0);


#6

Hi Dornaz
In the System configuration page, where does it say you pick the value up from, “core config” or “site config”?

regards
Garry


#7

Sounds like you’re editing the wrong file then. For example are you editing the default RT_SiteConfig.pm but have a copy in your local files that is overriding it?


#8

HI Dornaz

What happens in you set MaxInlineBody to something else, say 40000?

regards
Garry


#9

Hello
Both $StrictLinkACL and $MaxInlineBody are from “core config”.


#10

hi again

if I change MaxInlineBody to something like 4000000 or 300000 nothing will happen. again my MaxInlineBody parameter in Admin->Tools->System Configuration is set to default.


#11

hmmmm
How can I know which configuration file does my RT use?


#12

Look in Admin->Tools->System Configuration as it tells you there on the right hand side of each configuration item. On ours it either says “core config” or “site config” depending whether we’ve overridden the distributed config for each item or not.

The section called RT core variables also has a subsection called Loaded config files that shows you the explicit absolute paths of the config files that RT has loaded. If you’re editing a file that isn’t in that list, that would explain why your not seeing any changes being made.


#13

Many thanks to all for your useful answers.
@GreenJimll I was editing the wrong file. thank you for your answer