Chart and Show Results not showing correct query

Hello,

I have been using the Chart option in RT 3.8. When I click on Show Results
a different query is shown e.g. the most recent other saved query.

Also, it would be useful if the Total result in the table on the
Chart executed the full query. See attached chart.

Related to the above is the ability to edit the query than creates
a chart. I get inconsistent results so it looks like the query
linked to a saved Chart might be a clone of the query run when the
Chart is saved.

thanks Richard

I have been using the Chart option in RT 3.8. When I click on Show
Results a different query is shown e.g. the most recent other saved
query.

RT 3.8 is no longer receiving anything other than security bugfixes.
You also don’t specify which version of 3.8 you’re running, but it’s
quite likely that some of your complaints have been addressed in the
new charting in 4.2.

If you can replicate these bugs on 4.2, please let us know.

-kevin

I meant to say that we are using RT 4.0.17.On Wed, 18 Dec 2013, Kevin Falcone wrote:

Date: Wed, 18 Dec 2013 11:31:37 -0500
From: Kevin Falcone falcone@bestpractical.com
Reply-To: rt-users@lists.bestpractical.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Chart and Show Results not showing correct query

On Tue, Dec 17, 2013 at 09:12:17PM +0000, Richard McMahon wrote:

I have been using the Chart option in RT 3.8. When I click on Show
Results a different query is shown e.g. the most recent other saved
query.

RT 3.8 is no longer receiving anything other than security bugfixes.
You also don’t specify which version of 3.8 you’re running, but it’s
quite likely that some of your complaints have been addressed in the
new charting in 4.2.

If you can replicate these bugs on 4.2, please let us know.

-kevin

Also, it would be useful if the Total result in the table on the
Chart executed the full query. See attached chart.

Related to the above is the ability to edit the query than creates
a chart. I get inconsistent results so it looks like the query
linked to a saved Chart might be a clone of the query run when the
Chart is saved.

thanks Richard

Prof Richard G. McMahon | Phone (office) 44-(0)-1223-337519
Kavli Institute for Cosmology | (secretary) 1223-337516
Institute of Astronomy | (switchboard) 1223-337548
University of Cambridge |
Madingley Rd | FAX 1223-337523
Cambridge, CB3 OHA, UK. | mobile 7885-409019
Office: Kavli 22 |
email: rgm@ast.cam.ac.uk | WWW: http://www.ast.cam.ac.uk/~rgm
richardgmcmahon@gmail.com | skype: richardgmcmahon

I meant to say that we are using RT 4.0.17.

I’m not completely clear on the issue you’re seeing, but we did fix a
bug with the subnav links:

It’s a simple patch.