Charset

Greetings, after I had my RT-3.0.3 all configured, I’ve noticed that the
words on the Tickets are appearing with problems on the acents, for example
� or �.
I’ve tried to change directly in the database and it worked, so I believe
that I’m missing something on the RT.

Can anyone help me ?

Best Regards

rech

Joao Rechena
mailto:rechena@ispower.org
http://ispower.org
"Have no phear I is here"

Greetings, after I had my RT-3.0.3 all configured, I’ve noticed that
the words on the Tickets are appearing with problems on the acents,
for example á or â.
I’ve tried to change directly in the database and it worked, so I
believe that I’m missing something on the RT.
Can anyone help me ?

3.0.4 has fixes for international characters, so please upgrade and
report if that improved things. Especially, Jesse likes people to send
emails generating errors, if these still exist in the latest release of
RT.

Regards,
Harald

Greeting Harald I’ve upgraded to 3.0.4 and it keeps hapening

for instance � apears � I’ve changed on the mysql and appears good, but only
on a select to the database not on the browser…I’ve tried with IE, mozzila
, galeon…

:frowning:

Any ideias ?

Regards

rech

Harald Wagener writes:

Greetings, after I had my RT-3.0.3 all configured, I’ve noticed that the
words on the Tickets are appearing with problems on the acents, for
example � or �.
I’ve tried to change directly in the database and it worked, so I believe
that I’m missing something on the RT.
Can anyone help me ?

3.0.4 has fixes for international characters, so please upgrade and report
if that improved things. Especially, Jesse likes people to send emails
generating errors, if these still exist in the latest release of RT.

Regards,
Harald

Joao Rechena
mailto:rechena@ispower.org
http://ispower.org
"Have no phear I is here"

Hi,

Caracters have to be stored in the database in UTF-8. If you do your selects with an ISO tool (which a standard VT100 terminal is, or the MySQL control center in Windows), it is absolutely normal that you see caracters like à when reading an UTF coded string.
If you update the record, you then enter a ISO caracter in the database, it shows ok on a select, but can’t show OK from the RT interface. It looks like your browser does not switch to UTF-8 when it should
Try to look at the encoding menu in IE, and force it to use UTF-8. You should then see the RT interface correctly (the right setting is usually “automatic”).

Blaise
-----Message d’origine-----De : Joao Rechena [mailto:rechena@ispower.org]
Envoyé : mardi 15 juillet 2003 15:11
À : Harald Wagener
Cc : rt-users@lists.fsck.com
Objet : [rt-users] Re: Charset

Greeting Harald I’ve upgraded to 3.0.4 and it keeps hapening

for instance é apears à I’ve changed on the mysql and appears good, but only
on a select to the database not on the browser…I’ve tried with IE, mozzila
, galeon…

:frowning:

Any ideias ?

Regards

rech

Harald Wagener writes:

Greetings, after I had my RT-3.0.3 all configured, I’ve noticed that the
words on the Tickets are appearing with problems on the acents, for
example á or â.
I’ve tried to change directly in the database and it worked, so I believe
that I’m missing something on the RT.
Can anyone help me ?

3.0.4 has fixes for international characters, so please upgrade and report
if that improved things. Especially, Jesse likes people to send emails
generating errors, if these still exist in the latest release of RT.

Regards,
Harald

Joao Rechena
mailto:rechena@ispower.org
http://ispower.org
"Have no phear I is here"

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm