Charset problem

Hello!

I’m using RT 3.0.10 and I have a problem with charset recognition in
incomging emails:

X-Originalarrivaltime: 19 May 2004 12:12:41.0475 (UTC) FILETIME=[9571FD30:01C43D9A]
MIME-Version: 1.0
X-Spam-Status: No, hits=0.1 required=5.0 tests=TW_YY autolearn=ham version=2.62
X-Mailer: SquirrelMail (version 1.2.5)
content-type: text/plain; charset="utf-8"
Received:
Received:
Received:
Received:
Delivered-To: xxx@xxx
Return-Path: xxx@xxx
X-Original-To: xxx@xxx
X-Spam-Level:
Message-Id:
X-Spam-Checker-Version: SpamAssassin 2.62 (2004-01-11)
Content-Transfer-Encoding: 8bit
X-RT-Original-Encoding: iso-8859-1
Content-Length: 686

As you can see from the headers, it should be obvious that the
message has a utf-8 charset (and it does), but for some reason RT
decided that it should use iso-8859-1.

Also for some reason X-RT-Original-Encoding sometimes appears
multiple times with conflicting values. This is from a later message
in the same ticket as the headers above:

X-Originalarrivaltime: 25 May 2004 16:00:46.0172 (UTC) FILETIME=[70A389C0:01C44271]
MIME-Version: 1.0
In-Reply-To: xxx@xxx
X-Spam-Status: No, hits=0.1 required=5.0 tests=TW_YY autolearn=ham version=2.62
X-Mailer: SquirrelMail (version 1.2.5)
References: xxx@xxx
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: iso-8859-1
Received:
Received:
Received:
Received:
Delivered-To: xxx@xxx
Return-Path: xxx@xxx
X-Original-To: xxx@xxx
X-Spam-Level:
X-Spam-Checker-Version: SpamAssassin 2.62 (2004-01-11)
Message-Id: xxx@xxx
Content-Transfer-Encoding: 8bit
X-RT-Original-Encoding: utf-8
Content-Length: 1753

Has anyone else run into this problem before? Any ideas on a
solution?

-=[ Count Zero / TBH - Jussi H�m�l�inen - email count@theblah.fi ]=-

Hello!

I’m using RT 3.0.10 and I have a problem with charset recognition in
incomging emails:

Is it all messages or just some of them? If it’s just some of them,
could you send me one personally?

I’m using RT 3.0.10 and I have a problem with charset recognition in
incomging emails:

Is it all messages or just some of them? If it’s just some of them,
could you send me one personally?

Not all. Looks like messages sent with Eudora get utf8-botched, but
some others work just fine. I tested with Mozilla and RT seems to
handle those just fine. I’ll send an example directly to you.

-=[ Count Zero / TBH - Jussi H�m�l�inen - email count@theblah.fi ]=-