Category no longer shows in ticket

To list,

When we were in 3.6.4, the category for a Custom Field would show in the
"Modify Ticket" screen. This allowed a user to select the category from a
drop-down tab and thereby shorten the list of available values to choose
from for that CF.
Now in 3.8.7, that category list/drop-down no longer shows. I did link
the category to another CF and all those values are valid for the *
category*. It just doesn’t show up at all when in the "Modify Ticket’
screen. This is not what my users are used to, as we started using the *
category* field in the first place because they didn’t want to scroll thru a
bunch of values that didn’t apply to their respective groups (the
categoryitself).
Is anyone else getting this?

Thanks in advance.

Kenn
LBNL

Kenneth Crocker wrote:

To list,

When we were in 3.6.4, the category for a Custom Field would show in
the “Modify Ticket” screen. This allowed a user to select the
/category/ from a drop-down tab and thereby shorten the list of
available values to choose from for that CF.
Thats a new feature of 3.8.7. Read the Changelog and you’ll find a note
about it. For older installations there is a conversion script included.
I ran it but had problems afterwards that my Oracle based install of RT
didn’t work anymore. I think its fixed in the upcoming 3.8.8 or it was
an issue in 3.8.6 and fixed in 3.8.7.

Regards,

Joop

To list,

Any more on this? Is there a patch I can apply that will use the category
for a shorter value list?

Thanks.

Kenn
LBNLOn Fri, Apr 2, 2010 at 12:04 AM, Joop JoopvandeWege@mococo.nl wrote:

Kenneth Crocker wrote:

To list,

When we were in 3.6.4, the category for a Custom Field would show in the
"Modify Ticket" screen. This allowed a user to select the category from
a drop-down tab and thereby shorten the list of available values to choose
from for that CF.

Thats a new feature of 3.8.7. Read the Changelog and you’ll find a note
about it. For older installations there is a conversion script included. I
ran it but had problems afterwards that my Oracle based install of RT didn’t
work anymore. I think its fixed in the upcoming 3.8.8 or it was an issue in
3.8.6 and fixed in 3.8.7.

Regards,

Joop

To List,

Upon further testing, I’ve discovered that the Category of a Custom Field
only disappears from the Update Ticket screen when that Category is linked
to another CF. When I remove the link, the Category shows up again. Is this
normal? What is the reasoning for this?

Kenn
LBNLOn Thu, Apr 1, 2010 at 12:13 PM, Kenneth Crocker kfcrocker@lbl.gov wrote:

To list,

When we were in 3.6.4, the category for a Custom Field would show in the
"Modify Ticket" screen. This allowed a user to select the category from
a drop-down tab and thereby shorten the list of available values to choose
from for that CF.
Now in 3.8.7, that category list/drop-down no longer shows. I did link
the category to another CF and all those values are valid for the *
category*. It just doesn’t show up at all when in the "Modify Ticket’
screen. This is not what my users are used to, as we started using the *
category* field in the first place because they didn’t want to scroll thru
a bunch of values that didn’t apply to their respective groups (the *
category* itself).
Is anyone else getting this?

Thanks in advance.

Kenn
LBNL

Upon further testing, I’ve discovered that the Category of a Custom Field only disappears from
the Update Ticket screen when that Category is linked to another CF. When I remove the link,
the Category shows up again. Is this normal? What is the reasoning for this?

You really need to provide small screenshots and a reproduction method
for this, it sounds like you’ve misconfigured this new feature.

-kevin

Kevin,

Sorry it took so long for me to reply on this. I have a Custom Field named
"QA Approver" and it has a Category that is linked to another CF named
"ITBS-Dev-Group". A snap shot is below:

When looking at the CF in a ticket, there is no category drop-down to
shorten the display list:

and:

How do I get the ticket display to act like it did for 3.6.4 for categories?

P.S. If these screen shots don’t display, I’ve put them in a Word Doc and
attached them

Thanks.

Kenn
LBNLOn Tue, May 25, 2010 at 12:04 PM, Kevin Falcone falcone@bestpractical.comwrote:

On Tue, May 18, 2010 at 12:06:30PM -0700, Kenneth Crocker wrote:

Upon further testing, I’ve discovered that the Category of a Custom
Field only disappears from
the Update Ticket screen when that Category is linked to another CF.
When I remove the link,
the Category shows up again. Is this normal? What is the reasoning for
this?

You really need to provide small screenshots and a reproduction method
for this, it sounds like you’ve misconfigured this new feature.

-kevin

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

CF Displays.doc (43.5 KB)

Sorry it took so long for me to reply on this. I have a Custom Field named “QA Approver” and
it has a Category that is linked to another CF named “ITBS-Dev-Group”. A snap shot is below:

What happens when you apply ITBS-Dev-Group to the same queue where
you’re trying to use QA Approver?

-kevin

Kevin,

Kinda wierd. If I apply the CF “ITBS-Dev-Group” to the Queue AND I had
modified the CF to have that CF as a linked category, the display shows the
CF “ITBS-Dev-Froup” as a separate CF to be selected. However, if I apply the
CF “ITBS-Dev-Group” and do NOT link that CF as the category with any other
CF, then the display acts like it did in 3.6.4, which I think is the correct
display. IT shows as a drop-down right above each CF that applied to that
Queue. I would think that if I checked the link box to link one CF to
another as a category, it would show it each time right above the CF that
has a category. Instead, it is the other way around. I have to “uncheck” the
link box to get it right.

Kenn
LBNLOn Mon, Jun 28, 2010 at 12:23 PM, Kevin Falcone falcone@bestpractical.comwrote:

On Mon, Jun 28, 2010 at 12:05:19PM -0700, Kenneth Crocker wrote:

Sorry it took so long for me to reply on this. I have a Custom Field
named “QA Approver” and
it has a Category that is linked to another CF named “ITBS-Dev-Group”.
A snap shot is below:

What happens when you apply ITBS-Dev-Group to the same queue where
you’re trying to use QA Approver?

-kevin

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Kinda wierd. If I apply the CF “ITBS-Dev-Group” to the Queue AND I had modified the CF to have
that CF as a linked category, the display shows the CF “ITBS-Dev-Froup” as a separate CF to be
selected.

Yes, and when you select a value from ITBS-Dev-Group it will load the proper
set of values into QA Approver.

This is the way this UI works in 3.8

You do not want the 3.6 behavior, it was broken in an incredible
number of ways.

-kevin

Kevin,

Yes, I see now. I use this Category(value) for 3 different Custom FIelds. If
I link them and then apply it, the user only has to select their category
once and then it’s set for all the CF’s that use it. Kool. That saves a few
selection entries and therefore time.

Thanks.

Kenn
LBNLOn Mon, Jun 28, 2010 at 1:01 PM, Kevin Falcone falcone@bestpractical.comwrote:

On Mon, Jun 28, 2010 at 12:41:35PM -0700, Kenneth Crocker wrote:

Kinda wierd. If I apply the CF “ITBS-Dev-Group” to the Queue AND I had
modified the CF to have
that CF as a linked category, the display shows the CF
"ITBS-Dev-Froup" as a separate CF to be
selected.

Yes, and when you select a value from ITBS-Dev-Group it will load the
proper
set of values into QA Approver.

This is the way this UI works in 3.8

You do not want the 3.6 behavior, it was broken in an incredible
number of ways.

-kevin

However, if I apply the CF “ITBS-Dev-Group” and do NOT link that CF as
the category
with any other CF, then the display acts like it did in 3.6.4, which I
think is the correct
display. IT shows as a drop-down right above each CF that applied to
that Queue. I would think
that if I checked the link box to link one CF to another as a
category, it would show it each
time right above the CF that has a category. Instead, it is the other
way around. I have to
"uncheck" the link box to get it right.

Kenn
LBNL

On Mon, Jun 28, 2010 at 12:23 PM, Kevin Falcone <[1] falcone@bestpractical.com> wrote:

 On Mon, Jun 28, 2010 at 12:05:19PM -0700, Kenneth Crocker wrote:
 > Sorry it took so long for me to reply on this. I have a Custom

Field named “QA Approver”

 and
 > it has a Category that is linked to another CF named

“ITBS-Dev-Group”. A snap shot is

 below:

 What happens when you apply ITBS-Dev-Group to the same queue where
 you're trying to use QA Approver?

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hi List,
started today to setup our new webserver, running under centos (latest) with perl modules installed from freshrpms. inside the webui i can’t cleanly see the german umlaute, any hint which perl module i can check or update?

Thanks
Torsten

Kuehne + Nagel (AG & Co.) KG, Geschaeftsleitung: Hans-Georg Brinkmann (Vors.), Dirk Blesius, Reiner Heiken, Bruno Mang, Alfred Manke, Christian Marnetté, Mark Reinhardt, Jens Wollesen, Rainer Wunn, Sitz: Bremen, Registergericht: Bremen, HRA 21928, USt-IdNr.: DE 812773878, Persoenlich haftende Gesellschaft: Kuehne & Nagel A.G., Sitz: Contern/Luxemburg Geschaeftsfuehrender Verwaltungsrat: Klaus-Michael Kuehne

Sorry, found it, downgrade FCGI was the solution.

TorstenVon: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Brumm,Torsten / Kuehne + Nagel / Ham MI-ID
Gesendet: Montag, 28. Juni 2010 22:35
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] New RT Webserver install > german umlaute broken inwebui display (entered by webui)

Hi List,
started today to setup our new webserver, running under centos (latest) with perl modules installed from freshrpms. inside the webui i can’t cleanly see the german umlaute, any hint which perl module i can check or update?

Thanks
Torsten

Kühne + Nagel (AG & Co.) KG, Geschäftsleitung: Hans-Georg Brinkmann (Vors.), Dirk Blesius, Reiner Heiken, Bruno Mang, Alfred Manke, Christian Marnetté, Mark Reinhardt, Jens Wollesen, Rainer Wunn, Sitz: Bremen, Registergericht: Bremen, HRA 21928, USt-IdNr.: DE 812773878, Persönlich haftende Gesellschaft: Kühne & Nagel A.G., Sitz: Contern/Luxemburg, Geschäftsführender Verwaltungsrat: Klaus-Michael Kühne