Can't notify group about new ticket

I’m trying to send an email to members of the IT group when a ticket is created. The IT group has 4 members. All 4 members are watchers on the default queue, the only queue. My Template is:

RT-Attach-Message: yes

A new ticket was created in the {$Ticket->QueueObj->Name} queue.

Requestors: {$Ticket->RequestorAddresses}
Ticket <URL: {$RT::WebURL}Ticket/Display.html?id={$Ticket->id} >

{$Transaction->Content()}

But the log reports that it can’t find any recipients:

[Thu Mar 21 15:31:33 2013] [info]: rt-4.0.10-19257-1363879893-1009.116-4-0@mydomain.com #116/798 - Scrip 4 On Create Notify Everyone (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:285)
[Thu Mar 21 15:31:33 2013] [info]: rt-4.0.10-19257-1363879893-1009.116-4-0@mydomain.com No recipients found. Not sending. (/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:385)

I’d really appreciate any help anyone can offer.

Hi,

Try the following command:

./sbin/rt-email-group-admin --help

Your approach may work, but you should check content that is generated
by the template. To do this you have to add some debug logging to RT
code. I see “$group>MemberE…” while it should be
“$group->MemberE…”, not sure why you don’t see error in logs. It’s
valid perl code :), but still should fail with run time error.On Thu, Mar 21, 2013 at 7:40 PM, Warren H. Prince wprince@princelaw.com wrote:

I’m trying to send an email to members of the IT group when a ticket is created. The IT group has 4 members. All 4 members are watchers on the default queue, the only queue. My Template is:

To: { my $group = RT::Group->new( $RT::SystemUser ); $group->LoadUserDefinedGroup(“IT”); $group>MemberEmailAddressesAsString; }

RT-Attach-Message: yes

A new ticket was created in the {$Ticket->QueueObj->Name} queue.

Subject: {$Transaction->Subject || $Ticket->Subject || “(No subject given)”}
Requestors: {$Ticket->RequestorAddresses}
Ticket <URL: {$RT::WebURL}Ticket/Display.html?id={$Ticket->id} >

{$Transaction->Content()}

But the log reports that it can’t find any recipients:

[Thu Mar 21 15:31:33 2013] [info]: rt-4.0.10-19257-1363879893-1009.116-4-0@mydomain.com #116/798 - Scrip 4 On Create Notify Everyone (/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:285)
[Thu Mar 21 15:31:33 2013] [info]: rt-4.0.10-19257-1363879893-1009.116-4-0@mydomain.com No recipients found. Not sending. (/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:385)

I’d really appreciate any help anyone can offer.

Best regards, Ruslan.

Thanks Ruslan,
It took me several days to get back to this, but following the example in rt-email-group-admin did work. We’re receiving notices now.

–Warren