Can't install the PerlModule 5.8.3?

Hello,

I used the Yum to install RT correctly, however, I
encountered a lot of problem in the configuration
stages.
Did anyone encounter the following problem?

[root@osg-tg2 bin]# ./httpd -k start
Syntax error on line 421 of
/usr/local/apache2/conf/httpd.conf:
Invalid command ‘PerlModule’, perhaps misspelled or
defined by a module not included in the server
configuration

Then I tried to install this PerlModule, however, I
couldn’t do it successfully even with CPAN. Can anyone
give me a hand?

Thanks,
–Paul

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Hello,

I used the Yum to install RT correctly, however, I
encountered a lot of problem in the configuration
stages.
Did anyone encounter the following problem?

[root@osg-tg2 bin]# ./httpd -k start
Syntax error on line 421 of
/usr/local/apache2/conf/httpd.conf:
Invalid command ‘PerlModule’, perhaps misspelled or
defined by a module not included in the server
configuration

Then I tried to install this PerlModule, however, I
couldn’t do it successfully even with CPAN. Can anyone
give me a hand?

is ypu installing rt with mod_perl of *cgi

are you trying to install mod_perl 1 or 2 ?

can you post the error log please.

[root@osg-tg2 rt-3.4.5]# yum install rt
Gathering header information file(s) from server(s)
Server: Fedora Linux / stable for Red Hat Linux 9
(i386)
Server: Macromedia Flash Player for Red Hat Linux 9
Server: Red Hat Linux 9 (i386)
Server: Red Hat Linux 9 (i386) updates
Server: RT 3.4.x, updates and extra perl module
packages
Finding updated packages
Downloading needed headers
rt is installed and is the latest version.

I checked the yum installation again. It looks like
above. Actually I am not quite sure what type of
mod-perl I was installing. I just followed the
instructions to install that. Because it is mentioned
in the document we have to use Perl 5.8.3 or later. I
suspect that it is the reason that the http server
complains.

Actually I checked the version of perl in my machine.

/////////////////////////////////////////
[root@osg-tg2 bin]# perl -v

This is perl, v5.8.8 built for i686-linux
the Perl Home Page.
////////////////////////////////////////

But I don’t know where to check the perl module you
mentioned and could you give me some hints? And where
should I find the log file? There is no log file for
my httpd server since it even didn’t start up.

–Paul— Chaim Rieger chaim.rieger@gmail.com wrote:

On Feb 17, 2006, at 1:15 PM, zhou jian wrote:

Hello,

I used the Yum to install RT correctly, however, I
encountered a lot of problem in the configuration
stages.
Did anyone encounter the following problem?

[root@osg-tg2 bin]# ./httpd -k start
Syntax error on line 421 of
/usr/local/apache2/conf/httpd.conf:
Invalid command ‘PerlModule’, perhaps misspelled
or
defined by a module not included in the server
configuration

Then I tried to install this PerlModule, however,
I
couldn’t do it successfully even with CPAN. Can
anyone
give me a hand?

is ypu installing rt with mod_perl of *cgi

are you trying to install mod_perl 1 or 2 ?

can you post the error log please.

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

I just simply followed with yum installation as below.
And because we are students and don’t have money to
buy commercial support, do you know where can I find
some good document to configure the installation?

http://wiki.bestpractical.com/index.cgi?RPMInstall
Installation Notes
With yum

RT’s three step install procedure:

  1. Download the file:
    http://campus.fct.unl.pt/paulomatos/rt/repository/3.4.x/rt-3.4.x.repo

  2. Copy it to /etc/yum.repos.d/ or

cat rt-3.4.x.repo >> /etc/yum.conf

  1. Then type, as ‘root’:

yum install rt rt-mail-dispatcher

You’ll have rt installed in no time… then all you
have to do is configure a few settings as the messages
suggest.

Note: Depending upon which Perl modules you had
installed in the past, you may have to update before
installing via yum. If a whole lot of dependency
errors display when you run yum install, then type the
following:

yum update
yum install rt rt-mail-dispatcher

Without yum

Just download everything to a directory and do:

rpm -Uvh *.rpm

Post Installation Notes

A user pointed me out that he was in such a hurry to
try it out he lost the messages that appeared after
install. He also suggested I created a file with those
messages inside. Meanwhile here they are:

* rt

cp /etc/rt/RT_Config.pm /etc/rt/RT_SiteConfig.pm

to generate an editable site config file.

You must now configure RT by editing
/etc/rt/RT_SiteConfig.pm and
/etc/httpd/conf.d/rt.conf.

(You will definitely need to set RT’s database
password before continuing.
Not doing so could be very dangerous)

After that, you need to initialize RT’s database by
running

/usr/sbin/rt-setup-database --action init \
–dba root --prompt-for-dba-password

If something goes wrong you can always drop
everything, by executing

/usr/sbin/rt-setup-database --action drop \
–dba root --prompt-for-dba-password

* rt-mail-dispatcher

You must now configure somethings by editing
/var/rt/home/.procmailrc,
please read
/usr/share/doc/rt-3.4.4/README.mail-dispatcher.

Upgrading Notes

If you are upgrading, take a look at
/usr/share/doc/rt-3.4.4/README, step 7 (the files
are under /etc/rt/upgrade) and
/usr/share/doc/rt-3.4.4/UPGRADING.

To Do / Future directions

* Integrate RT3StatisticsPackage as a RPM package

and its dependencies;
* Provide a sample HTTPS configuration and the
dependencies associated (done);
* Apply patches to solve current known and solved
problems with RT;
* Update to new RT release when it’s out;
* Support RT on PostgreSQL;

Although there are some interdependencies among this
list there is in no particular order at the moment.— Chaim Rieger chaim.rieger@gmail.com wrote:

On Feb 17, 2006, at 1:15 PM, zhou jian wrote:

Hello,

I used the Yum to install RT correctly, however, I
encountered a lot of problem in the configuration
stages.
Did anyone encounter the following problem?

[root@osg-tg2 bin]# ./httpd -k start
Syntax error on line 421 of
/usr/local/apache2/conf/httpd.conf:
Invalid command ‘PerlModule’, perhaps misspelled
or
defined by a module not included in the server
configuration

Then I tried to install this PerlModule, however,
I
couldn’t do it successfully even with CPAN. Can
anyone
give me a hand?

is ypu installing rt with mod_perl of *cgi

are you trying to install mod_perl 1 or 2 ?

can you post the error log please.

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

ok lets start over,

are you having instalation questions/issues, or are you asking for
help in doing a local config (which means its installed properly)

if you are having trouble with the instalation, please post your
problem,

if you need help with confiiguration please start a new thread.

thanx

http://wiki.bestpractical.com/index.cgi?ManualInstallation
SETTING UP THE WEB INTERFACE

RT’s web interface is based around HTML::Mason, which
works best with the mod_perl perl interpreter within
Apache httpd. Alternatively, support for the FastCGI
(and plain CGI) interface is also provided as
’bin/mason_handler.fcgi’. Setting up either of these
can be fairly intricate; don’t get discouraged if it
takes you some time to get this right.

Probably I didn’t address more background to my
problem. I am setting up the WEB INTERFACE right now.
By your definition, it should be a configuration
problem. I configured like below:

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Then I tried to start the httpd server and encountered
the PerlModule problem.

I checked that my rt is installed in directly
/usr/local/rt
however, my apache server also installed the same
level,
/usr/local/apache

[root@osg-tg2 rt]# pwd
/usr/local/rt
[root@osg-tg2 rt]# ls
etc html lib po

I hope that I have given you enough information.
Thanks!

–Paul— Chaim Rieger chaim.rieger@gmail.com wrote:

ok lets start over,

are you having instalation questions/issues, or are
you asking for
help in doing a local config (which means its
installed properly)

if you are having trouble with the instalation,
please post your
problem,

if you need help with confiiguration please start a
new thread.

thanx

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Probably I didn’t address more background to my
problem. I am setting up the WEB INTERFACE right now.
By your definition, it should be a configuration
problem. I configured like below:

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Then I tried to start the httpd server and encountered
the PerlModule problem.

I checked that my rt is installed in directly
/usr/local/rt
however, my apache server also installed the same
level,
/usr/local/apache

ok so your rt is installed in /usr/local/rt but in apache you defined
it as /opt/rt3

please correct,

also can you please post the erros from your error log as well as the
output of which perl.

thanx