Can't complete installation at mod_perl1/apache1 step on osx

I’m trying to install RT3 on an OSX box, and can’t get past the Apache /
mod_perl setup step. I’m running:

MacOSX 10.2.6 (build 6L60)
Fink perl: 5.8.0 (<-- this is what I’m trying to use)
system perl: stock 5.6.0 (<-- trying to leave untouched)
Apache 1.3.27, as supplied by Apple
mod_perl as supplied by Apple
RT 3.0.2

The first installation phases went fine, but when I get to setting up the
web interface things break down. The README file contains a sample block
of Apache directives to use, and I have inserted this block with relevant
changes (paths, urls, etc) into my httpd.conf.

At this point, apachectl configtest breaks down with:

[Fri Jun 20 10:59:31 2003] [error] Can’t locate
Locale/Maketext/Lexicon.pm in @INC (@INC contains:
/usr/local/rt3/local/lib /usr/local/rt3/lib /sw/lib/perl5/5.6.0/darwin
/sw/lib/perl5/5.6.0 /sw/lib/perl5/darwin /sw/lib/perl5
/System/Library/Perl/darwin /System/Library/Perl /Library/Perl/darwin
/Library/Perl /Network/Library/Perl/darwin /Network/Library/Perl .
/usr/ /usr/lib/perl) at /usr/local/rt3/lib/RT/I18N.pm line 34.
BEGIN failed–compilation aborted at /usr/local/rt3/lib/RT/I18N.pm
line 34.
Compilation failed in require at /usr/local/rt3/lib/RT.pm line 29.
BEGIN failed–compilation aborted at /usr/local/rt3/lib/RT.pm line 29.
Compilation failed in require at /usr/local/rt3/bin/webmux.pl line 37.
BEGIN failed–compilation aborted at /usr/local/rt3/bin/webmux.pl line 37.
Compilation failed in require at (eval 5) line 1.

But the library it’s complaining about, Locale::Maketext::Lexicon, is
available via Fink under /sw/lib/perl5/site_perl/5.8.0 – and that seems
to be part of the @INC array, right? So I cheat a little bit, and edit
/usr/local/rt3/bin/webmux.pl so that this path shows up:

use lib ("/usr/local/rt3/local/lib",
"/usr/local/rt3/lib",
"/sw/lib/perl5/site_perl/5.8.0");

And for good measure, I edit that file’s shebang line to explicitly point
to Perl5.8.0 under /sw/bin (it already pointed to /sw/bin/perl (which
didn’t seem incorrect), but now it points to /sw/bin/perl5.8.0, which
seems like a sure bet).

Then the error changes to this:

[Fri Jun 20 11:22:24 2003] [error] Encode.pm compatibility layer for
5.006 not yet available. at
/sw/lib/perl5/site_perl/5.8.0/Encode/compat.pm line 21.
Compilation failed in require at /usr/local/rt3/lib/RT/I18N.pm line 39.
BEGIN failed–compilation aborted at /usr/local/rt3/lib/RT/I18N.pm line
41.
Compilation failed in require at /usr/local/rt3/lib/RT.pm line 29.
BEGIN failed–compilation aborted at /usr/local/rt3/lib/RT.pm line 29.
Compilation failed in require at /usr/local/rt3/bin/webmux.pl line 38.
BEGIN failed–compilation aborted at /usr/local/rt3/bin/webmux.pl line
38.
Compilation failed in require at (eval 5) line 1.

So for some reason, Apple’s Perl 5.6.0 & its libraries seem to be masking
the newer stuff, and I can’t get past this.

Apologies if this has been discussed to death on the list already, I did
check the archives and couldn’t find any relevant material discussing the
Encode.pm error above. If this has been discussed and someone can point me
towards a URL where it was discussed, that would shut me up :slight_smile:

Yay “I can’t install your software” questions… :slight_smile:

Chris Devers

I’m trying to install RT3 on an OSX box, and can’t get past the Apache /
mod_perl setup step. I’m running:

MacOSX 10.2.6 (build 6L60)
Fink perl: 5.8.0 (<-- this is what I’m trying to use)
system perl: stock 5.6.0 (<-- trying to leave untouched)
Apache 1.3.27, as supplied by Apple
mod_perl as supplied by Apple

This is your problem. if you want to use a non-stock perl, you need to
build a non-stock mod_perl to go with it.

RT 3.0.2

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

I’m trying to install RT3 on an OSX box, and can’t get past the Apache /
mod_perl setup step. I’m running:

MacOSX 10.2.6 (build 6L60)
Fink perl: 5.8.0 (<-- this is what I’m trying to use)
system perl: stock 5.6.0 (<-- trying to leave untouched)
Apache 1.3.27, as supplied by Apple
mod_perl as supplied by Apple

This is your problem. if you want to use a non-stock perl, you need to
build a non-stock mod_perl to go with it.

Ahh, okay, that makes a lot of sense.

Thanks, I can take it from here then.

Chris Devers cdevers@{boston.com,cis.usouthal.edu}