Broken permissions on HelpDesk Default Installation


I’ve got a default installation of RT (docker/netsandbox/) with a default HelpDesk extension installation.

While following along with the YouTube video I get stuck when my user creates a ticket, “No permission to view newly created ticket #1.”

Error is present regardless of privileged/unprivileged user, I’ve tried tweaking the permissions of the Queue/Group to no avail – but my understanding is it should work out of the box.

Any recommendations? Thanks.

Can you see the ticket OK with a user with superuser powers (either enoch root or an admin account you’ve created)? If so, you probably want to give Requestor rights to see the ticket in the queue. And you’ll need to give staff users rights to the queue as well so that they can interact with it.

Thanks for the quick reply,

I have tweaked the Requestor rights and that does seem to have fixed the issue – partially. Now when a user creates a ticket they can see it, but when they go back home (SelfService) no tickets are viewable in ‘My Open Tickets’ or ‘My Closed Tickets’

I have gone ahead and given every category every permission for both the support group and queue, still the same issue. I think it must be some kind of bug?

I have linked a screenshot of my view.

Thanks again

Hi Spatterlight,
Not sure what rights you have given but we give the Everyone and Requestor roles the following rights and it seems to work for us. Reply to tickets, View Queue and View ticket summaries.
Hope this helps.