Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?

Best regards

Allan Eising

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found
in RT_Config.pm)

it sounds like something is failing in mason.On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

did you complete the schema upgrade as noted in UPGRADE.mysql?On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

(once again with rt-users as CC)

I did an upgrade with rt-setup-database –dba root
–prompt-for-dba-password –action upgrade if that’s what you mean?On Tue, Nov 11, 2008 at 3:31 PM, John nimbius@sdf.lonestar.org wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

Med venlig hilsen / Best regards

Allan Eising
Ørestads Boulevard 37D, 3. tv
2300 København S

+45 22420772
allan.eising@gmail.com
http://www.linkedin.com/in/aeising

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

AllanOn Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

yes. you have to run that regardless, just because youre upgrading from a
verison of RT older than 3.8.1…like i said, rather poorly worded in the
docs. sorry.On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:56:36 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

Allan

On Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

I see… I had hoped the upgrade scripts took care of those schema
changes, but I’ll try to run the schema script later tonight, when rt
traffic is low.

Thanks for the help so far.

AllanOn Tue, Nov 11, 2008 at 3:58 PM, John nimbius@sdf.lonestar.org wrote:

yes. you have to run that regardless, just because youre upgrading from a
verison of RT older than 3.8.1…like i said, rather poorly worded in the
docs. sorry.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:56:36 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

Allan

On Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be
found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

I just ran the schema upgrade file (schema.mysql-4.0-4.1.pl), and it
gave me a lot of sql commands.

As it required me to type the username and password to mysql, I assume
it executed those commands, or am I wrong here?

AllanOn Tue, Nov 11, 2008 at 4:02 PM, Allan Eising allan.eising@gmail.com wrote:

I see… I had hoped the upgrade scripts took care of those schema
changes, but I’ll try to run the schema script later tonight, when rt
traffic is low.

Thanks for the help so far.

Allan

On Tue, Nov 11, 2008 at 3:58 PM, John nimbius@sdf.lonestar.org wrote:

yes. you have to run that regardless, just because youre upgrading from a
verison of RT older than 3.8.1…like i said, rather poorly worded in the
docs. sorry.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:56:36 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

Allan

On Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be
found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

the first script you run will create (or should be redirected to) a file.
importing that file into mysql is the next step as you need to run those
commands against the database nowOn Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 17:35:10 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I just ran the schema upgrade file (schema.mysql-4.0-4.1.pl), and it
gave me a lot of sql commands.

As it required me to type the username and password to mysql, I assume
it executed those commands, or am I wrong here?

Allan

On Tue, Nov 11, 2008 at 4:02 PM, Allan Eising allan.eising@gmail.com wrote:

I see… I had hoped the upgrade scripts took care of those schema
changes, but I’ll try to run the schema script later tonight, when rt
traffic is low.

Thanks for the help so far.

Allan

On Tue, Nov 11, 2008 at 3:58 PM, John nimbius@sdf.lonestar.org wrote:

yes. you have to run that regardless, just because youre upgrading from a
verison of RT older than 3.8.1…like i said, rather poorly worded in the
docs. sorry.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:56:36 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

Allan

On Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be
found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

Hi,

I just wanted to follow up and tell you that running the upgrade
script solved the problem.

Thank you very much for your help!

AllanOn Tue, Nov 11, 2008 at 6:48 PM, John nimbius@sdf.lonestar.org wrote:

the first script you run will create (or should be redirected to) a file.
importing that file into mysql is the next step as you need to run those
commands against the database now

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 17:35:10 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I just ran the schema upgrade file (schema.mysql-4.0-4.1.pl), and it
gave me a lot of sql commands.

As it required me to type the username and password to mysql, I assume
it executed those commands, or am I wrong here?

Allan

On Tue, Nov 11, 2008 at 4:02 PM, Allan Eising allan.eising@gmail.com wrote:

I see… I had hoped the upgrade scripts took care of those schema
changes, but I’ll try to run the schema script later tonight, when rt
traffic is low.

Thanks for the help so far.

Allan

On Tue, Nov 11, 2008 at 3:58 PM, John nimbius@sdf.lonestar.org wrote:

yes. you have to run that regardless, just because youre upgrading from
a
verison of RT older than 3.8.1…like i said, rather poorly worded in
the
docs. sorry.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:56:36 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Cc: Jon Tollerton jtollerton@zoominternet.net,
rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

So, what you are saying is that if I did not upgrade mysql but only
RT, I still have to run the mysql schema upgrades?

Allan

On Tue, Nov 11, 2008 at 3:52 PM, John nimbius@sdf.lonestar.org wrote:

ok, so this is deceptive…read once more…

“If you’re upgrading RT from versions prior to 3.8.0 then you MUST
follow
instructions below.”

yeah, it still means you have to run it.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:47:57 +0100
From: Allan Eising allan.eising@gmail.com
To: Jon Tollerton jtollerton@zoominternet.net
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Blank page annoyance

I have 4.005 installed, so this is not the issue.

However, I pulled the package off fedora’s rawhide repository, so I
suspect some incompatibilities there. It’s the version that will be
released with the upcoming fedora core 10, so I hope when I do the
full upgrade upon release, it will be fixed.

On Tue, Nov 11, 2008 at 3:44 PM, Jon Tollerton jtollerton@zoominternet.net wrote:

If this is mysql, don’t take DBD::mysql past 4.006

http://rt.cpan.org/Public/Bug/Display.html?id=37027

John wrote:

did you complete the schema upgrade as noted in UPGRADE.mysql?

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 15:29:12 +0100
From: Allan Eising allan.eising@gmail.com
To: John nimbius@sdf.lonestar.org
Subject: Re: [rt-users] Blank page annoyance

It’s an upgrade.

The most consistent error I get from my httpd log is:

[Tue Nov 11 15:27:02 2008] [notice] child pid 10058 exit signal
Segmentation fault (11)

I’ll try and see if I can update mod_perl and DBI/DBD…

Allan

On Tue, Nov 11, 2008 at 3:08 PM, John nimbius@sdf.lonestar.org wrote:

Allan,
is this an upgrade or a new install?
do you see any errors in your webserver logs?
have you tried turning on RT logging and tracing? (settings can be
found
in
RT_Config.pm)

it sounds like something is failing in mason.

On Tue, 11 Nov 2008, Allan Eising wrote:

Date: Tue, 11 Nov 2008 14:33:15 +0100
From: Allan Eising allan.eising@gmail.com
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Blank page annoyance

Hi there,

I have a problem on my rt 3.8.1 installation. After using the web
interface for a few minutes, pages stop being generated, and when I
click a link, I receive a blank page. I can then log in again by
typing the url, and observe the same issue reappear after a short
while. I’ve checked my syslog, and it doesn’t cointain any
information
other than the fact that the user logged in.

Can anyone help me debug this problem?


Best regards

Allan Eising


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org