Bad Request

Hi, folks.

I have faced a problem when I’m using Request Tracker:

Bad Request

Your browser sent a request that this server could not understand.
Reason: You’re speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://rtracker.pop-sp.rnp.br/

Apache/2.2.9 (Debian) mod_ssl/2.2.9 OpenSSL/0.9.8g mod_perl/2.0.4
Perl/v5.10.0 Server at rtracker.pop-sp.rnp.br Port 443

This is happening when I open/close/find a ticket.

Although, the system sent me a message with the new ticket and, after,
that ticket resolved.

I’ll appreciate any help.

Thanks,

Wagner Pereira

PoP-SP/RNP - Ponto de Presen�a da RNP em S�o Paulo
CCE/USP - Centro de Computa��o Eletr�nica da Universidade de S�o Paulo
http://www.pop-sp.rnp.br
Tel. (11) 3091-8901

Hi, folks.

I have faced a problem when I’m using Request Tracker:

++++++++++++++++++++
Bad Request

Your browser sent a request that this server could not understand.
Reason: You’re speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://rtracker.pop-sp.rnp.br/

What kind of protocol do you use (httpS it seems). What is your settings
in RT_SiteConfig.pm for WebPort/WebBaseURL (those settings changed
between RT 3.6 and RT 3.8).
Maybe you were previously using HTTP and turned on HTTPS in apache
without RT configuration update?

Hi, Emmanuel.

What kind of protocol do you use (httpS it seems). What is your settings
in RT_SiteConfig.pm for WebPort/WebBaseURL (those settings changed
between RT 3.6 and RT 3.8).

THE WEBSERVER:

Set($WebPath , “/rt”);
Set($WebBaseURL , “http://rt.pop-sp.rnp.br”);

Maybe you were previously using HTTP and turned on HTTPS in apache
without RT configuration update?

Well, I tried to change the WebBaseURL for https but didn’t work, although.

Wagner Pereira

PoP-SP/RNP - Ponto de Presen�a da RNP em S�o Paulo
CCE/USP - Centro de Computa��o Eletr�nica da Universidade de S�o Paulo
http://www.pop-sp.rnp.br
Tel. (11) 3091-8901

Emmanuel Lacour escreveu:> On Mon, Jan 11, 2010 at 06:13:25PM -0200, Wagner Pereira wrote:

Hi, folks.

I have faced a problem when I’m using Request Tracker:

++++++++++++++++++++
Bad Request

Your browser sent a request that this server could not understand.
Reason: You’re speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://rtracker.pop-sp.rnp.br/

What kind of protocol do you use (httpS it seems). What is your settings
in RT_SiteConfig.pm for WebPort/WebBaseURL (those settings changed
between RT 3.6 and RT 3.8).
Maybe you were previously using HTTP and turned on HTTPS in apache
without RT configuration update?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com