Bad From: header within mail send from rt


#1

hallalieh !

I have a problem with the mail send via rt.

The From: header always looks like…

RT <rt@YAST_ASK>

therefore a reply to these messages is quite difficult :frowning: !

I tried to use config.pm to configure this string…

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=“RT::CorrespondAddress.not.set”;

$CommentAddress=“RT::CommentAddress.not.set”;

but setting this parameters didn’t show any effect !?!

Any ideas ?

I am using rt 1.3.81.

Thanks for your help and regards from Germany and…

Gerd.

±----------------------- Gerd Nienhaus --------------------------+
| Orthogon GmbH, Hastedter Osterdeich 222, D-28207 Bremen |
| E-Mail: Gerd Nienhaus nienhaus@orthogon.de |
±— Tel.: +49 (0)421 20122-0/-53, FAX: +49 (0)421 20122-999 ----+

ORTHOGON and ODS Toolbox are registered trademarks of Orthogon GmbH


#2

| The From: header always looks like…
|
| RT <rt@YAST_ASK>
±–>8

Edit /etc/rc.config and change the value of FROM_HEADER, then run
"/sbin/SuSEconfig --nonewpackage".

brandon s. allbery [os/2][linux][solaris][japh] allbery@kf8nh.apk.net
system administrator [WAY too many hats] allbery@ece.cmu.edu
electrical and computer engineering KF8NH
carnegie mellon university [“better check the oblivious first” -ke6sls]


#3

aloha Jess, hi Brandon !

Jesse wrote:

have you tried setting the queue’s return address in Admin/Queues ?

Yes I did several tests with the ‘Correspondence Address:’, but
everything
after an ‘@’ seems to be ignored ?!?

Everything before an ‘@’ will be added to the From header in front
of the ‘@YAST_ASK’ !

Additionally the ‘@YAST_ASK’ will be added !

Is that the intended behaviour ?

The solution Brandon provided works fine for me :slight_smile:

Thanks for your quick assistance…

and regards from Germany and…

Gerd.

±----------------------- Gerd Nienhaus --------------------------+
| Orthogon GmbH, Hastedter Osterdeich 222, D-28207 Bremen |
| E-Mail: Gerd Nienhaus nienhaus@orthogon.de |
±— Tel.: +49 (0)421 20122-0/-53, FAX: +49 (0)421 20122-999 ----+

ORTHOGON and ODS Toolbox are registered trademarks of Orthogon GmbH


#4

| Everything before an ‘@’ will be added to the From header in front
| of the ‘@YAST_ASK’ !
|
| Additionally the ‘@YAST_ASK’ will be added !
|
| Is that the intended behaviour ?
±–>8

The “YAST” should have been a clue: that has nothing to do with RT, it’s a
misconfiguration in SuSE’s YaST config file (/etc/rc.config). Your mailer
is supposed to append the local hostname to any email addresses that lack
one; because it was never set, it defaulted to YAST_ASK and that’s what the
mailer (sendmail, postfix, whatever) is appending.

brandon s. allbery [os/2][linux][solaris][japh] allbery@kf8nh.apk.net
system administrator [WAY too many hats] allbery@ece.cmu.edu
electrical and computer engineering KF8NH
carnegie mellon university [“better check the oblivious first” -ke6sls]