AWS RT5 Instance - DB Restore Table Full?


I’m trying to migrate our ancient 3.8.11 install over to a shiny new RT5 AWS instance. I’ve performed a sqldump and have restored it onto the new instance (dropped and created a fresh new db first though). All seems to work perfectly, apart from the final step of the make upgrade-database, when I’m presented with the following error - I’ve double checked the sqldump process (I’ve re-done it 3 times now) and have scp’d over the new backups in case there was anything wrong with the first one I tried, but I get the same error, at the same point each time.

Processing 4.5.2
Now populating database schema.
[27298] [Thu Oct 1 10:26:59 2020] [critical]: DBD::mysql::st execute failed: The table ‘Attachments’ is full at /home/admin/rt/sbin/…/lib/RT/H line 548. (/home/admin/rt/sbin/…/lib/
DBD::mysql::st execute failed: The table ‘Attachments’ is full at /home/admin/rt/sbin/…/lib/RT/ line 548.
Makefile:393: recipe for target ‘upgrade-database’ failed
make: *** [upgrade-database] Error 11

I should say that the restore seems to work fine, and that the new instance works perfectly, but I’m concerned that if we do start using this instance as our prod RT server, we’ll run into significant issues fairly quickly if the table is already full as a result of the import.

So, 2 questions I guess - does this issue need fixing, and if so, any pointers on how I’d go about it ?



When we did test migrations from RT 4.4.3/4 to RT5.0 test releases we found that we needed about three times the disc space for the migration than we needed in use, thanks to the table conversions in play. Sounds like you might have hit the same issue?