Autoreply stopped working

We have recently encountered a situation where auto replies have stopped
going out for all queues. The only recent changes have been to the
global scrip which sends them.

It had been pointed out that when people are listed as Ccs on a ticket
they don’t get the content of an email. I had modified the scrip to
include those people but decided they didn’t need the auto reply and
only needed the content of the email. I made another scrip to cover
this instead. After creating the second scrip I set the first one back
to On Create Notify Requestors with Global Template: Autoreply. Since
then, nothing goes out.

I’ve verified that it isn’t set to Disabled and that the Stage is
TransactionCreate.

Anyone else ever experience this and know what to do about it?

Mathew
Keep up with me and what I’m up to: http://theillien.blogspot.com

Yes to both.

Mathew

Roy El-Hames wrote:

Hi Matt;

Sorry to ask the obvious but I have falling to this trap many a times …
Is the template still there, and is the action on the script is still
set to On Create??

Roy

Mathew wrote:

We have recently encountered a situation where auto replies have
stopped going out for all queues. The only recent changes have been
to the global scrip which sends them.

It had been pointed out that when people are listed as Ccs on a ticket
they don’t get the content of an email. I had modified the scrip to
include those people but decided they didn’t need the auto reply and
only needed the content of the email. I made another scrip to cover
this instead. After creating the second scrip I set the first one
back to On Create Notify Requestors with Global Template: Autoreply.
Since then, nothing goes out.

I’ve verified that it isn’t set to Disabled and that the Stage is
TransactionCreate.

Anyone else ever experience this and know what to do about it?

Mathew

Keep up with me and what I’m up to: http://theillien.blogspot.com

Just in case you might have also cleaned up the template, make sure its
first line is blank.

Turn on debugging in your logs and stick logger commands into various parts
of the scrip so you can see what is going on.

At 04:05 AM 3/10/2008, Mathew wrote:

We have recently encountered a situation where auto replies have stopped
going out for all queues. The only recent changes have been to the
global scrip which sends them.

It had been pointed out that when people are listed as Ccs on a ticket
they don’t get the content of an email. I had modified the scrip to
include those people but decided they didn’t need the auto reply and
only needed the content of the email. I made another scrip to cover
this instead. After creating the second scrip I set the first one back
to On Create Notify Requestors with Global Template: Autoreply. Since
then, nothing goes out.

I’ve verified that it isn’t set to Disabled and that the Stage is
TransactionCreate.

Anyone else ever experience this and know what to do about it?

Mathew

Keep up with me and what I’m up to: http://theillien.blogspot.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Gene LeDuc, GSEC
Security Analyst
San Diego State University

Figured it out. The action I had set was “Notify Requestors” instead of
"Autoreply to Requestors".

Mathew

Gene LeDuc wrote:

Just in case you might have also cleaned up the template, make sure its
first line is blank.

Turn on debugging in your logs and stick logger commands into various
parts of the scrip so you can see what is going on.

At 04:05 AM 3/10/2008, Mathew wrote:

We have recently encountered a situation where auto replies have stopped
going out for all queues. The only recent changes have been to the
global scrip which sends them.

It had been pointed out that when people are listed as Ccs on a ticket
they don’t get the content of an email. I had modified the scrip to
include those people but decided they didn’t need the auto reply and
only needed the content of the email. I made another scrip to cover
this instead. After creating the second scrip I set the first one back
to On Create Notify Requestors with Global Template: Autoreply. Since
then, nothing goes out.

I’ve verified that it isn’t set to Disabled and that the Stage is
TransactionCreate.

Anyone else ever experience this and know what to do about it?

Mathew

Keep up with me and what I’m up to: http://theillien.blogspot.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Keep up with me and what I’m up to: http://theillien.blogspot.com