Auto reply Reply Address

RT Version 2.0.14 running on Redhat 7.3 with
Sendmail

I dug through the archives and the docs and did
find some reference to this, but nothing that
could fix my problem.

My RT is up and running with email to queues and
the web interface is working.

The one problem I have at the moment is the reply
address for the rt queues. I’d like to change it
manually but I can’t find a reference to change it
and somehow RT always pulls out the sub domain.
(Yes I know using sub domains is not preferred,
but this is the way I want to do it :slight_smile:

What I want is if I send mail to
rt@rt.mydomain.org the auto reply should reply
with the reply address rt@rt.mydomain.org. At the
moment RT is ripping out the rt. (sub domain) bit.
The reply address I want, which I setup on the web
interface, is attached at the bottom of the
message body, but it doesn’t affect the actual
reply address.

Any pointers in the right direction would be nice
(I’ve only been playing with RT for 3 days now,
but it’s been fun :wink:

Regards
Emile
Emile Coetzee
System Administrator
ExiNet/Eduflex
Tel: +27 21 448 4678
Fax: +27 21 448 4620
Cell: 082 3312160

I think what you are looking for is the correspondence address in the queue
setup menu.

Thanks,
RichardOn Wed, Oct 23, 2002 at 03:55:52PM +0200, Emile Coetzee wrote:

RT Version 2.0.14 running on Redhat 7.3 with
Sendmail

I dug through the archives and the docs and did
find some reference to this, but nothing that
could fix my problem.

My RT is up and running with email to queues and
the web interface is working.

The one problem I have at the moment is the reply
address for the rt queues. I’d like to change it
manually but I can’t find a reference to change it
and somehow RT always pulls out the sub domain.
(Yes I know using sub domains is not preferred,
but this is the way I want to do it :slight_smile:

What I want is if I send mail to
rt@rt.mydomain.org the auto reply should reply
with the reply address rt@rt.mydomain.org. At the
moment RT is ripping out the rt. (sub domain) bit.
The reply address I want, which I setup on the web
interface, is attached at the bottom of the
message body, but it doesn’t affect the actual
reply address.

Any pointers in the right direction would be nice
(I’ve only been playing with RT for 3 days now,
but it’s been fun :wink:

Regards
Emile

Emile Coetzee
System Administrator
ExiNet/Eduflex
Tel: +27 21 448 4678
Fax: +27 21 448 4620
Cell: 082 3312160


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

THERE IS ALMOST NO LEGAL, HIGH QUALITY CONTENT AVAILABLE ON THE INTERNET.
-Sen. Ernest Hollings D-S.C.

RT Version 2.0.14 running on Redhat 7.3 with
Sendmail

I dug through the archives and the docs and did
find some reference to this, but nothing that
could fix my problem.

My RT is up and running with email to queues and
the web interface is working.

The one problem I have at the moment is the reply
address for the rt queues. I’d like to change it
manually but I can’t find a reference to change it
and somehow RT always pulls out the sub domain.
(Yes I know using sub domains is not preferred,
but this is the way I want to do it :slight_smile:

What I want is if I send mail to
rt@rt.mydomain.org the auto reply should reply
with the reply address rt@rt.mydomain.org. At the
moment RT is ripping out the rt. (sub domain) bit.
The reply address I want, which I setup on the web
interface, is attached at the bottom of the
message body, but it doesn’t affect the actual
reply address.

Any pointers in the right direction would be nice
(I’ve only been playing with RT for 3 days now,
but it’s been fun :wink:

Regards
Emile

This works for me:

Our RT installation is ‘rt.farwestern.com’. It’s on a Red Hat
7.3/sendmail system whose /etc/mail/sendmail.mc includes this line:

Cwfarwestern.com

Don’t forget to run this as root after editing sendmail.mc:

/usr/bin/mc m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

In DNS, ‘rt.farwestern.com’ is an A record pointing to the public IP
address of the RH 7.3 system. I’m not 100% sure this is necessary (maybe
it’s OK if it’s a CNAME to the actual hostname?), but that’s what works
for me.

And, of course, RT itself is configured appropriately.

With this setup, outgoing mail from RT is sent from
’queuename@rt.farwestern.com’, even though the actual hostname is
different.

Another option might have been to use Sendmail’s ‘generics-domains’ and
’genericstables’ features, but I couldn’t get those to work.

Good luck

Graham Freeman
Manager of Information Technology
Far Western Anthropological Research Group, Inc.
+1 530 756 3941
graham@farwestern.com

Don’t forget to run this as root after editing sendmail.mc:

/usr/bin/mc m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

Whoops. That should read:

/usr/bin/m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

Also, don’t forget to run ‘/sbin/service sendmail restart’ to make the new
config take effect.

Graham Freeman
Manager of Information Technology
Far Western Anthropological Research Group, Inc.
+1 530 756 3941
graham@farwestern.com

That broke my sendmail :frowning:

I can still send mail to RT but i get no
autoreply’s

I’ve set the email addys for the queues, but they
only appear at the bottom of the auto reply (see
below). They don’t affect the reply addy used by
the automailer.
What would be nice if either RT used the addy
specified in the queue or there was an additional
setting to set that (HINT-HINT, NUDGE-NUDGE :slight_smile:

– Sample From RT Autoreply –
Greetings,

This message has been automatically generated
[SNIP]
in the subject line of all future correspondence
about this issue. To do so,
you may reply to this message.

                    Thank you,
                    rt@rt.myhosts.org

Regards
Emile

That broke my sendmail :frowning:

I can still send mail to RT but i get no
autoreply’s

I’ve set the email addys for the queues, but they
only appear at the bottom of the auto reply (see
below). They don’t affect the reply addy used by
the automailer.
What would be nice if either RT used the addy
specified in the queue or there was an additional
setting to set that (HINT-HINT, NUDGE-NUDGE :slight_smile:

– Sample From RT Autoreply –
Greetings,

This message has been automatically generated
[SNIP]
in the subject line of all future correspondence
about this issue. To do so,
you may reply to this message.

                    Thank you,
                    rt@rt.myhosts.org

Regards
Emile

Have you checked your ‘/etc/mail/local-host-names’ file and the
’/etc/mail/relay-domains’ files?

Also, what does /var/log/maillog say? Do you see evidence of RT trying to
mail you autoresponses?

If you’ll tar the contents of /etc/mail and e-mail it to me offlist, I’ll
examine your config and tell you what I think is wrong. I’ll post a
generalized (non-site-specific) summary of this to the list for public
benefit.

Command to run: ‘/bin/tar -cvf /var/tmp/etc_mail_to_graham.tar /etc/mail’

Graham Freeman
Manager of Information Technology
Far Western Anthropological Research Group, Inc.
+1 530 756 3941
graham@farwestern.com