Auto-created users not does not appear

Hi,

I have a lot of auto-created users in my RT installation, they are
readed from a LDAP directory when an e-mail is received.

The question is that those users do not appear on every drop-down, so I
can’t select them as search criteria and etc.

Is there a way to make them appear?

RT 3.6.1-4 - Debian package.

Thanks.

Fabio,

It all depends on how you grant rights' to the queues. If you have 

groups with the correct rights to the correct queues, then you will need
to add these users to one of your existing groups OR grant some of these
rights globally to “Everyone”, “Privileged”, “Requestor”, or whatever
case fits. You could also write some code (as a scrip) to add users to a
group using the info added to an account by LDAP. Either way, RT does
not automatically add users to user-defined groups, only system groups
and the “Requestor” role.
As far as searches go, I do believe that the “Requestor” field is
available for ALL searches as a role, not as individuals. For that, you
might want the search to sort on requestor or something. It depends on
what you are trying to do. Hope this helps.

Kenn
LBNLOn 3/26/2008 6:05 AM, F�bio M. Catunda wrote:

Hi,

I have a lot of auto-created users in my RT installation, they are
readed from a LDAP directory when an e-mail is received.

The question is that those users do not appear on every drop-down, so I
can’t select them as search criteria and etc.

Is there a way to make them appear?

RT 3.6.1-4 - Debian package.

Thanks.


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Mr. Crocker,

Good that the “mailbox full” message is ok, I was afraid that the list
could be down for some reason!

I did the SuperUser thing just for testing purpose, I was kind of
desperate, as it did not work, I removed it.

I was composing a huge message with all my groups, queues and users to
try to explain how things are, but then I realized that a specific queue
was without the “OwnTicket” privilege to the “Privileged” group, that
was cousing the problem.

Anyway, thanks a lot for your help, by now everything is ok!

[]'s, F�bio Catunda!

Kenneth Crocker escreveu: