Authentication troubles

*System information at the end of the email.

Problem:
When the “Login” page loads, I always get the following error when
attempting to authenticate “Your username or password is incorrect”

What I’ve tried so far:
I’ve reset the password by using the rtadmin command.

spliff:/opt/rt2/bin# ./rtadmin --user=root --password=“password”

User root Password: The new value has been set.
spliff:/opt/rt2/bin#

I know its modifying the password field because the hash changes in
MySQL database.

During the installation I followed the README file that came with the
src as well as the Debian installation notes found at
http://fsck.com/rtfm/article.html?id=1#156

So far I’ve tried stabbing a clear text password by using the "update"
command :> update Users set password=“password” where id=“3”;
id 3 happens to be root.

mysql> select id,name,password,privileged,disabled from Users where id=“3”;
| id | name | password | privileged | disabled |
| 3 | root | bIsoEXpW41pRk | 1 | 0 |
1 row in set (0.00 sec)

mysql>

I’ve dropped the db and re-ran make install twice so far (make testdeps
finds everything BTW) to no avail. So I know its installing right and
it has to be something with my configuration.

The last time I played with Request Tracker was in its ealier versions,
the configs don’t even look the same anymore…

I was hoping someone has run into this problem before - 'cause quite
frankly I’m lost…

I can’t confirm 100% that the scipts are talking to the mysql server
(nothing gets generated in the rt.log file…)
$LogToScreen = ‘error’;
$LogToFile = ‘debug’;
However I think its fair to assume that it is because when I stop the
mysql daemon and attempt to login, Apache gives me an internal
configuration error.

Does anyone ahve any ideas? My guess is that its something stupid and
simple that I’ve overlooked.

Thank you

— system information –
Linux spliff 2.2.20 #1 Sat Apr 20 11:45:28 EST 2002 i686 Celeron
(Mendocino) GenuineIntel GNU/Linux

ServerName spliff.vianet.ca

DocumentRoot /opt/rt2/WebRT/html

PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /opt/rt2/bin/webmux.pl

Sethandler perl-script
PerlHandler RT::Mason

Options SymLinksIfOwnerMatch AllowOverride None

NOTE
This machine is using a RFC1918 ip address
In the hosts file, the following has been added:
192.168.100.3 spliff spliff.vianet.ca
END NOTE

Apache/1.3.26 Server at spliff.vianet.ca Port 80

ii mysql-server 3.23.52-2 mysql database server binaries
ii mysql-client 3.23.52-2 mysql database client binaries
ii mysql-common 3.23.52-2 mysql database common files