Authen-ExternalAuth LDAP problem

I just installed RT 4.0.6 with no issue.

The only issue I currently have is getting it to work with ldap.

below is snippet of my config.

Set( @Plugins, qw(RT::Authen::ExternalAuth) );

LDAP Configuration

The order in which the services defined in ExternalSettings

should be used to authenticate users. User is authenticated

if successfully confirmed by any service - no more services

are checked.

Set($ExternalAuthPriority, [ ‘My_LDAP’ ]
);

The order in which the services defined in ExternalSettings

should be used to get information about users. This includes

RealName, Tel numbers etc, but also whether or not the user

should be considered disabled.

Set($ExternalInfoPriority, [ ‘My_LDAP’ ]
);

If this is set to true, then the relevant packages will

be loaded to use SSL/TLS connections. At the moment,

this just means “use Net::SSLeay;”

Set($ExternalServiceUsesSSLorTLS, 0);

If this is set to 1, then users should be autocreated by RT

as internal users if they fail to authenticate from an

external service.

Set($AutoCreateNonExternalUsers, 0);

LDAP Settings

‘My_LDAP’ => {
‘type’ => ‘ldap’,
‘server’ => ‘ldapserver’,
‘user’ => ‘cn=user,ou=oragnizational unit,dc=example,dc=net’,
‘pass’ => ‘passwd’,
‘base’ => ‘dc=example,dc=net’,
‘filter’ => ‘(objectClass=*)’,
‘d_filter’ => ‘(objectClass=Foo)’,
‘tls’ => ‘0’,
‘ssl_version’ => ‘3’,
‘net_ldap_args’ => ‘[ version => 3, port => 389 ]’,
‘attr_match_list’ => [
‘Name’,
‘EmailAddress’
],
‘attr_map’ => {
‘Name’ => ‘uid’,
‘EmailAddress’ => ‘mail’
}
},

There are no errors in the logs other than below:

[Mon Jun 11 11:30:43 2012] [warn] [client serverip] mod_fcgid: stderr: [Mon Jun 11 16:30:43 2012] [error]: FAILED LOGIN for my_user from serverip (/usr/local/rt/sbin/…/lib/RT/Interface/Web.pm:685), referer: http://servername/rt.

There are some “warnings” those are below:
[Mon Jun 11 11:30:43 2012] [warn] [client 1serverip] mod_fcgid: stderr: [Mon Jun 11 16:30:43 2012] [warning]: Use of uninitialized value in string eq at /usr/local/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm line 471. (/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/Externa, referer: http://servername/rt
[Mon Jun 11 11:30:43 2012] [warn] [client serverip] mod_fcgid: stderr: lAuth.pm:471), referer: http://servername/rt
[Mon Jun 11 11:30:43 2012] [warn] [client servername] mod_fcgid: stderr: [Mon Jun 11 16:30:43 2012] [warning]: Use of uninitialized value in string eq at /usr/local/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm line 473. (/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:471), referer: http://servername/rt.

Nothing else errors.

The other interesting thing here is that I do not see any network traffic from my RT server to the LDAP server configured here.

Can I get an assist here?

Thanks!

knip

as internal users if they fail to authenticate from an

external service.

Set($AutoCreateNonExternalUsers, 0);

LDAP Settings

‘My_LDAP’ => {
‘type’ => ‘ldap’,
‘server’ =>
‘ldapserver’,
‘user’ =>
‘cn=user,ou=oragnizational unit,dc=example,dc=net’,
‘pass’ => ‘passwd’,
‘base’ =>
‘dc=example,dc=net’,
‘filter’ =>
’(objectClass=*)’,
‘d_filter’ =>
’(objectClass=Foo)’,

This should be:

Set( $ExternalSettings, {
‘My_LDAP’ => {

etc.

Do not forget to verify your RT_SiteConfig.pm with perl -c RT_SiteConfig
after editing and restarting your webserver.

HTH,

natxo

                            'user'                  =>      'cn=user,ou=oragnizational unit,dc=example,dc=net',

Not sure, but there could be a typo.
ou=organizational unit
should be correct I guess.

Cheers,
Alex