Auth info


#1

Hi,

The check box for

“Send authentication info to all scripts on this server.”

is missing in RT2 development version. I find that the login box is
prompted whenever I click on a link. Will the check box be back on the
index screen soon? Thanks.

Sherrill
Sherrill (Pei-chih) Verbrugge
spv@gospelcom.net
ext. 273
http://www.gospelcom.net
http://bible.gospelcom.net


#2

It shouldn’t be necesary with RT2.

What browser are you using (exact version) and what exact URL is your
RT server running on?

    -jOn Thu, May 31, 2001 at 02:53:49PM -0400, Sherrill (Pei-chih) Verbrugge wrote:

Hi,

The check box for

“Send authentication info to all scripts on this server.”

is missing in RT2 development version. I find that the login box is
prompted whenever I click on a link. Will the check box be back on the
index screen soon? Thanks.

Sherrill

Sherrill (Pei-chih) Verbrugge
spv@gospelcom.net
ext. 273
http://www.gospelcom.net
http://bible.gospelcom.net

Rt-devel mailing list
Rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

pretty soon we’re going to HAVE to have hypertext mail!
–Tim Berners Lee. (8 Jan 1993 on www-talk)


#3

I suspect that the apache::session cache directory is not writable by your
apache user. Quit and restart your browser and turn on 'notify me of cookies’
and tell me what RT sends for a cookie.

    -jOn Thu, May 31, 2001 at 04:34:22PM -0400, Sherrill (Pei-chih) Verbrugge wrote:

Jesse,

Thanks for replying.

I am using Netscape Communicator 4.76 on redhat7.1. I also try it on
Internet Explore 5.5 and Netscape Communicator 4.72 on windows98.

If I click on the link, I see the login box again. I can get around it by
clicking on the “back” button and click on the link again. But I have to
do it on every single link.

I am testing RT2. I unpack the distribution and put what are suggested in
the REAME to the httpd config file. I have tried different versions
since May. Now I have rt-1-3-82 installed. Right now the url is
spv.gf.gospelcom.net (10.0.0.72). You probably can’t reach it. :< Please
let me know if you need anything else. Thanks.

Sherrill

On Thu, 31 May 2001, Jesse wrote:

It shouldn’t be necesary with RT2.

What browser are you using (exact version) and what exact URL is your
RT server running on?

    -j

On Thu, May 31, 2001 at 02:53:49PM -0400, Sherrill (Pei-chih) Verbrugge wrote:

Hi,

The check box for

“Send authentication info to all scripts on this server.”

is missing in RT2 development version. I find that the login box is
prompted whenever I click on a link. Will the check box be back on the
index screen soon? Thanks.

Sherrill

Sherrill (Pei-chih) Verbrugge
spv@gospelcom.net
ext. 273
http://www.gospelcom.net
http://bible.gospelcom.net

Rt-devel mailing list
Rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

Sherrill (Pei-chih) Verbrugge
spv@gospelcom.net
ext. 273
http://www.gospelcom.net
http://bible.gospelcom.net

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

“That package looks like what I wanted, but the site was down today,
so I decided to reimplement it in Perl.”
-me


#4

Ok. that’s the same problem I’ve been seeing. I suspect
that there are some extra spaces in the chown located on line 94
of webmux.pl. It’s making WebRT/sessiondata unwritable by
your apache process. I intend to take out the gratuitous chown in
the next snapshot. I also intend to have RT die screaming rather than
just lose on writing session files.On Thu, May 31, 2001 at 04:45:28PM -0400, Sherrill (Pei-chih) Verbrugge wrote:

Jesse,

When I type in spv, this is the message:

"The server spv wishes to set a cookie that will be sent only back to
itself. The name and value of the cookie are:
AF_SID=

Do you wish to allow the cookie to be set?"

I click on OK. It shows the first login page. I put in the login info.
I get in. I click on Configuration-> the login screen. I click on User
-> the login screen. There are no more cookie warnings.

Thanks,
Sherrill

On Thu, 31 May 2001, Jesse wrote:

I suspect that the apache::session cache directory is not writable by your
apache user. Quit and restart your browser and turn on 'notify me of cookies’
and tell me what RT sends for a cookie.

    -j

[snip]

Sherrill (Pei-chih) Verbrugge
spv@gospelcom.net
ext. 273
http://www.gospelcom.net
http://bible.gospelcom.net

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

autoconf is your friend until it mysteriously stops working, at which
point it is a snarling wolverine attached to your genitals by its teeth
(that said, it’s better than most of the alternatives) – Nathan Mehl