Attachment truncated inside ticket

Hi all,

when I receive a ticket created via e-mail with an attachment bigger
than 4k RT web interface shows it fine but when I try to open it I can’t
because it is corrupted. I try with 1k, 2k , 4k attachment and all works
Inside file I set :
Set($MaxAttachmentSize , 10000000);
Set($TruncateLongAttachments , 1);
Set($DropLongAttachments , 1);
and I restart apache web server.

I try every solution suggested in the mailing list (included: upgrade to
rt 3.0.6, mod_perl-1.99_07-20) but I still have this problem.
I use RedHat 9.0, RT 3.0.3, Apache/2.0.40, perl 5.8.0, mysql ver 11.18
Distrib 3.23.56, mod_perl-1.99_07-5; I have the same problem under
FreeBSD 5.1 using RT 3.0.4, perl 5.8.0 (I tried also with perl 5.6.1),
mysql Ver 12.21 Distrib 4.0.14, mod_perl2-1.99r09.
May be it’s a problem with mysql parameters, how can I tuning my DBMS ?
Can this problem impact over performance? My searches are very slow and
we have no more than 400 tickets …



INFN Sez. Firenze

Francesca Del Corso wrote:

Inside file I set :
Set($TruncateLongAttachments , 1);
Set($DropLongAttachments , 1);

So, do you want to truncate long attachments, or drop them?

May be it’s a problem with mysql parameters, how can I tuning my DBMS ? has excellent configuration documentation.
The max_allowed_packet parameter is the one you want in this case.
Though I doubt it’s the cause of your problem; the default is
usually around the 1Mb mark. I’ve not heard of this problem
under anything but RedHat-supplied broken mod_perl2 packages.
Phil Homewood, Systems Janitor, Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


I have been told you need at least mod_perl-1.99_09 - there is a bug in mod_perl-1.99_07. However I could not manage to install it (probably my own stupidity), so I reverted to using Apache 1.3.28 and mod_perl-1.28 and now it works fine.