Approval link missing

Hi rt-users,

What permissions must I give to a certain user/group to enable the
’Approval’ left-hand-nav menu item?

I had the link for my ApproverCA user but after discussion with the
client I found that this user needed much more restricted rights. I
restricted the rights for this user to almost bare-bones and their
’Approval’ link (not surprisingly) disappeared.

What is the minimum amount of rights needed to do this?
My ApprovalTicketRequests are in a ApprovalsCA queue.

Thanks in advance,

/Alister

P.S. Here is some extra info for what I have done with my RT install
exactly.

RT:3.8.8

OnTicketCreate an approval-request goes into the ApprovalsCA queue.
In the future other tickets will go into other queues.
(I am not opposed to using the ___Approvals queue, I just didn’t think I
could restrict access on Group Membership for groups can/cannot approve.)

"By managing your permissions, you can set up Approval systems
for various organisational departments.

Note that if you’re using the default ___Approvals Queue for your
approvals, you’ll need to give the people who are to approve things
permissions to see tickets in this queue (which you can only do by
granting Global permissions.) You’ll want to grant ShowTicket to
AdminCC’s (which ever role your template attaches the approving group to
the approval ticket as)"

I have tried this for my own queue but it doesn’t seem to work.

Permissions I have set:
Global:
AdminCC:: ShowTicket
ApprovalsCA Queue:
ApproversCA: ModifyTicket, SeeQueue, ShowTicket

My-Approval-Template:
===Create-Ticket: changerequest-approval
Depended-On-By: TOP
Refers-To: TOP
Queue: ApprovalsCA
Type: approval
Owner: username-of-owner
AdminCC: {
my $group_name = “ApproversCA”;
my $groups = RT::Groups->new( $RT::SystemUser );

$groups->LimitToUserDefinedGroups();
$groups->Limit( 'FIELD' => 'Name',
                'OPERATOR' => '=', 'VALUE' => $group_name );
$groups->First->Id;

}
Content: Someone has moved a ticket into the ChangeRequests queue. You
should review and approve it.
ENDOFCONTENT

Found it. It was a global setting.

Configuration > Global > Group Rights > $mygroup > ShowApprovalsTab

Cheers,

Alister West alister@gossamer-threads.com
http://www.gossamer-threads.com