Apache2 Starting at boot time

I have a very strange issue. It seems when i enable apache2 to start at boot, during the boot process i get an error about PerlModule Apache::DBI that is in my vhost.conf for RT 3.4.5. However when i start apache at the command line it doesn’t throw-up all over the place and the program runs fine. I started looking on CPAN for Apache2::DBI but found nothing. Has anyone else seen this issue? Is there an Apache2::DBI i could download?

System nfo:
SuSe 9.0 Network Enterpise
RT 3.4.5
Apache2
Mod_Perl2

RT.vhost.conf

Listen 443 LoadModule apreq_module /usr/lib/apache2/mod_apreq2.so ServerName rt.newrt.dnc.org:443 DocumentRoot /opt/rt3/share/html LogLevel debug ErrorLog /var/log/apache2/rt_error_log TransferLog /var/log/apache2/rt_access_log PerlSetVar MasonArgsMethod CGI RewriteEngine On RewriteRule ^(.*)/$ $1/index.html PerlModule Apache::DBI SetHandler perl-script PerlHandler RT::Mason SSLEngine on SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL SSLCertificateFile /etc/apache2/ssl.crt/newcert.crt SSLCertificateKeyFile /etc/apache2/ssl.key/newkey.pem

<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +StdEnvVars

<Directory “/srv/www/cgi-bin”>
SSLOptions +StdEnvVars

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0

CustomLog /var/log/apache2/rt_ssl_error_log ssl_combined

Error Msg at boot:
[Wed Apr 19 13:56:32 2006] [error] Can’t locate Apache/DBI.pm in @INC (@INC contains: /usr/lib/perl5/5.8.3/i586-linux-thread-multi /usr/lib/perl5/5.8.3 /usr/lib/perl5/site_perl/5.8.3/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl . /srv/www) at (eval 2) line 3.\n
[Wed Apr 19 13:56:32 2006] [error] Can’t load Perl module Apache::DBI for server rt.newrt.dnc.org:443, exiting…

How low will we go? Check out Yahoo! Messenger’s low PC-to-Phone call rates.

I have a very strange issue. It seems when i enable apache2 to
start at boot, during the boot process i get an error about
PerlModule Apache::DBI that is in my vhost.conf for RT 3.4.5.
However when i start apache at the command line it doesn’t throw-up
all over the place and the program runs fine. I started looking on
CPAN for Apache2::DBI but found nothing. Has anyone else seen this
issue? Is there an Apache2::DBI i could download?

what’s in your environment on your login shell?

i bet you set some PERL paths.

and what does this have to do with RT development? seems like a
users issue to me.

Vivek,

bash env

some more nfo:
I have a very strange issue. It seems when i enable apache2 to start at boot, during the boot process i get an error about PerlModule Apache::DBI that is in my vhost.conf for RT 3.4.5. However when i start apache at the command line it doesn’t throw-up all over the place and the program runs fine. I started looking on CPAN for Apache2::DBI but found nothing. Has anyone else seen this issue? Is there an Apache2::DBI i could download?

System nfo:
SuSe 9.0 Network Enterpise
RT 3.4.5
Apache2
Mod_Perl2Vivek Khera vivek@khera.org wrote:

On Apr 19, 2006, at 1:59 PM, Winn Johnston wrote:

I have a very strange issue. It seems when i enable apache2 to
start at boot, during the boot process i get an error about
PerlModule Apache::DBI that is in my vhost.conf for RT 3.4.5.
However when i start apache at the command line it doesn’t throw-up
all over the place and the program runs fine. I started looking on
CPAN for Apache2::DBI but found nothing. Has anyone else seen this
issue? Is there an Apache2::DBI i could download?

what’s in your environment on your login shell?

i bet you set some PERL paths.

and what does this have to do with RT development? seems like a
users issue to me.

List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

Best Practical is hiring! Come hack Perl for us: http://bestpractical.com/about/jobs.html

New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.