Apache2 + RT 3.x + mod_fastcgi

Is it me, or are the directions for configuring mod_fastcgi under
Apache2 for RT wrong?

The “FastCgiServer <path_to_mason_handler.fcgi” directive has to go
outside any virtual hosts directives. This was not the case with Apache
1.3.x, but I get an error if I even attempt to put that directive within
a VirtualHost block.

-Rich

Yes the RT docs are wrong, but not for the reason you might expect. If
I remember correctly this is actually a problem in FastCGI 2.4.2, where
2.4.0 didn’t have this problem.

It’s been a few weeks since I looked at it, but I recall getting that
error with both Apache 1.3 and 2.0 using FastCGI 2.4.2. Someone might
want to check that, but I’m about 85% sure that’s what it turned out
to be.

Matt

I am also running fastcgi/apache2 using the worker mpm and I have been
experiencing some very odd behavior with attachments.

At first I thought it was the same issue others are having, however if I
submitted a ticket with a word doc attachment having just restarted the
webserver, it went in fine. Then I keep submitting the same document, be it
a reply or a new ticket and after about the third or fourth, it would come
up a few k larger and be corrupted.

Restarting the web server, everything was fine, again for a bit and then
attachments would begin to get corrupt.

Now this DIDN’T happen if I ran it completely as a dynamic app with the
following vhost entry without the FastCgiServer directive, just the load
module:

<VirtualHost *:80>
ServerName
DocumentRoot /home/vhosts/ops-support/rtops/share/html
AddDefaultCharset UTF-8
CustomLog logs/access_log common
ErrorLog logs/error_log
ScriptAlias / /home/vhosts/ops-support/rtops/bin/mason_handler.fcgi/
<Directory /home/vhosts/ops-support/rtops/bin/mason_handler.fcgi/>
SetHandler fastcgi-script
Options +ExecCGI

However, performance was terrible.

At this point I am committed but I can’t go having the webserver restarting
itself all the time so I had to do the following:

FastCgiServer /home/vhosts/ops-support/rtops/bin/mason_handler.fcgi
-processes 50
FastCgiConfig -minProcesses 50 -killInterval 10

And then on with the vhost entry above.

I cant seem to find anything on this but are there any garbage collection
routines that can be run that may clean this up?

Would anyone have any idea why this is?

A.J.-----Original Message-----
From: rt-devel-bounces@lists.bestpractical.com
[mailto:rt-devel-bounces@lists.bestpractical.com] On Behalf Of Matt Knopp
Sent: Monday, January 26, 2004 10:42 PM
To: Rich West
Cc: rt-users@lists.bestpractical.com; rt-devel@lists.bestpractical.com
Subject: Re: [rt-devel] Apache2 + RT 3.x + mod_fastcgi

Yes the RT docs are wrong, but not for the reason you might expect. If
I remember correctly this is actually a problem in FastCGI 2.4.2, where
2.4.0 didn’t have this problem.

It’s been a few weeks since I looked at it, but I recall getting that
error with both Apache 1.3 and 2.0 using FastCGI 2.4.2. Someone might
want to check that, but I’m about 85% sure that’s what it turned out
to be.

Matt
rt-devel mailing list
rt-devel@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-devel