Apache + mod_perl

Arggh!

I know this is off-topic, but, since there must be someone else out
there with the same setup, but working, I figured I would try…

Has anyone had any success with Apache + mod_perl on Solaris 8?

I’ve had great success under Linux with Apache 1.3.20 and mod_perl 1.26,
but, under Solaris 8, the thing continually logs a Segmentation Fault
(11) for each apache process. The server answers for normal requests,
but, when a request goes to the virual host for RT, that’s when it seg
faults.

And, no… I didn’t compile it as a DSO. Out from the configure/make
looks like: o perl_module uses ConfigStart/End
+ mod_perl build type: OBJ
+ setting up mod_perl build environment
+ id: mod_perl/1.26
+ id: Perl/v5.6.1 (solaris) [perl]
+ adjusting Apache build environment
+ enabling Perl support for SSI (mod_include)


with all of the perl stuff listed as “enabled”.

sigh I am so close at getting RT2 up for this site, I can taste it…

Any tips, tricks, pointers, etc would be much appreciated!

Thanks!
-Rich

Richard West $14.95 Registrations mailto:rwest@wesmo.com
Wesmo Computer Services .com .net .org .tv .cc http://www.wesmo.com
Full Domain & Web Hosting .BIZ .INFO & MORE!!

Rich,

I compiled apache successfully (twice) on Solaris 8.

I basically used the document at

http://www.delouw.ch/linux/apache.phtml

only slightly modified (ie, mm just Doesn’t Work, don’t bother installing
it)

You need to be careful, though, if you’re not using the Sun (Forte) C
compiler. I’ve run into a great deal of trouble there. I have also run
into trouble, along those same lines, with my build of perl – perl
expected the compiler to be cc (sun’s Forte C compiler), and so whenever I
did “perl Makefile.PL” as with mod_perl, I got some funky errors.

Our solution temporarily is to rebuild perl to recognize gcc. However, in
the long term, we’re buying the license for the $#!$@$# compiler.

Sheeri Kritzer
Systems Administrator
University Systems Group
Tufts University
617-627-3925
skritz01@emerald.tufts.eduOn Wed, 17 Oct 2001, Rich West wrote:

Arggh!

I know this is off-topic, but, since there must be someone else out
there with the same setup, but working, I figured I would try…

Has anyone had any success with Apache + mod_perl on Solaris 8?

I’ve had great success under Linux with Apache 1.3.20 and mod_perl 1.26,
but, under Solaris 8, the thing continually logs a Segmentation Fault
(11) for each apache process. The server answers for normal requests,
but, when a request goes to the virual host for RT, that’s when it seg
faults.

And, no… I didn’t compile it as a DSO. Out from the configure/make
looks like: o perl_module uses ConfigStart/End
+ mod_perl build type: OBJ
+ setting up mod_perl build environment
+ id: mod_perl/1.26
+ id: Perl/v5.6.1 (solaris) [perl]
+ adjusting Apache build environment
+ enabling Perl support for SSI (mod_include)


with all of the perl stuff listed as “enabled”.

sigh I am so close at getting RT2 up for this site, I can taste it…

Any tips, tricks, pointers, etc would be much appreciated!

Thanks!
-Rich


Richard West $14.95 Registrations mailto:rwest@wesmo.com
Wesmo Computer Services .com .net .org .tv .cc http://www.wesmo.com
Full Domain & Web Hosting .BIZ .INFO & MORE!!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

OK… shoot me now. For the life of me, it will not work. :frowning:

bah… grrr… grumble…

This really shouldn’t be that much trouble…

Somehow I do not think I could sneak by a CLI-only version of RT2 past
the helpdesk folks here… They would probably lynch me. :slight_smile:

I browsed through those pages, and the darned thing tries to compile
mod_ssl as a DSO. ack That, and gcc happily builds everything, but
Sun’s C compiler bombs.

Man, it burns me that I got this far at this site with RT2 only to be
stopped in my tracks by dumb-old mod_perl.

toss in the towel Now that I have a huge headache, I’m done for today.

-Rich

#!/bin/sh

CC="cc"
PATH=/opt/SUNWspro/bin:/usr/local/bin:$PATH
export CC PATH

cd mod_ssl-2.8.4-1.3.20/
./configure --with-apache=…/apache_1.3.20 --enable-shared=ssl
cd …
cd mod_perl-1.26
perl Makefile.PL APACHE_SRC=…/apache_1.3.20/src DO_HTTPD=1 PREP_HTTPD=1
USE_APACI=1 EVERYTHING=1
make
make install
cd …/apache_1.3.20

LD_LIBRARY_PATH=/usr/local/lib
export LD_LIBRARY_PATH
CFLAGS="-L/usr/local/lib" SSL_BASE=/usr/local/pkg/openssl-0.9.6b
./configure --prefix=/usr/local/pkg/apache-1.3.20-test
–enable-module=ssl
–enable-shared=ssl
–enable-module=unique_id
–enable-module=rewrite
–enable-module=speling
–enable-module=expires
–enable-module=info
–enable-module=log_agent
–enable-module=log_referer
–enable-module=usertrack
–enable-module=proxy
–enable-module=userdir
–enable-module=so
–disable-module=auth_dbm
–enable-suexec
–suexec-caller=nobody
–suexec-docroot=/nj/www
–add-module=…/mod_bandwidth.c
–activate-module=src/modules/perl/libperl.a
–enable-module=perl
–disable-rule=WANTHSREGEX
make
make install

Sheeri Kritzer wrote:

Actually, yeah. sheeri’s point about apache and perl being built with
different compilers is very good. That can just suck. But, you can always
just use the fastcgi frontend…

-jOn Wed, Oct 17, 2001 at 04:31:54PM -0400, Rich West wrote:

OK… shoot me now. For the life of me, it will not work. :frowning:

bah… grrr… grumble…

This really shouldn’t be that much trouble…

Somehow I do not think I could sneak by a CLI-only version of RT2 past
the helpdesk folks here… They would probably lynch me. :slight_smile:

I browsed through those pages, and the darned thing tries to compile
mod_ssl as a DSO. ack That, and gcc happily builds everything, but
Sun’s C compiler bombs.

Man, it burns me that I got this far at this site with RT2 only to be
stopped in my tracks by dumb-old mod_perl.

toss in the towel Now that I have a huge headache, I’m done for today.

-Rich

#!/bin/sh

CC="cc"
PATH=/opt/SUNWspro/bin:/usr/local/bin:$PATH
export CC PATH

cd mod_ssl-2.8.4-1.3.20/
./configure --with-apache=…/apache_1.3.20 --enable-shared=ssl
cd …
cd mod_perl-1.26
perl Makefile.PL APACHE_SRC=…/apache_1.3.20/src DO_HTTPD=1 PREP_HTTPD=1
USE_APACI=1 EVERYTHING=1
make
make install
cd …/apache_1.3.20

LD_LIBRARY_PATH=/usr/local/lib
export LD_LIBRARY_PATH
CFLAGS="-L/usr/local/lib" SSL_BASE=/usr/local/pkg/openssl-0.9.6b
./configure --prefix=/usr/local/pkg/apache-1.3.20-test
–enable-module=ssl
–enable-shared=ssl
–enable-module=unique_id
–enable-module=rewrite
–enable-module=speling
–enable-module=expires
–enable-module=info
–enable-module=log_agent
–enable-module=log_referer
–enable-module=usertrack
–enable-module=proxy
–enable-module=userdir
–enable-module=so
–disable-module=auth_dbm
–enable-suexec
–suexec-caller=nobody
–suexec-docroot=/nj/www
–add-module=…/mod_bandwidth.c
–activate-module=src/modules/perl/libperl.a
–enable-module=perl
–disable-rule=WANTHSREGEX
make
make install

Sheeri Kritzer wrote:

Rich,

I compiled apache successfully (twice) on Solaris 8.

I basically used the document at

http://www.delouw.ch/linux/apache.phtml

only slightly modified (ie, mm just Doesn’t Work, don’t bother installing
it)

You need to be careful, though, if you’re not using the Sun (Forte) C
compiler. I’ve run into a great deal of trouble there. I have also run
into trouble, along those same lines, with my build of perl – perl
expected the compiler to be cc (sun’s Forte C compiler), and so whenever I
did “perl Makefile.PL” as with mod_perl, I got some funky errors.

Our solution temporarily is to rebuild perl to recognize gcc. However, in
the long term, we’re buying the license for the $#!$@$# compiler.

Sheeri Kritzer
Systems Administrator
University Systems Group
Tufts University
617-627-3925
skritz01@emerald.tufts.edu

On Wed, 17 Oct 2001, Rich West wrote:

Arggh!

I know this is off-topic, but, since there must be someone else out
there with the same setup, but working, I figured I would try…

Has anyone had any success with Apache + mod_perl on Solaris 8?

I’ve had great success under Linux with Apache 1.3.20 and mod_perl 1.26,
but, under Solaris 8, the thing continually logs a Segmentation Fault
(11) for each apache process. The server answers for normal requests,
but, when a request goes to the virual host for RT, that’s when it seg
faults.

And, no… I didn’t compile it as a DSO. Out from the configure/make
looks like: o perl_module uses ConfigStart/End

  • mod_perl build type: OBJ
  • setting up mod_perl build environment
  • id: mod_perl/1.26
  • id: Perl/v5.6.1 (solaris) [perl]
  • adjusting Apache build environment
  • enabling Perl support for SSI (mod_include)


with all of the perl stuff listed as “enabled”.

sigh I am so close at getting RT2 up for this site, I can taste it…

Any tips, tricks, pointers, etc would be much appreciated!

Thanks!
-Rich


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

“RW” == Rich West Rich.West@wesmo.com writes:

RW> I browsed through those pages, and the darned thing tries to compile
RW> mod_ssl as a DSO. ack That, and gcc happily builds everything, but
RW> Sun’s C compiler bombs.

You must use the same compiler for everything.

You must specify the same LARGE FILES setting for everything.

everything == apache and mod_perl.

Vivek Khera wrote:

You must use the same compiler for everything.

You must specify the same LARGE FILES setting for everything.

everything == apache and mod_perl.

And if it’s not obvious, you’ll also need to compile everything yourself.
It’s not difficult.

T�o de Hesselle, \ One possible reason that things
Unix Systems Administrator \ aren’t going according to plan
\ is that there never was a plan
University of Technology, Sydney \ in the first place.

Vivek Khera wrote:

You must use the same compiler for everything.

You must specify the same LARGE FILES setting for everything.

everything == apache and mod_perl.

And if it’s not obvious, you’ll also need to compile everything yourself.
It’s not difficult.

Right, I don’t think that was the issue. The issue is that Solaris has
some funky compiler issues, and the Berkeley cc doesn’t help – you either
need gcc or Sun’s Forte Compiler. The problem is that sometimes perl, the
package, not mod_perl, but the big, whopping, honking perl, is set so that
when you use it to create a makefile (ie, perl Makefile.PL, as you need to
do with the mod_perl installation), it looks for “cc” instead of “default
compiler”.

Sheeri Kritzer
Systems Administrator
University Systems Group
Tufts University
617-627-3925
skritz01@emerald.tufts.edu

  • Sheeri Kritzer wrote on 18 Oct 2001:> On Thu, 18 Oct 2001, Teo de Hesselle wrote:

Vivek Khera wrote:

You must use the same compiler for everything.

You must specify the same LARGE FILES setting for everything.

everything == apache and mod_perl.

And if it’s not obvious, you’ll also need to compile everything yourself.
It’s not difficult.

Right, I don’t think that was the issue. The issue is that Solaris has
some funky compiler issues, and the Berkeley cc doesn’t help – you either
need gcc or Sun’s Forte Compiler. The problem is that sometimes perl, the
package, not mod_perl, but the big, whopping, honking perl, is set so that
when you use it to create a makefile (ie, perl Makefile.PL, as you need to
do with the mod_perl installation), it looks for “cc” instead of “default
compiler”.

and if this helps, I couldnt get it to work unless I had mod_perl build apache:

{sys1:/u/pratoa/src/build/mod_perl-stat/mod_perl-1.26} cat buildme
perl Makefile.PL APACHE_PREFIX=/usr/local/apache APACHE_SRC=…/apache_1.3.20/src DO_HTTPD=1 USE_APACI=1 EVERYTHING=1 APACI_ARGS="cat ../apache_1.3.20/aa"

and the apaci args I used are:

--prefix=/usr/local/apache  --sysconfdir=/var/apache/conf --logfiledir=/var/apache/logs --datadir=/var/apache --localstatedir=/var/apache --with-layout=Apache --with-perl=/usr/local/bin/perl --enable-rule=SHARED_CORE --enable-module=so --enable-module=env --enable-module=proxy --enable-module=log_config --enable-module=log_agent --enable-module=log_referer --enable-module=mime_magic --enable-module=mime --enable-module=negotiation --enable-module=status --enable-module=info --enable-module=include --enable-module=autoindex --enable-module=dir --enable-module=cgi --enable-module=asis --enable-module=imap --enable-module=actions --enable-module=userdir --enable-module=alias --enable-module=rewrite --enable-module=access --enable-module=auth --enable-module=usertrack --enable-module=setenvif

This built apache with dso support, but builds mod_perl static into apache:

} /usr/local/apache/bin/httpd -l | grep perl
mod_perl.c

I ran make and make install from the mod_perl directory.

Adam

Perhaps Apache Toolbox might be a good resource for people. I haven’t tried
it with RT but it solved my problems with other Apache configs (i.e.
mod_perl + PHP + auth_mysql etc)

http://www.apachetoolbox.com/

Cheers
Adam----- Original Message -----
From: “Adam R Prato” arp-rt2@metachar.net
To: “Sheeri Kritzer” skritz01@emerald.tufts.edu
Cc: “Teo de Hesselle” teo.dehesselle@uts.edu.au; rt-users@fsck.com
Sent: Friday, October 19, 2001 5:20 AM
Subject: Re: [rt-users] Apache + mod_perl

I use a modified Apache Toolbox here to include some other things that I
need (namely qt and gnome’s xml parser for eZpublish…) Works rather well…
there ARE module incompatibilities that it doesn’t know about, so you can
get frustrated if you turn on too much stuff, but it works well…

Jay

Perhaps Apache Toolbox might be a good resource for people. I haven’t
tried