Apache + mod_perl (from: Rich.West@wesmo.com)

----- Forwarded message from Rich West Rich.West@wesmo.com -----Date: Wed, 17 Oct 2001 19:44:51 -0400
From: Rich West Rich.West@wesmo.com
Organization: WesMo
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726 Netscape6/6.1
To: Jesse Vincent jesse@bestpractical.com
Subject: Re: [rt-users] Apache + mod_perl

FastCGI works like a champ, minus the RT graphic (odd - I wonder why
that is the case… I don’t know enough (yet) about fastcgi).

The key is that you also need to install the perl module “FCGI” from
cpan. Outside of that, there isn’t anything else.

It is extremely straightforward and does run happily as a DSO.

Of course, I tested this on my linux systems. I won’t be able to test
this until tomorrow under Solaris.

Anyhow, the full out procedure is:
o Use CPAN to install “FCGI”.
o Download http://www.fastcgi.com/dist/mod_fastcgi.tar.gz
o Decompress it.
o Build as a DSO via: apxs -o mod_fastcgi.so -c *.c
o Fix the permissions via: chmod 755 mod_fastcgi.so
o Install the compiled DSO via: cp mod_fastcgi.so
/apache_install/modules/mod_fastcgi.so
o Update your httpd.conf file to include "LoadModule fastcgi_module
modules/mod_fastcgi.so"
o Also add: "AddModule mod_fastcgi.c"
o Add "ScriptAlias / /usr/rt2/bin/mason_handler.fcgi/"
o Restart the webserver.

Done.

:slight_smile:

-Rich

Jesse Vincent wrote:

http://fsck.com/rtfm/article.html?id=49 is what I’ve got at this point.

updates owuld be cool.

Hrmm… now that is a good option.

I’m trying that right now. I take it that the docs aren’t there (yet)
for the fastcgi configuration, eh? If that is the case, I’ll muddle
through, then send you updated docs if you would like…

-Rich

Jesse Vincent wrote:

IT doesn’t display the RT logo, but otherwise should be fine.
and yeah. that cuts mod perl out entirely.

…?

I thought the fastcgi stuff wasn’t fully working yet… Would that drop
the dependency on mod_perl?

-Rich

Jesse Vincent wrote:

Actually, yeah. sheeri’s point about apache and perl being built with
different compilers is very good. That can just suck. But, you can always
just use the fastcgi frontend…

-j

OK… shoot me now. For the life of me, it will not work. :frowning:

bah… grrr… grumble…

This really shouldn’t be that much trouble…

Somehow I do not think I could sneak by a CLI-only version of RT2 past
the helpdesk folks here… They would probably lynch me. :slight_smile:

I browsed through those pages, and the darned thing tries to compile
mod_ssl as a DSO. ack That, and gcc happily builds everything, but
Sun’s C compiler bombs.

Man, it burns me that I got this far at this site with RT2 only to be
stopped in my tracks by dumb-old mod_perl.

toss in the towel Now that I have a huge headache, I’m done for today.

-Rich

#!/bin/sh

CC="cc"
PATH=/opt/SUNWspro/bin:/usr/local/bin:$PATH
export CC PATH

cd mod_ssl-2.8.4-1.3.20/
./configure --with-apache=…/apache_1.3.20 --enable-shared=ssl
cd …
cd mod_perl-1.26
perl Makefile.PL APACHE_SRC=…/apache_1.3.20/src DO_HTTPD=1 PREP_HTTPD=1
USE_APACI=1 EVERYTHING=1
make
make install
cd …/apache_1.3.20

LD_LIBRARY_PATH=/usr/local/lib
export LD_LIBRARY_PATH
CFLAGS="-L/usr/local/lib" SSL_BASE=/usr/local/pkg/openssl-0.9.6b
./configure --prefix=/usr/local/pkg/apache-1.3.20-test
–enable-module=ssl
–enable-shared=ssl
–enable-module=unique_id
–enable-module=rewrite
–enable-module=speling
–enable-module=expires
–enable-module=info
–enable-module=log_agent
–enable-module=log_referer
–enable-module=usertrack
–enable-module=proxy
–enable-module=userdir
–enable-module=so
–disable-module=auth_dbm
–enable-suexec
–suexec-caller=nobody
–suexec-docroot=/nj/www
–add-module=…/mod_bandwidth.c
–activate-module=src/modules/perl/libperl.a
–enable-module=perl
–disable-rule=WANTHSREGEX
make
make install

Sheeri Kritzer wrote:

Rich,

I compiled apache successfully (twice) on Solaris 8.

I basically used the document at

http://www.delouw.ch/linux/apache.phtml

only slightly modified (ie, mm just Doesn’t Work, don’t bother installing
it)

You need to be careful, though, if you’re not using the Sun (Forte) C
compiler. I’ve run into a great deal of trouble there. I have also run
into trouble, along those same lines, with my build of perl – perl
expected the compiler to be cc (sun’s Forte C compiler), and so whenever I
did “perl Makefile.PL” as with mod_perl, I got some funky errors.

Our solution temporarily is to rebuild perl to recognize gcc. However, in
the long term, we’re buying the license for the $#!$@$# compiler.

Sheeri Kritzer
Systems Administrator
University Systems Group
Tufts University
617-627-3925
skritz01@emerald.tufts.edu

Arggh!

I know this is off-topic, but, since there must be someone else out
there with the same setup, but working, I figured I would try…

Has anyone had any success with Apache + mod_perl on Solaris 8?

I’ve had great success under Linux with Apache 1.3.20 and mod_perl 1.26,
but, under Solaris 8, the thing continually logs a Segmentation Fault
(11) for each apache process. The server answers for normal requests,
but, when a request goes to the virual host for RT, that’s when it seg
faults.

And, no… I didn’t compile it as a DSO. Out from the configure/make
looks like: o perl_module uses ConfigStart/End

  • mod_perl build type: OBJ
  • setting up mod_perl build environment
  • id: mod_perl/1.26
  • id: Perl/v5.6.1 (solaris) [perl]
  • adjusting Apache build environment
  • enabling Perl support for SSI (mod_include)


with all of the perl stuff listed as “enabled”.

sigh I am so close at getting RT2 up for this site, I can taste it…

Any tips, tricks, pointers, etc would be much appreciated!

Thanks!
-Rich

----- End forwarded message -----

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Just to follow up, this worked wonderfully under Solaris, as well.

-Rich

Jesse Vincent wrote: