Apache::Cookie?

I’m using RedHat 7.3 and the RPM versions of perl ( v5.6.1 built for
i386-Linux) and apache (Server version: Apache/1.3.23 (Unix)
(Red-Hat/Linux)Server built: Apr 9 2002 14:56:43).

Is this why I am having problems with Apache::Cookie?

What is the appropriate course of action to fuixc this?

Remove the RPM version of apache and build it from scratch?

Here is my output from make fixdeps:
Subject:
Date:
Mon, 10 Jun 2002 09:44:33 -0600
From:
root root@rtserv.enel.ucalgary.ca
To:
rmillis@enel.ucalgary.ca

Script started on Mon Jun 10 09:44:00 2002
e]0;root@rtserv:~/rt-2-0-13a[root@rtserv rt-2-0-13]# clear
e[He[2Je]0;root@rtserv:~/rt-2-0-13a[root@rtserv rt-2-0-13]# make fixdeps
/usr/bin/perl ./tools/testdeps -fix mysql
Checking for Digest::MD5…found
Checking for Storable…found
Checking for DBI 1.18 …found
Checking for DBIx::DataSource 0.02 …found
Checking for DBIx::SearchBuilder 0.48 …found
Checking for HTML::Entities…found
Checking for MLDBM…found
Checking for Net::Domain…found
Checking for Net::SMTP…found
Checking for Params::Validate 0.02 …found
Checking for HTML::Mason 1.02 …found
Checking for CGI::Cookie 1.20 …found
Checking for Apache::Cookie…Apache::Cookie not installed.Installing
with CPAN…Goingto read /root/.cpan/Metadata
Database was generated on Mon, 10 Jun 2002 05:40:11 GMT
Running install for module Apache::Cookie
Running make for J/JI/JIMW/libapreq-1.0.tar.gz

CPAN: MD5 security checks disabled because MD5 not installed.
Please consider installing the MD5 module.

Scanning cache /root/.cpan/build for sizes
libapreq-1.0/
libapreq-1.0/.cvsignore
libapreq-1.0/CREDITS
libapreq-1.0/Changes
libapreq-1.0/INSTALL
libapreq-1.0/LICENSE
libapreq-1.0/MANIFEST
libapreq-1.0/Makefile.PL
libapreq-1.0/Makefile.am
libapreq-1.0/README
libapreq-1.0/ToDo
libapreq-1.0/acconfig.h
libapreq-1.0/acinclude.m4
libapreq-1.0/aclocal.m4
libapreq-1.0/config.guess
libapreq-1.0/config.sub
libapreq-1.0/configure.in
libapreq-1.0/install-sh
libapreq-1.0/libapreq.pod
libapreq-1.0/libtool
libapreq-1.0/ltconfig
libapreq-1.0/ltmain.sh
libapreq-1.0/mkinstalldirs
libapreq-1.0/typemap
libapreq-1.0/Cookie/
libapreq-1.0/Cookie/.cvsignore
libapreq-1.0/Cookie/Cookie.pm
libapreq-1.0/Cookie/Cookie.xs
libapreq-1.0/Cookie/Makefile.PL
libapreq-1.0/Request/
libapreq-1.0/Request/.cvsignore
libapreq-1.0/Request/Makefile.PL
libapreq-1.0/Request/Request.pm
libapreq-1.0/Request/Request.xs
libapreq-1.0/c/
libapreq-1.0/c/.cvsignore
libapreq-1.0/c/Makefile.PL
libapreq-1.0/c/Makefile.am
libapreq-1.0/c/Makefile.noperl
libapreq-1.0/c/apache_cookie.c
libapreq-1.0/c/apache_cookie.h
libapreq-1.0/c/apache_multipart_buffer.c
libapreq-1.0/c/apache_multipart_buffer.h
libapreq-1.0/c/apache_request.c
libapreq-1.0/c/apache_request.h
libapreq-1.0/c/libapreq_config.h.in
libapreq-1.0/c/stamp-h.in
libapreq-1.0/c/Makefile.in
libapreq-1.0/eg/
libapreq-1.0/eg/c/
libapreq-1.0/eg/c/testapreq/
libapreq-1.0/eg/c/testapreq/Makefile.apxs
libapreq-1.0/eg/c/testapreq/Makefile.tmpl
libapreq-1.0/eg/c/testapreq/mod_testapreq.c
libapreq-1.0/eg/c/testapreq/mod_testapreq.module
libapreq-1.0/eg/perl/
libapreq-1.0/eg/perl/cookie.pl
libapreq-1.0/eg/perl/file_upload.pl
libapreq-1.0/lib/
libapreq-1.0/lib/Apache/
libapreq-1.0/lib/Apache/libapreq.pm
libapreq-1.0/missing
libapreq-1.0/Makefile.in
libapreq-1.0/configure
Removing previously used /root/.cpan/build/libapreq-1.0

CPAN.pm: Going to build J/JI/JIMW/libapreq-1.0.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for libapreq
mkdir …/blib
mkdir …/blib/arch
mkdir …/blib/arch/auto
mkdir …/blib/arch/auto/libapreq
Warning: -L…/blib/arch/auto/libapreq changed to
-L/root/.cpan/build/libapreq-1.0/Request/…/blib/arch/auto/libapreq
Writing Makefile for Apache::Request
Warning: -L…/blib/arch/auto/libapreq changed to
-L/root/.cpan/build/libapreq-1.0/Cookie/…/blib/arch/auto/libapreq
Writing Makefile for Apache::Cookie
Writing Makefile for libapreq
make[1]: Entering directory /root/.cpan/build/libapreq-1.0' cp libapreq.pod blib/lib/libapreq.pod cp lib/Apache/libapreq.pm blib/lib/Apache/libapreq.pm make[2]: Entering directory/root/.cpan/build/libapreq-1.0/c’
gcc -c -I/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/auto/Apache/include
-I/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/auto/Apache/include/modules/perl-fno-strict-aliasing -I/usr/local/include -O2 -march=i386 -mcpu=i686
-DVERSION=“0.10”-DXS_VERSION=“0.10” -fPIC -I/usr/lib/perl5/5.6.1/i386-linux/CORE
apache_request.cIn file included from apache_request.c:59:
apache_request.h:5:19: httpd.h: No such file or directory
apache_request.h:6:25: http_config.h: No such file or directory
apache_request.h:7:23: http_core.h: No such file or directory
apache_request.h:8:22: http_log.h: No such file or directory
apache_request.h:9:23: http_main.h: No such file or directory
apache_request.h:10:27: http_protocol.h: No such file or directory
apache_request.h:11:25: util_script.h: No such file or directory
make[2]: *** [apache_request.o] Error 1
make[2]: Leaving directory /root/.cpan/build/libapreq-1.0/c' make[1]: *** [subdirs] Error 2 make[1]: Leaving directory/root/.cpan/build/libapreq-1.0’
/usr/bin/make – NOT OK
Running make test
Can’t test without successful make
Running make install
make had returned bad status, install seems impossible

Checking for Apache::Session 1.53 …found
Checking for Date::Parse…found
Checking for Date::Format…found
Checking for MIME::Entity 5.108 …found
Checking for Mail::Mailer 1.20 …found
Checking for Getopt::Long 2.24 …found
Checking for Tie::IxHash…found
Checking for Text::Wrapper…found
Checking for Text::Template…found
Checking for File::Spec 0.8 …found
Checking for Errno…found
Checking for FreezeThaw…found
Checking for File::Temp…found
Checking for Log::Dispatch 1.6 …found
Checking for DBD::mysql 2.0416 …found
e]0;root@rtserv:~/rt-2-0-13a[root@rtserv rt-2-0-13]#
Script done on Mon Jun 10 09:44:16 2002

Just looks like you need the Apache header files. Find and install the
apache-devel RPM and you should be set.

Personally I like building perl and apache from scratch because it’s
easier to control and get exactly what you want. RPM should be fine
though, just make sure you have mod_perl installed or RT will be very
slow.

-Michael

Michael D. Marziani
Systems Administrator
Keller Williams Realty Int’l-----Original Message-----
From: Randy Millis [mailto:rmillisl@enel.ucalgary.ca]
Sent: Monday, June 10, 2002 10:50 AM
To: rt-users@lists.fsck.com
Subject: [rt-users] Apache::Cookie??

I’m using RedHat 7.3 and the RPM versions of perl ( v5.6.1 built for
i386-Linux) and apache (Server version: Apache/1.3.23 (Unix)
(Red-Hat/Linux)Server built: Apr 9 2002 14:56:43).

Is this why I am having problems with Apache::Cookie?

What is the appropriate course of action to fuixc this?

Remove the RPM version of apache and build it from scratch?

Here is my output from make fixdeps:
Subject:
Date:
Mon, 10 Jun 2002 09:44:33 -0600
From:
root root@rtserv.enel.ucalgary.ca
To:
rmillis@enel.ucalgary.ca

Script started on Mon Jun 10 09:44:00 2002 e]0;root@rtserv:~/rt-2-0-13
[root@rtserv rt-2-0-13]# clear e[He[2Je]0;root@rtserv:~/rt-2-0-13
[root@rtserv rt-2-0-13]# make fixdeps /usr/bin/perl ./tools/testdeps
-fix mysql Checking for Digest::MD5…found Checking for
Storable…found Checking for DBI 1.18 …found Checking for
DBIx::DataSource 0.02 …found Checking for DBIx::SearchBuilder 0.48
…found Checking for HTML::Entities…found Checking for MLDBM…found
Checking for Net::Domain…found Checking for Net::SMTP…found Checking
for Params::Validate 0.02 …found Checking for HTML::Mason 1.02
…found Checking for CGI::Cookie 1.20 …found Checking for
Apache::Cookie…Apache::Cookie not installed.Installing with
CPAN…Goingto read /root/.cpan/Metadata
Database was generated on Mon, 10 Jun 2002 05:40:11 GMT Running
install for module Apache::Cookie Running make for
J/JI/JIMW/libapreq-1.0.tar.gz

CPAN: MD5 security checks disabled because MD5 not installed.
Please consider installing the MD5 module.

Scanning cache /root/.cpan/build for sizes
libapreq-1.0/
libapreq-1.0/.cvsignore
libapreq-1.0/CREDITS
libapreq-1.0/Changes
libapreq-1.0/INSTALL
libapreq-1.0/LICENSE
libapreq-1.0/MANIFEST
libapreq-1.0/Makefile.PL
libapreq-1.0/Makefile.am
libapreq-1.0/README
libapreq-1.0/ToDo
libapreq-1.0/acconfig.h
libapreq-1.0/acinclude.m4
libapreq-1.0/aclocal.m4
libapreq-1.0/config.guess
libapreq-1.0/config.sub
libapreq-1.0/configure.in
libapreq-1.0/install-sh
libapreq-1.0/libapreq.pod
libapreq-1.0/libtool
libapreq-1.0/ltconfig
libapreq-1.0/ltmain.sh
libapreq-1.0/mkinstalldirs
libapreq-1.0/typemap
libapreq-1.0/Cookie/
libapreq-1.0/Cookie/.cvsignore
libapreq-1.0/Cookie/Cookie.pm
libapreq-1.0/Cookie/Cookie.xs
libapreq-1.0/Cookie/Makefile.PL
libapreq-1.0/Request/
libapreq-1.0/Request/.cvsignore libapreq-1.0/Request/Makefile.PL
libapreq-1.0/Request/Request.pm libapreq-1.0/Request/Request.xs
libapreq-1.0/c/ libapreq-1.0/c/.cvsignore libapreq-1.0/c/Makefile.PL
libapreq-1.0/c/Makefile.am libapreq-1.0/c/Makefile.noperl
libapreq-1.0/c/apache_cookie.c libapreq-1.0/c/apache_cookie.h
libapreq-1.0/c/apache_multipart_buffer.c
libapreq-1.0/c/apache_multipart_buffer.h
libapreq-1.0/c/apache_request.c
libapreq-1.0/c/apache_request.h libapreq-1.0/c/libapreq_config.h.in
libapreq-1.0/c/stamp-h.in
libapreq-1.0/c/Makefile.in
libapreq-1.0/eg/
libapreq-1.0/eg/c/
libapreq-1.0/eg/c/testapreq/ libapreq-1.0/eg/c/testapreq/Makefile.apxs
libapreq-1.0/eg/c/testapreq/Makefile.tmpl
libapreq-1.0/eg/c/testapreq/mod_testapreq.c
libapreq-1.0/eg/c/testapreq/mod_testapreq.module
libapreq-1.0/eg/perl/
libapreq-1.0/eg/perl/cookie.pl libapreq-1.0/eg/perl/file_upload.pl
libapreq-1.0/lib/
libapreq-1.0/lib/Apache/
libapreq-1.0/lib/Apache/libapreq.pm
libapreq-1.0/missing
libapreq-1.0/Makefile.in
libapreq-1.0/configure
Removing previously used /root/.cpan/build/libapreq-1.0

CPAN.pm: Going to build J/JI/JIMW/libapreq-1.0.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for libapreq
mkdir …/blib
mkdir …/blib/arch
mkdir …/blib/arch/auto
mkdir …/blib/arch/auto/libapreq
Warning: -L…/blib/arch/auto/libapreq changed to
-L/root/.cpan/build/libapreq-1.0/Request/…/blib/arch/auto/libapreq
Writing Makefile for Apache::Request
Warning: -L…/blib/arch/auto/libapreq changed to
-L/root/.cpan/build/libapreq-1.0/Cookie/…/blib/arch/auto/libapreq
Writing Makefile for Apache::Cookie
Writing Makefile for libapreq
make[1]: Entering directory /root/.cpan/build/libapreq-1.0' cp libapreq.pod blib/lib/libapreq.pod cp lib/Apache/libapreq.pm blib/lib/Apache/libapreq.pm make[2]: Entering directory/root/.cpan/build/libapreq-1.0/c’
gcc -c -I/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/auto/Apache/include
-I/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/auto/Apache/include/module
s/perl-fno-strict-aliasing -I/usr/local/include -O2 -march=i386
-mcpu=i686
-DVERSION=“0.10”-DXS_VERSION=“0.10” -fPIC
-I/usr/lib/perl5/5.6.1/i386-linux/CORE
apache_request.cIn file included from apache_request.c:59:
apache_request.h:5:19: httpd.h: No such file or directory
apache_request.h:6:25: http_config.h: No such file or directory
apache_request.h:7:23: http_core.h: No such file or directory
apache_request.h:8:22: http_log.h: No such file or directory
apache_request.h:9:23: http_main.h: No such file or directory
apache_request.h:10:27: http_protocol.h: No such file or directory
apache_request.h:11:25: util_script.h: No such file or directory
make[2]: *** [apache_request.o] Error 1
make[2]: Leaving directory /root/.cpan/build/libapreq-1.0/c' make[1]: *** [subdirs] Error 2 make[1]: Leaving directory/root/.cpan/build/libapreq-1.0’
/usr/bin/make – NOT OK
Running make test
Can’t test without successful make
Running make install
make had returned bad status, install seems impossible

Checking for Apache::Session 1.53 …found
Checking for Date::Parse…found
Checking for Date::Format…found
Checking for MIME::Entity 5.108 …found
Checking for Mail::Mailer 1.20 …found
Checking for Getopt::Long 2.24 …found
Checking for Tie::IxHash…found
Checking for Text::Wrapper…found
Checking for Text::Template…found
Checking for File::Spec 0.8 …found
Checking for Errno…found
Checking for FreezeThaw…found
Checking for File::Temp…found
Checking for Log::Dispatch 1.6 …found
Checking for DBD::mysql 2.0416 …found e]0;root@rtserv:~/rt-2-0-13
[root@rtserv rt-2-0-13]# Script done on Mon Jun 10 09:44:16 2002

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I hate when you rack your brain, give up and ask for help, then you figure
it out.:slight_smile:
Adding apache-devel-1.3.23-11.i386.rpm seems to allow make fixdeps to work.