Apache and MySQL problems on Install of 3.0.4

I am trying to install RT 3.0.4 on a RH8 system. I have:
Perl 5.8.0 (installed from RPM)
MySQL 4.0.14 (installed from RPM)
Apache 1.3.28 (installed manually)
ModPerl 1.28 (installed manually)

MySQL is running and accepting commands
Apache is running and serving pages

But when I to install RT it fails when testing for dependencies. The
commands used are:

./configure --with-db-rt-pass=mypassword
perl sbin/rt-test-dependencies --with-mysql --with-modperl1

Found errors here - It complained that Apache::Request and DBD::mysql
2.1018 were missing. I tried running this with the --install option but
that was unable to install the two missing items as well.
CPAN is setup and running. The only glitch I can find is that I may have
pointed CPAN to an older archive. Trouble is I can’t seem to find where to
re-initialize it.

I’ve looked through the RT archives on fsck.com but couldn’t find any
thing that helped.

I believe this is the point where I say “help”

Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

Download the sources and compile them yourself, cpan just makes it
easier…

http://search.cpan.org

and search for your modules

or go to interactive mode of cpan and type install perlmod
(install
Apache::Request)

and give us the error output from that

Michael-----Original Message-----
From: Leon Sonntag [mailto:leon@iwa-solutions.com]
Posted At: Thursday, September 04, 2003 2:14 PM
Posted To: RT
Conversation: [rt-users] Apache and MySQL problems on Install of 3.0.4
Subject: [rt-users] Apache and MySQL problems on Install of 3.0.4

I am trying to install RT 3.0.4 on a RH8 system. I have:
Perl 5.8.0 (installed from RPM)
MySQL 4.0.14 (installed from RPM)
Apache 1.3.28 (installed manually)
ModPerl 1.28 (installed manually)

MySQL is running and accepting commands
Apache is running and serving pages

But when I to install RT it fails when testing for dependencies. The
commands used are:

./configure --with-db-rt-pass=mypassword
perl sbin/rt-test-dependencies --with-mysql --with-modperl1

Found errors here - It complained that Apache::Request and DBD::mysql
2.1018 were missing. I tried running this with the --install option but

that was unable to install the two missing items as well.
CPAN is setup and running. The only glitch I can find is that I may
have
pointed CPAN to an older archive. Trouble is I can’t seem to find where
to
re-initialize it.

I’ve looked through the RT archives on fsck.com but couldn’t find any
thing that helped.

I believe this is the point where I say “help”

Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Leon,

use cpan to “auto” install missing modules:

perl -MCPAN -e ‘install Apache::Request’
perl -MCPAN -e ‘install DBD::mysql’

DBD::mysql might fail to install, because make test fails.

Go to your $HOME/.cpan/build directory, and then to DBD’s subdir and force
the install via make install (without previous make test).

Hope this helps,
A.-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Leon Sonntag
Sent: Thursday, September 04, 2003 8:14 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Apache and MySQL problems on Install of 3.0.4

I am trying to install RT 3.0.4 on a RH8 system. I have:
Perl 5.8.0 (installed from RPM)
MySQL 4.0.14 (installed from RPM)
Apache 1.3.28 (installed manually)
ModPerl 1.28 (installed manually)

MySQL is running and accepting commands
Apache is running and serving pages

But when I to install RT it fails when testing for dependencies. The
commands used are:

./configure --with-db-rt-pass=mypassword
perl sbin/rt-test-dependencies --with-mysql --with-modperl1

Found errors here - It complained that Apache::Request and DBD::mysql
2.1018 were missing. I tried running this with the --install option but
that was unable to install the two missing items as well.
CPAN is setup and running. The only glitch I can find is that I may have
pointed CPAN to an older archive. Trouble is I can’t seem to find where to
re-initialize it.

I’ve looked through the RT archives on fsck.com but couldn’t find any
thing that helped.

I believe this is the point where I say “help”

Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

In case of Apache::Request make test offten fails too
I recomend to do all installation steps under not root and only make
install under root.
because of test suit bug(or feature) that cause fails under root login.
Best regards. Ruslan.

Ale� Su�nik wrote:

hi leon,
hi list,

while installing
rt-3-0-5rc1

with
mysql-standard-4.0.14
modperl 1.27

on a
suse8.1 box

i also ran into the problem that Apache::Request and DBD::mysql refused to
be installed via CPAN.

i could solve it this way:
i downloaded libapreq-1.2.tar.gz (containing Apache::Request ) and
DBD-mysql-2.1028.tar.gz form CPAN.org manually.

i installed (after unpacking :wink: DBD::mysql with the ‘–libs’ option as CPAN
suggested:
perl Makefile.PL --libs -L/usr/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm

then i installed (as root) libapreq.

→ viola ‘rt-test-dependencies’ stopped complaining.

hope this also works for you (and others).

cu
andreas

Andreas Wahlfeldt
subshell GmbH
Weidenallee 1
20357 Hamburg

t +49.40. 431 362-25
f +49.40. 431 362-29
e awahlfeldt@subshell.com

At 12:48 PM 9/5/2003 +0200, Andreas Wahlfeldt wrote:

hi leon,
hi list,

while installing
rt-3-0-5rc1

with
mysql-standard-4.0.14
modperl 1.27

on a
suse8.1 box

i also ran into the problem that Apache::Request and DBD::mysql refused to
be installed via CPAN.

i could solve it this way:
i downloaded libapreq-1.2.tar.gz (containing Apache::Request ) and
DBD-mysql-2.1028.tar.gz form CPAN.org manually.

i installed (after unpacking :wink: DBD::mysql with the ‘–libs’ option as CPAN
suggested:
perl Makefile.PL --libs -L/usr/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm

then i installed (as root) libapreq.

→ viola ‘rt-test-dependencies’ stopped complaining.

hope this also works for you (and others).

Well that got me half way there…I think.
I reinstalled mysql from source because I kept getting “Can’t find
mysql+conf”. Then I followed you instructions. Now the only thing the
rt-test-dependencies is Apache::Request. And Yes, I did go ahead and
install libapreg-1.38. I have this feeling that I need to go back and
recompile Apache differently some how but doing it ‘generically’ didn’t do
the trick either.

Ooohhh welll…next…

cu
andreas


Andreas Wahlfeldt
subshell GmbH
Weidenallee 1
20357 Hamburg

t +49.40. 431 362-25
f +49.40. 431 362-29
e awahlfeldt@subshell.com


Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

What is the error when you try compile Apache::Request via source tar
ball or via cpan?

MichaelFrom: Leon Sonntag [mailto:leon@iwa-solutions.com]
Posted At: Friday, September 05, 2003 7:40 PM
Posted To: RT
Conversation: [rt-users] RE: Apache and MySQL problems on Install of
3.0.4
Subject: [rt-users] RE: Apache and MySQL problems on Install of 3.0.4

At 12:48 PM 9/5/2003 +0200, Andreas Wahlfeldt wrote:

hi leon,
hi list,

while installing
rt-3-0-5rc1

with
mysql-standard-4.0.14
modperl 1.27

on a
suse8.1 box

i also ran into the problem that Apache::Request and DBD::mysql refused
to
be installed via CPAN.

i could solve it this way:
i downloaded libapreq-1.2.tar.gz (containing Apache::Request ) and
DBD-mysql-2.1028.tar.gz form CPAN.org manually.

i installed (after unpacking :wink: DBD::mysql with the ‘–libs’ option as
CPAN
suggested:
perl Makefile.PL --libs -L/usr/lib/mysql -lmysqlclient -lz -lcrypt
-lnsl -lm

then i installed (as root) libapreq.

→ viola ‘rt-test-dependencies’ stopped complaining.

hope this also works for you (and others).

Well that got me half way there…I think.
I reinstalled mysql from source because I kept getting “Can’t find
mysql+conf”. Then I followed you instructions. Now the only thing the
rt-test-dependencies is Apache::Request. And Yes, I did go ahead and
install libapreg-1.38. I have this feeling that I need to go back and
recompile Apache differently some how but doing it ‘generically’ didn’t
do
the trick either.

Ooohhh welll…next…

cu
andreas


Andreas Wahlfeldt
subshell GmbH
Weidenallee 1
20357 Hamburg

t +49.40. 431 362-25
f +49.40. 431 362-29
e awahlfeldt@subshell.com


Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm