Apache 2/ Mod_perl2/ RT 3.0.7 problem

Hello,

I install RT 3.0.7 in Fedora Core 1, but don't works!
My configuration:
	Apache 2.48
	Mod_perl 1.99
	MySQL 3.23
	Perl 8

Problem: html form method POST (/Elements/Login), don't work. I'm using GET insted.
But the password and user appears in url.
Some suggestion?? 

Thanks,
Tallitha

I would recommend installing mod_fastcgi and utilizing that over
mod_perl… I’m running that under Fedora Core 1, Apache 2.0.48, mysql
4.0.17, perl 5.8.1.

-Rich

I don’t using Apache 2, remember anything about mod_perl 2.0, changed to
Apache 2 …

Check it…

Marco Antonio

Rich West wrote:

Sure!

This is what I did:
o download mod_fastcgi
o uncompress and extract it.
o cd mod_fastcgi-2.4.2
o mv Makefile.AP2 Makefile
o make top_dir-/etc/httpd install
o edit /etc/httpd/conf/httpd.conf and add:

→ In the “LoadModule” section, I added the following line at the end
of the list:
LoadModule fastcgi_module modules/mod_fastcgi.so

→ After the line “AddHandler type-map var”, I added the following lines:

For FastCGI applications

AddHandler fastcgi-script fcg fcgi fpl

FastCgiServer /opt/rt3/bin/mason_handler.fcgi

→ In the Virtual Hosts section, I added the following lines:
ScriptAlias /rt3 /opt/rt3/bin/mason_handler.fcgi/

o Note that, in my situation, I access my rt3 installation via a browser
by pointing to “http://my.site.com/rt3” rather than having a virtual
host dedicated to rt3 (eg: http://rt3.mysite.com). In that case, you
would have “ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/”
o Also note that, with FastCGI, it cannot serve up the images, so you
have to have the images accessible OUTSIDE of your RT tree. This means
that you would have to edit your RT_SiteConfig.pm and
‘Set($WebImagesURL, “<images_url>”’, and then copy the relative images
over to that url. Fortunately, RT is very lightweight on the number of
images. :slight_smile:

Let me know if you have any problems. I would be glad to help!

-Rich

Tallitha Winckelmann de Campos wrote:

Well that explains the ‘scrunched’ image for the header.

Thank you sir!
A.J.From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Rich West
Sent: Tuesday, January 27, 2004 12:41 PM
To: Tallitha Winckelmann de Campos
Cc: rt-users@lists.bestpractical.com; rt-devel@lists.bestpractical.com
Subject: [rt-users] Re: [rt-devel] Apache 2/ Mod_perl2/ RT 3.0.7 problem

Sure!

This is what I did:
o download mod_fastcgi
o uncompress and extract it.
o cd mod_fastcgi-2.4.2
o mv Makefile.AP2 Makefile
o make top_dir-/etc/httpd install
o edit /etc/httpd/conf/httpd.conf and add:

→ In the “LoadModule” section, I added the following line at the end
of the list:
LoadModule fastcgi_module modules/mod_fastcgi.so

→ After the line “AddHandler type-map var”, I added the following lines:

For FastCGI applications

AddHandler fastcgi-script fcg fcgi fpl

FastCgiServer /opt/rt3/bin/mason_handler.fcgi

→ In the Virtual Hosts section, I added the following lines:
ScriptAlias /rt3 /opt/rt3/bin/mason_handler.fcgi/

o Note that, in my situation, I access my rt3 installation via a browser
by pointing to “http://my.site.com/rt3” rather than having a virtual
host dedicated to rt3 (eg: http://rt3.mysite.com). In that case, you
would have “ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/”
o Also note that, with FastCGI, it cannot serve up the images, so you
have to have the images accessible OUTSIDE of your RT tree. This means
that you would have to edit your RT_SiteConfig.pm and
‘Set($WebImagesURL, “<images_url>”’, and then copy the relative images
over to that url. Fortunately, RT is very lightweight on the number of
images. :slight_smile:

Let me know if you have any problems. I would be glad to help!

-Rich

Tallitha Winckelmann de Campos wrote:

Hi Rich,

Could you send me your configuration with mod_fastcgi?
Steps for instalation/ configuration… please?

Thanks for help me,
Tallitha

I would recommend installing mod_fastcgi and utilizing that over
mod_perl… I’m running that under Fedora Core 1, Apache 2.0.48, mysql
4.0.17, perl 5.8.1.

-Rich

Hello,

I install RT 3.0.7 in Fedora Core 1, but don’t works!
My configuration:
Apache 2.48
Mod_perl 1.99
MySQL 3.23
Perl 8

Problem: html form method POST (/Elements/Login), don’t work. I’m
using GET insted.
But the password and user appears in url.
Some suggestion??

Thanks,
Tallitha

rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Just as a quick FYI:

IF you need to have the fastcgiserver directive within a
definition for any reason (ie: I generate my “virtual.conf” file from a
database which allows me to disable all aspects of a particualr virtual
host with the click of a button), then you need to use mod_fastcgi 2.4.0.

-Rich

Rich West wrote:

o Also note that, with FastCGI, it cannot serve up the images, so you
have to have the images accessible OUTSIDE of your RT tree. This means
that you would have to edit your RT_SiteConfig.pm and
‘Set($WebImagesURL, “<images_url>”’, and then copy the relative images
over to that url. Fortunately, RT is very lightweight on the number of
images. :slight_smile:

You can also add
Alias /NoAuth/images /opt/rt3/share/html/NoAuth/images
and not worry about changing the images URL.

Michael
Michael S. Liebman m-liebman@northwestern.edu
http://msl521.freeshell.org/
“I have vision and the rest of the world wears bifocals.”
-Paul Newman in “Butch Cassidy & the Sundance Kid”