Am a little bit lost with setup of RT

Have set up RT before, but i am missing my installation documentation;
nowhere to be seen.

I have RT up and running on IP adress and Port 8080 with the RT Server. What
doesn’t work at all is the Mailinterface. He says, he sends mails, but they
never arrive, also, Mails i send to RT won’t arrive, so i assume there is a
problem on that side.

I am wondering about the settings for Postfix:
rt: "|/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://example.com"
rt-comment: “|/opt/rt4/bin/rt-mailgate --queue general --action comment
–url http://example.com

I gave it a shot with fetchmail, but didn’t succeed there.

My configuration is: The RT Website should be found under
http://www.example.com, although i would like to have https instead, but i
want to have it working first, before i am going to experiment with SSL.

Anybody got a list of packages i need besides the deps, i can fix with make
fixdeps?
Also, how to configure Apache Server? I do not want to have it in a
subdirectory like http://example.com/rt

Perhaps someone could push me in the right direction, please? Tried to find
a complete, and also uptodate installation documentation for Ubuntu 10.04
but haven’t found something real helpful.

Thank you all for help.
Best

j_m
View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33676210.html

Have set up RT before, but i am missing my installation documentation;
nowhere to be seen.

I have RT up and running on IP adress and Port 8080 with the RT Server. What
doesn’t work at all is the Mailinterface. He says, he sends mails, but they
never arrive, also, Mails i send to RT won’t arrive, so i assume there is a
problem on that side.

You’re running on 8080? so you access it as http://example.com:8080 ?
You’re telling mailgate to access it on 80 not 8080.

I am wondering about the settings for Postfix:
rt: “|/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://example.com
rt-comment: “|/opt/rt4/bin/rt-mailgate --queue general --action comment
–url http://example.com

I gave it a shot with fetchmail, but didn’t succeed there.

My configuration is: The RT Website should be found under
http://www.example.com, although i would like to have https instead, but i
want to have it working first, before i am going to experiment with SSL.

Anybody got a list of packages i need besides the deps, i can fix with make
fixdeps?
Also, how to configure Apache Server? I do not want to have it in a
subdirectory like http://example.com/rt

The standard RT documentation in web_deployment.pod describes how to
put it at example.com.

Perhaps someone could push me in the right direction, please? Tried to find
a complete, and also uptodate installation documentation for Ubuntu 10.04
but haven’t found something real helpful.

-kevin

Kevin Falcone-2 wrote:

Have set up RT before, but i am missing my installation documentation;
nowhere to be seen.

I have RT up and running on IP adress and Port 8080 with the RT Server.
What
doesn’t work at all is the Mailinterface. He says, he sends mails, but
they
never arrive, also, Mails i send to RT won’t arrive, so i assume there
is a
problem on that side.

You’re running on 8080? so you access it as http://example.com:8080 ?
You’re telling mailgate to access it on 80 not 8080.

I started the rt server with port 8080 and i can only access it with IP
Adress and port 8080, like http://123.456.789.0:8080, i cannot access it
via http://www.example.com:8080.
I gave it another try by using this setting for apache:

### Optional apache logs for RT ErrorLog /opt/rt4/var/log/apache2.error TransferLog /opt/rt4/var/log/apache2.access LogLevel debug

AddDefaultCharset UTF-8

    DocumentRoot /opt/rt4/share/html
    <Location />
        Order allow,deny
        Allow from all

        SetHandler modperl
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Location>
    <Perl>
        use Plack::Handler::Apache2;
        Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
    </Perl>
</VirtualHost>

But that wouldn’t work either. I still can only connect via IP Adress.

The default configuration is like this:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www

Options FollowSymLinks
AllowOverride None

<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory “/usr/lib/cgi-bin”>
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all

#Include /etc/request-tracker4/apache2-modperl2.conf

ErrorLog /var/log/apache2/error.log

Possible values include: debug, info, notice, warn, error, crit,

alert, emerg.

LogLevel warn

#CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

I am wondering about the settings for Postfix:
rt: “|/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://example.com
rt-comment: “|/opt/rt4/bin/rt-mailgate --queue general --action comment
–url http://example.com

I gave it a shot with fetchmail, but didn’t succeed there.

My configuration is: The RT Website should be found under
http://www.example.com, although i would like to have https instead, but
i
want to have it working first, before i am going to experiment with SSL.

Anybody got a list of packages i need besides the deps, i can fix with
make
fixdeps?
Also, how to configure Apache Server? I do not want to have it in a
subdirectory like http://example.com/rt

The standard RT documentation in web_deployment.pod describes how to
put it at example.com.

Perhaps someone could push me in the right direction, please? Tried to
find
a complete, and also uptodate installation documentation for Ubuntu 10.04
but haven’t found something real helpful.

-kevin

Any idea how to get mailgate running? The Mails are not bounced, but i
receive every 5hrs a mail delayed email.

Thanks for help!
Best

View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33687430.html

Am Sat, 14 Apr 2012 10:12:21 -0700 (PDT)
schrieb who else bogey_63@yahoo.com:

Any idea how to get mailgate running? The Mails are not bounced,
but i receive every 5hrs a mail delayed email.

In my experience, it’s pretty straighforward to get RT running -
provided you do exactly as described in the documentation and (to a
certain degree) know what you are doing.

I admit, I removed the default vhost from apache completely and I ended
up getting this:

(RT 3.8)

ServerName rt3.domain:443 ServerAdmin admin DocumentRoot "/usr/local/rt38/share/html" AddDefaultCharset UTF-8 Options FollowSymLinks AllowOverride None Order Allow,Deny Allow from all PerlModule Apache::DBI PerlRequire /usr/local/rt38/bin/webmux.pl SetHandler perl-script PerlHandler RT::Mason ErrorLog /var/log/apache/rt3-httpd-error.log TransferLog /var/log/apache/rt3-httpd-access.log SSLEngine on SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL SSLCertificateFile /usr/local/etc/apache22/ssl.rt3/server.crt SSLCertificateKeyFile /usr/local/etc/apache22/ssl.rt3/server.key SSLOptions +StdEnvVars SSLOptions +StdEnvVars BrowserMatch ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0 CustomLog /var/log/httpd-ssl_request.log \ "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

I’ve only installed RT4 in a VM, but the basic apache config is similar,
IIRC.

Personally, I found fetchmail the easiest to get to run, at the price
of inflexibility (you need to define every queue in the
fetchmail-config, which may or may not be what you want):

#Template

Queue: QUEUE_NAME

poll your.pop3.server proto pop3:
username QUEUE_NAME password PASSWORD mda
“/usr/bin/perl /usr/local/rt38/bin/rt-mailgate --url
https://rt3.domain/ --queue QUEUE_NAME --action correspond”
poll your.pop3.server proto pop3:
username QUEUE_NAME-comment password PASSWORD mda
“/usr/bin/perl /usr/local/rt38/bin/rt-mailgate --url
https://rt3.domain/ --queue QUEUE_NAME --action comment”

Obviously, your usernames might be different from your queue-names.

All that pulled from the wiki and the mailing-list, back in 2005…

I also admit, I run qmail on the rt3-server - because that’s the only
MTA that I really understand :wink:

Rainer

Any idea how to get mailgate running? The Mails are not bounced, but i
receive every 5hrs a mail delayed email.

What’s in your mail logs.
What’s in your RT logs.

Also, you didn’t reply to my earlier note that you’re running RT on
one port and connecting rt-mailgate to another port.

-kevin

Kevin Falcone-2 wrote:

Any idea how to get mailgate running? The Mails are not bounced, but i
receive every 5hrs a mail delayed email.

What’s in your mail logs.
What’s in your RT logs.

Also, you didn’t reply to my earlier note that you’re running RT on
one port and connecting rt-mailgate to another port.

-kevin

Hi Kevin,
i was trying some other suggestions, so i can now give an update:

There are two logfiles in /opt/rt4/var/logs; these contain only zlib
messages and failed logins; i received a bunch of connection timed out
emails, of my test mails.

Mail logs contain entries like:

mail.info:
connect from
disconnect from
lost connection from

On the domain side:

I started the rt server with port 8080 and i can only access it with IP
Adress and port 8080, like http://123.456.789.0:8080, i cannot access it via
http://www.example.com:8080.
I gave it another try by using this setting for apache:

### Optional apache logs for RT ErrorLog /opt/rt4/var/log/apache2.error TransferLog /opt/rt4/var/log/apache2.access LogLevel debug

AddDefaultCharset UTF-8

    DocumentRoot /opt/rt4/share/html
    <Location />
        Order allow,deny
        Allow from all

        SetHandler modperl
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Location>
    <Perl>
        use Plack::Handler::Apache2;
        Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
    </Perl>
</VirtualHost>

But that wouldn’t work either. I still can only connect via IP Adress.

The default configuration is like this:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

#Include /etc/request-tracker4/apache2-modperl2.conf


ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

#CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

Best
w_e
View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33705772.html

The mailproblem is the one with higher priority, what i do not catch up with
is:

  1. How to get Postfix to work with rt-mailgate
  2. Otherwise how to get fetchmail/Postfix working with rt-mailgate:

oll mail.help-me-do.it
protocol pop3
username “general@example.com” password “noneiknowof”
mda “/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://www.example.com
no keep

poll mail.help-me-do.it
protocol pop3
username “general-comment@example.com” password “noneiknowof”
mda “/opt/rt4/bin/rt-mailgate --queue general --action comment --url
http://www.example.com

What confuses me:

  1. What do i enter at the url part? Since i can only access the RT Instance
    via the IP Address, i am not sure.
  2. I need to enter a username in the fetchmailrc config file; and a
    password. Do i need to create this mailbox somewhere else or is this the
    mailbox itself, which is created and i can use any password i want to?

I really appreciate your help. Thanks.
w_e

View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33710033.html

The mailproblem is the one with higher priority, what i do not catch up with
is:

  1. How to get Postfix to work with rt-mailgate

http://requesttracker.wikia.com/wiki/ManualEmailConfig
?

  1. Otherwise how to get fetchmail/Postfix working with rt-mailgate:

oll mail.help-me-do.it
protocol pop3
username “general@example.com” password “noneiknowof”
mda “/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://www.example.com
no keep

poll mail.help-me-do.it
protocol pop3
username “general-comment@example.com” password “noneiknowof”
mda “/opt/rt4/bin/rt-mailgate --queue general --action comment --url
http://www.example.com

What confuses me:

  1. What do i enter at the url part? Since i can only access the RT Instance
    via the IP Address, i am not sure.

The URL is the URL of your RT-install.
That includes the TCP-ports.
IP or DNS-name is irrelevant.

  1. I need to enter a username in the fetchmailrc config file; and a
    password. Do i need to create this mailbox somewhere else or is this the
    mailbox itself, which is created and i can use any password i want to?

I really appreciate your help. Thanks.
w_e

You can run fetchmail on the shell with more verbose output and see how it works.

Where is your mail hosted?
I assume, you don’t run RT on your mailserver, right?
The mailboxes (you need two) are on your mailserver.
The mailserver is the server that is recorded in your MX record.
If you had told us your real domain, we could look it up and tell you its IP-address…

I would really suggest you ask BestPractical or someone else for an onsite install.

Rainer

Rainer Duffner wrote:

Where is your mail hosted?
I assume, you don’t run RT on your mailserver, right?
The mailboxes (you need two) are on your mailserver.
The mailserver is the server that is recorded in your MX record.
If you had told us your real domain, we could look it up and tell you its
IP-address…

I would really suggest you ask BestPractical or someone else for an onsite
install.

Rainer

Hi Rainer,
RT is running on the same machine as the mailserver. While RT should be on
the domain example.com; the mailserver is on the subdomain mail.example.com;
both point to the same IP.
I have had it up and running end of last year, but my provider closed down
unexpectedly and i am missing my install docs, unfortunately, otherwise i
wouldn’t have needed to ask questions here… I am wondering if i am
missing something obvious; like some package or so. That’s why i was asking
for a current install doc, to be able to compare, where i might have made a
mistake.

The ManualEmailConfig says: The mail gateway requires the web UI to be set
up and functional.
Well, i cannot login by using: http://example.com but with http://

I will setup everything one more time. :frowning:
Best

View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33712078.html

PS: Perhaps i made a mistake in the first place.
Since i want RT to respond to http://www.example.com and the mailserver is
mail.example.com, what would be acceptable as hostname? www.example.com ?
Should i configure postfix with IP or with mail.example.com? Emails are
being sent, but the replies are hanging around until they come backwith a
timeout.
Besides all the fixdeps; Postfix, Apache2, optional fetchmail, MySQL, am i
missing something else?

Do i need fetchmail or is it fine just to run postfix? I added this lines to
aliases and executed newaliases, of course.

rt: “|/opt/rt4/bin/rt-mailgate --queue general --action correspond --url
http://example.com

rt-comment: “|/opt/rt4/bin/rt-mailgate --queue general --action comment
–url http://example.com

But no emails keep coming in, whether i run fetchmail and postfix or just
postfix alone.

w_e
View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33712147.html

Ok,
i gave it another shot with the following settings:
Domain is: support.example.com
Mailserver is: mail.example.com
hostname is: support.example.com
hosts is: support.example.com example.com
webpath is: /rt

Given that, i set up a new Debian Squeeze Server, installed Apache2, MySQL
and Postfix.
Configure Mysql with a password and Postfix with mailserverdomain,
Internetsite and confirm any other given question with the preferences
shown.

Then i added this to /etc/apt/sources.list:

deb http://backports.debian.org/debian-backports squeeze-backports main

Then save and enter

aptitude update

Next is:
apt-get install rt4-db-mysql
apt-get install rt4-apache2
apt-get install request-tracker4

But beware: the last command will tell you , that there are some packages
needed, with newer version than squeeze can provide. So DO NOT ENTER YES,
but enter no.
Next you will see a List of 20 or more packages. Enter y(es) here, and it
will install without any problem each and every package for Request Tracker.

Checkout, which configuration in /etc/request-tracker4 fits your needs. I
was opting for ModPerl2, so mine was apache2-modperl2.conf, which i copied
to /etc/apache2/sites-available.
Then i changed into /etc/apache2/sites-enabled and did a

ln -s /etc/apache2/sites-available/apache2-modperl2.conf

I also enabled the line

AddDefaultCharset UTF-8

in the file apache2-modperl2.conf

Next is, open /etc/apache2/sites-available/default and add this line just
bevor </virtual host>:

Include /etc/request-tracker4/apache2-modperl2.conf

Then:
/etc/init.d/apache2 restart

For Postfix you have to update your aliases file:

rt: “|/usr/bin/rt-mailgate --queue general --action correspond --url
http://localhost/rt

rt-comment: “|/usr/bin/rt-mailgate --queue general --action comment --url
http://localhost/rt

Then do a:

newaliases

I also restarted Postfix, just to be sure (/etc/init.d/postfix restart)

Finally i did the following:

Set (WebPath , “/rt”);

in /etc/request-tracker4/RT_SiteConfig.pm

And that was it.

The only thing i didn’t catch, was:

  • Which hostname and hosts entry to use in order to have RT respond to
    example.com or www.example.com
  • Which settings i else needed for this.

So then, it is working now, i have to setup tons of rights and queues and
stuff.

Thank you all
Best
w_e
View this message in context: http://old.nabble.com/Am-a-little-bit-lost-with-setup-of-RT-tp33676210p33713421.html