About to give up on RT!

Here’s my situation, I have MySql, Apache and RT
successfully installed and ready to go but I can’t get
RT’s web interface up and going. When I go to
localhost.localdomain, I get the default apache
webserver test page. Can anyone PLEASE help me out and
take a look at my httpd.conf file and advise for any
errors or mishaps. I will gladly give any informaiton
you would like. I have attached it below. Thanks you
so much in advance.

<VirtualHost 192.168.148.100>
ServerName localhost.localdomain
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
                                                  
                  
<Location>
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/

I presume that you have DNS set up so that localhost.localdomain
resolves to 192.168.148.100. If not, do so – or fix the ServerName
directive to have the real name that you use.

One other possible problem is that your directive does not
have a path; I think you have to say:
instead.

There are many ways to do this, but I suspect apache doesn’t know to
send the requests to the virtualhost. You didn’t give us the rest of
the info, but here’s one way to do it:

Put this:

NameVirtualHost *:80

just above (outside) the stanza.

Start the stanza like this:

<VirtualHost *:80> instead of naming the IP address.

If you do the above, then all requests to port 80 will go to that
VirtualHost stanza; if you’re not using apache for anything else then
that is what you want.

Threatening to stop using a software product isn’t going to get you any
friends on a high traffic volunteer support mailing list. Consider
hiring a consultant.

Here’s my situation, I have MySql, Apache and RT
successfully installed and ready to go but I can’t get
RT’s web interface up and going. When I go to
localhost.localdomain, I get the default apache
webserver test page.

As you assume, it’s probably your http.conf

Can anyone PLEASE help me out and take a look at my httpd.conf file
and advise for any errors or mishaps.

VirtualHost seems slightly suspect. Are you using them? Have you read
the apache docs? What about the RT docs? Did you stop and start
apache?

seph

I don’t mean to threaten, its just that I am very frustrated at this point and don’t know what to do next.

friends on a high traffic volunteer support mailing list. Consider
hiring a consultant.

Here’s my situation, I have MySql, Apache and RT
successfully installed and ready to go but I can’t get
RT’s web interface up and going. When I go to
localhost.localdomain, I get the default apache
webserver test page.

As you assume, it’s probably your http.conf

Can anyone PLEASE help me out and take a look at my httpd.conf file
and advise for any errors or mishaps.

VirtualHost seems slightly suspect. Are you using them? Have you read
the apache docs? What about the RT docs? Did you stop and start
apache?

seph

Do you Yahoo!?
Free Pop-Up Blocker - Get it now

Had the SAME situation (AND Frustration!!!) My fix was not pretty but it
works…
Be forewarned !!! It affects ALL websites on that server. I found
documentation that says if you are running modperl2 (Called modperl199) you
need to use the following:

RedirectMatch permanent (.*)/$ http://hostname.domain$1/index.html

I put this at the end of my virtualhost defination in httpd.conf.

By the way, If any body knows a way to get this to work without directing
ALL requests, I sure would like to know about it. It would be nice to use
this for other websites too.

At 01:13 PM 11/21/03, you wrote:

Here’s my situation, I have MySql, Apache and RT
successfully installed and ready to go but I can’t get
RT’s web interface up and going. When I go to
localhost.localdomain, I get the default apache
webserver test page. Can anyone PLEASE help me out and
take a look at my httpd.conf file and advise for any
errors or mishaps. I will gladly give any informaiton
you would like. I have attached it below. Thanks you
so much in advance.

<VirtualHost 192.168.148.100>
ServerName localhost.localdomain
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl


<Location>
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Most anything is easy after you’ve done it successfully a few times

Leon Sonntag
Innovative Web Applications
leon at iwa-solutions dot com

Does this machine have a real hostname? Why not enter
that in the ServerName entry below?
I suspect strange things are happening because you’re
trying to web to localhost. Can you try changing
localhost.localdomain to the value in $rtname in your
/opt/rtX/etc/config.pm file?

Then, of course, stop/start httpd.

<VirtualHost 192.168.148.100>
ServerName localhost.localdomain
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
                                                

                  
<Location>
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/

I don’t mean this in a condescending way at all, especially since this one
got me for about 3 hours myself:

Did you restart Apache?From: Joseph Spenner [mailto:joseph85750@yahoo.com]
Sent: Friday, November 21, 2003 4:43 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] About to give up on RT!!

Does this machine have a real hostname? Why not enter
that in the ServerName entry below?
I suspect strange things are happening because you’re
trying to web to localhost. Can you try changing
localhost.localdomain to the value in $rtname in your
/opt/rtX/etc/config.pm file?

Then, of course, stop/start httpd.

<VirtualHost 192.168.148.100>
ServerName localhost.localdomain
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
                                                

                  
<Location>
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Leon Sonntag wrote:

Had the SAME situation (AND Frustration!!!) My fix was not pretty
but it works…
Be forewarned !!! It affects ALL websites on that server. I found
documentation that says if you are running modperl2 (Called
modperl199) you need to use the following:

RedirectMatch permanent (.*)/$ http://hostname.domain$1/index.html

I put this at the end of my virtualhost defination in httpd.conf.

By the way, If any body knows a way to get this to work without
directing ALL requests, I sure would like to know about it. It would
be nice to use this for other websites too.

Here is my httpd configuration.

I have avoided using RedirectMatch by not only applying “SetHandler
perl-script” (which seems to be what blocks the usual DirectoryIndex
behaviour) to html files, and those specific directories which need it.

Max.

-----------------begin----------------------
Alias /rt /opt/rt3/share/html
PerlModule Apache2 Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
Options All
AllowOverride All
AddDefaultCharset UTF-8
<Files *.html>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/Ticket/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/SelfService/Attachment>
SetHandler perl-script
PerlHandler RT::Mason

<Directory /opt/rt3/share/html/REST>
SetHandler perl-script
PerlHandler RT::Mason

-----------------end---------------------------

Matthew Kasa wrote:

Here’s my situation, I have MySql, Apache and RT
successfully installed and ready to go but I can’t get
RT’s web interface up and going. When I go to
localhost.localdomain, I get the default apache
webserver test page. Can anyone PLEASE help me out and
take a look at my httpd.conf file and advise for any
errors or mishaps. I will gladly give any informaiton
you would like. I have attached it below. Thanks you
so much in advance.

You have to parts of apache conf: main server and virtual hosts.
By default after installation “main server” point to installed apache
documentation.
So if you want to serve only RT under this machine then you can change
"main server" configuration.
If really want VHost so there is several ways:

  1. IP based
  2. Port based
  3. Name based
  4. Hybrid…
    All about it here http://httpd.apache.org in separate article about
    Virtual Hosts.

For me easiest way is port based VHosts on machine with static IP for
test suit server and IP based for production server.

You trying to use Named VHosts, so you should add

NameVirtualHost 192.168.148.100

<VirtualHost 192.168.148.100>
ServerName localhost.localdomain
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
                                                  
                  
<Location>
   SetHandler perl-script
   PerlHandler RT::Mason
</Location>

Then restart apache. And try it. Look at logs access and error for more
info.

	Best regards. Ruslan.